ESX VM unable to gain internet access

Hi Guru's,

Hope you can help.

Here's the run down:
SBS 2011 (Physical server)

Used VConvert to convert to our ESX server (approx 900GB in size) - This took about 20 hours on a 1Gbps, maybe you have some advise there to reduce the convert time? (We have disabled SSL in VConvert already)

VM is now on our ESX server. Powered down physical server, powered up VM.

Confirmed LAN IP is correct and only one NIC showing (this might be part of the issue as the physical server showed 2 nics in Windows, one being the LAN card, the other the iLO) - There was also a nubmer of HP utilities (one of with was a NIC utility in the sys tray). I've since removed these on the VM to try and fix the issue.

IP: 192.168.254.6
Sub: 255.255.255.0
GW: 192.168.254.1
DNS1: 127.0.0.1 (also tried 192.168.254.6)
DNS2: 8.8.8.8

DNS is installed on the windows sbs vm, it shows the interface correctly as the LAN card (both IPv4 and IPv6 listed, even though we're not usingg IPv6, but I cant see this will cause an issue).

WHAT WE'VE TRIED:
=================
If I do a ping of say bbc.co.uk it comes back with the IP but shows "timed out".
Running the SBS "Connect to the intrnet" wizard, this fails with "unable to find your router. We also CANNOT get to our router from the VM.
Fix My Network wizard also fails telling us we need to run the "Connect to the internet" wizard.
Pinging other devices on the LAN (outside of the ESX host) - e.g. a printer or another physical server - THIS WORKS.
Removed the NIC from vmware Vsphere and re-added.
Access a share on the VM from another computer (\\SERVERNAME\DATA) - THIS WORKS.

I belive the biggest issue here is the VM cannot see the rotuer on 192.168.254.1

Hope you can help!

Thanks.

Leigh.
ProtecITAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Benjamin Van DitmarsSr Network EngineerCommented:
please add second network card in same network. and see if the sbs machine likes this.
ProtecITAuthor Commented:
Will give it a go out of hours tonight.

I thought sbs 2003 supported 2 nics and sbs 2011 only 1 Nic?
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Check you have removed the hidden devices and phantom network cards, because this can cause issues with the default gateway.

if you ping 158.152.1.222 is it reachable ?

if you tracert to 158.152.1.222, does it resolve to

demon-du.demon.co.uk

if you ping

demon-du.demon.co.uk

does it resolve to 158.152.1.222 ?

also make sure you are using the VMXNET3 interface, and have VMware Tools installed before you use this interface.
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

ProtecITAuthor Commented:
Hi Andrew,

Sounds advise as always, will give it a go tonight. I suspect the HP NIC utlilities are messing things around, or the VConvert copy has only brought over the nic that is was showing as the iLO and not the LAN card.

Will ping back answers later tonight when I can down the PROD server and spin this VM back up as the LAN IP's are the same.
ProtecITAuthor Commented:
Andrew - (see pic) This NIC is currently on E1000 but I do have the option of added a new card with either VMXNET2 and 3.

any mileage in the 2 NIC's idea posted above? I thought SBS 2011 only liked 1 NIC?
CCDB02-VM.jpg
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
You should REMOVE ALL the VENDOR software on the physical server before your P2V!

VMware Converter, will not detect the iLo, interface, and it's up to the user how many NICs you add in the process!

Also be careful bringing up and Live Physical and VM, make sure the VM is disconnected, otherwise you could experience domain issues!

DO NOT USE E1000 NICs! They are only there for legacy installations!

replace with VMXNET3.

and get rid of those hidden devices.

see this blog entry...

http://blog.mpecsinc.ca/2008/02/sbs-shadowprotect-some-hardware.html
ProtecITAuthor Commented:
Thanks Andrew, will try tonight.

Yes no problem we have iLO3 on the Physical server so will power that down before brining the VM online to avoid any conflicts.

Regards,

Leigh.
ProtecITAuthor Commented:
Ok, so physical server down. VM Powered up.

Have removed all HP utilities and agents etc (no server reboot as yet).

I've added the VMXNET3 card. Set as follows:
IP: 192.168.254.6
Sub: 255.255.255.0
GW: 192.168.254.1
DNS1: 127.0.0.1
DNS2: 0.0.0.0

I'm still unable to ping the router (192.168.254.1) or browse the internet from within the VM.

Will try a power cycle on the VM.

DNS on the server itself has the IP showing in "Interfaces", do I need to repoint \ bind DNS somehow to the new VMXNET3 adapter?

Just disabling DHPC on the router and running the "Internet Connection Wiz" within the SBS console to see if that kicks things into action.
ProtecITAuthor Commented:
SBS Internet Connection Wiz still failing within "Cannot find the router on your network" enter after entering 192.168.254.1 in the wizard.

Am I missing something here within ESX on the HOST that's maybe blocking this traffic out to the router?

Router is a Draytek 2820n, I've cycled it since downing the physical instance of the server to ensure it drops any cache for routing etc.

Running out of ideas!
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Did you remove ALL the Hidden Devices, and phantom adaptors ?
ProtecITAuthor Commented:
Here's device manager, unless it's Virtual clone driver causing an issue I cant see anything else.

The VM can be pinged from other devices on the LAN, the VM can ping other devices on the LAN. It just cant see the router to get out.

As we're powering down the Physical unit and bringing up the Virtual one do you think the ARP cache on the router (or somewhere else) might be storing the old details of the physical server and thus not allowing the traffic to pass out of the router?
DeviceMngr.png
ProtecITAuthor Commented:
How to I find the hidden devices?
ProtecITAuthor Commented:
Ok,basically I'm getting these guys issue. When SBS 2011 VM LAN card is set to obtain by DHCP (and DHCP is issued by the router) then I CAN - Ping the router 254.1 and also get internet access.

When I set the server with a static IP address - CAN'T PING router or get internet access.
ProtecITAuthor Commented:
I've just jumped on the router to check it's ARP table. It has an entry for the physical server along with the MAC address, this is not the same MAC add the VM is using for it's VMXNET3 nic.

I'll clear the ARP cache on the router and see if it fixes it.
ProtecITAuthor Commented:
Right I've finally work it out!

DHCP on the router had a reservation for the server IP against it's MAC address. Once the server had been through the P2V process it changes the MAC address.

Removed the entry in DHCP for the reservation and hey presto! All working.

Thanks for the pointers everyone.

L

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ProtecITAuthor Commented:
Worked out it was a DHCP reservation on the router.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.