Event ID 1004 — IPMI Driver Functionality - Windows 2012 STD

Event ID 1004 — IPMI Driver Functionality

Source: IPMIDRV
Type: Error
Description:
The IPMI device driver attempted to communicate with the IPMI BMC device during normal operation. However the communication failed due to a timeout. You can increase the timeouts associated with the IPMI device driver.

My server spec.
Dell R630 controller Perc 730P - Windows 2012 STD

- OS:: 3x 300GB 15K: Raid and 1 drive configured as a hotpsare
- Storage for VM (SQL 2014):: 7x 500GB SSD RAID 50 and 1x drive configured as a hotspare.

There is no error on System devices node and locate Microsoft Generic IPMI Compliant Device.


Please advice.

Thank you.
SQ1ResourcesAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

andyalderSaggar maker's framemakerCommented:
Could you run racadm getsysinfo and post the output so we can see if the iDRAC7 firmware is up to date please.
SQ1ResourcesAuthor Commented:
I have latest firmware for all servers components. Just updated 2 month ago.

racadm getsysinfo  result below:

Please advice.

Thanks


RAC Information:
RAC Date/Time           = Tue Nov 17 14:55:51 2015

Firmware Version        = 2.15.10.10
Firmware Build          = 08
Last Firmware Update    = 09/23/2015 14:15:32
Hardware Version        = 0.01
MAC Address             = 74:E6:E2:FA:25:FE

Common settings:
Register DNS RAC Name   = 0
DNS RAC Name            = idrac
Current DNS Domain      =
Domain Name from DHCP   = Disabled

IPv4 settings:
Enabled                 = 1
Current IP Address      = xxx
Current IP Gateway      = xxx
Current IP Netmask      = xxx
DHCP Enabled            = 0
Current DNS Server 1    = 0.0.0.0
Current DNS Server 2    = 0.0.0.0
DNS Servers from DHCP   = Disabled

IPv6 settings:
Enabled                 = 0
Current IP Address 1    = ::
Current IP Gateway      = ::
Autoconfig              = 1
Link Local IP Address   = ::
Current IP Address 2    = ::
Current IP Address 3    = ::
Current IP Address 4    = ::
Current IP Address 5    = ::
Current IP Address 6    = ::
Current IP Address 7    = ::
Current IP Address 8    = ::
Current IP Address 9    = ::
Current IP Address 10   = ::
Current IP Address 11   = ::
Current IP Address 12   = ::
Current IP Address 13   = ::
Current IP Address 14   = ::
Current IP Address 15   = ::
DNS Servers from DHCPv6 = Disabled
Current DNS Server 1    = ::
Current DNS Server 2    = ::

System Information:
System Model            = PowerEdge R630
System Revision         = I
System BIOS Version     = 1.3.6
Service Tag             = xxx
Express Svc Code        = xxx
Host Name               = SQLHV1
OS Name                 = Microsoft Windows Server 2012 R2, Standard x64 Edition

OS Version              = 6.3
Power Status            = ON
Fresh Air Capable       = Yes

Watchdog Information:
Recovery Action         = None
Present countdown value = 474 seconds
Initial countdown value = 480 seconds

Embedded NIC MAC Addresses:
NIC.Integrated.1-1-1    Ethernet                = B8:2A:72:D0:B9:C8
NIC.Integrated.1-2-1    Ethernet                = B8:2A:72:D0:B9:C9
NIC.Integrated.1-3-1    Ethernet                = B8:2A:72:D0:B9:CA
NIC.Integrated.1-4-1    Ethernet                = B8:2A:72:D0:B9:CB
andyalderSaggar maker's framemakerCommented:
Maybe you just need to increase HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\HardwareManagement\IPMI\IpmbWaitTimeoutPeriod and CommandWaitTimeoutPeriod by 50% or so in the registry to increase the length of time it waits for response from the drac/BMC.
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

SQ1ResourcesAuthor Commented:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\HardwareManagement\IPMI\IpmbWaitTimeoutPeriod and CommandWaitTimeoutPeriod
is not present in Windows 2012 R2 STD.

The registry location I found below:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\IPMI


Current config below:

IpmbWaitTimeoutPeriod - Value data is: 1e8480
and
CommandWaitTimeoutPeriod - Value data is: 4c4b40

Can you please let me know how I can change IpmbWaitTimeoutPeriod and CommandWaitTimeoutPeriod by 50%

Thank you
andyalderSaggar maker's framemakerCommented:
Set IpmbWaitTimeoutPeriod to 2DC620 and CommandWaitTimeoutPeriod to 7270E0 would be 50% more, use registry editor to set those values to that.
SQ1ResourcesAuthor Commented:
I have set to 50% and still the same same problem.

Any idea
andyalderSaggar maker's framemakerCommented:
It's probably a problem with the iDRAC driver, I'd check with Dell support to see if there's a new one that fixes the problem since they had the same problem with previous versions.
SQ1ResourcesAuthor Commented:
Just spoken with Dell Support and Dell just released new Firmware Version 2.21.21.21, A00 on 9 November 2015.

Fixes & Enhancements
Fixes

- In rare instances, iDRAC8 may lose connectivity with an internal memory component without generating any alert or log entry.

- This release includes fixes for security vulnerabilities that have the potential for users to be able to execute a number of iDRAC system management operations without requiring any user authentication.

- Lifecycle Controller is disabled during internal NDC communication.

- On certain 12th generation of PowerEdge servers, F1 keyboard error messages are reported.

- IPMI Serial Over LAN (SOL) issues observed on systems with iDRAC version 2.20.20.20.

- Negative CPU temperature values are reported in the OpenManage Server Administrator console.

- On Dell PowerVault MD3xxx series, incorrect hard-disk predictive failures occur from iDRAC.

- While creating virtual disks using RAID 10, the virtual disks display an incorrect size.




I will schedule maintenance next week and I will let you know the status.

Thank for support
SQ1ResourcesAuthor Commented:
No luck still the same error in event log
SQ1ResourcesAuthor Commented:
Dell support confirmed that I dont have to worried about these errors. Could be simple bug . Waiting for new Idrac firmware.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SQ1ResourcesAuthor Commented:
Waiting for new firmware
keystonetechCommented:
Any news on this thread?  I have a T620 with the same issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.