Personal Cloud - Port Forwarding

Hi Experts

Where I'm living, the walls are strong, therefore I decided to move the D-Link DWR-555 3G outside the house with wireless disabled and configured with 192.168.210.200, and brought a TP-Link TL-MR3420 inside the house with wireless enabled and configured as 192.168.150.10, connected them with Ethernet cable (from port 1 to wan port), and everything works great so far.

After, I installed the Iomega ix4-200d Cloud Edition on the inside router, and tried to setup a personal cloud. I registered with LenovoEMC. However the Storage Manager of the NAS keeps saying that router needs to be configured for port forwarding. So how could I do that ? And which router that needs to be configured ? Many thanks in advance.
Faraj1969System AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jmcgOwnerCommented:
It looks like you configured your external router and your internal AP to be  different subnets. Perhaps you had a reason for this, but it seems like a needless complication.

For your personal cloud to be accessible from the internet when you're out of the house, a port forwarding has to be set up to permit this access. It very well may be that you need to set this up for both the external router and for the internal AP, depending on whether both are doing NAT.

But perhaps I'm misunderstanding what your setup is and what you're trying to do. Do you have static addresses or DHCP lease reservations set up for the NAS device?
0
Faraj1969System AdministratorAuthor Commented:
Hi Jmcg.
Yes it's maybe a needless complication, and I would definitely change the configuration if it helps to resolve the issue.

The internal router have DHCP on it, and an IP reserved for the NAS.
0
Faraj1969System AdministratorAuthor Commented:
OK, guess I solved it and the credit goes to you Jmcg.

I configured the outside router to forward port 50500 to the internal AP IP 192.168.150.10, and configured the internal AP to forward port 50500 to the NAS IP, and the error message went off.

Many thanks mate.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Faraj1969System AdministratorAuthor Commented:
Sorry,  I thought it's solved, but it's not, any more ideas ?
0
jmcgOwnerCommented:
You have port forwarding in place, but what about firewall settings?
0
Faraj1969System AdministratorAuthor Commented:
I've checked on both routers, no role to prohibit access, I've also added an inbound TCP & UDP to my workstation windows 10 firewall. When I use a public service to test port 50500, its still unseen.
0
jmcgOwnerCommented:
Can you compare an attempt to contact port 50500 from inside your network with and attempt from outside?

Alternatively, can you see that you have a process listening on 50500?
0
Faraj1969System AdministratorAuthor Commented:
Sorry, this is where I'm lost. how to test from inside the network ? Is there a utility that could do that ?
0
jmcgOwnerCommented:
Well, I'm at a bit of a loss, too, since I know very little about your personal cloud device.

For instance, I am guessing that you set up port forwarding for port 50500 because you know that's the port your device will be listening on, either because that's a port number you were able to tell it in its configuration or that its documentation told you was the port it would like to use.

For things to work, some program has to request a connection on that port. For testing, at least with some protocols, you can do that with telnet or ssh to attempt a connection. If the connection succeeds, then you can bet that there's a program listening. If it fails, then that might be because there is no listener - which leads you down one branch of the troubleshooting tree - or it could be because of some other barrier such as needing a special protocol or secret knocks or some such to successfully make a connection.

If you have an app that speaks to your cloud device, you could use that to attempt a connection, both on your local network and from the outside. If it acts the same way in both situations, we know that we probably have to find out why you don't have a listener or why that listener isn't responding. If it works on the local network but not from outside, then we know that it's likely to be a routing problem and not a problem with the listener.
0
jmcgOwnerCommented:
According to this forum question at Lenovo's community self-help site:
Iomega ix4-200d Cloud Edition port forwarding [forums.lenovo.com]
there are quite a few ports that you need to arrange to be forwarded to:
TCP ->80
TCP - > 443
TCP -> 50500-50599
UDP-> 50500-50599

Open in new window

Those are the destination ports. You could presumably choose different port numbers -- and almost certainly would want to choose different external port numbers to forward for 80 (http) and 443 (https) -- if you decide to allow access to them from outside.
0
Faraj1969System AdministratorAuthor Commented:
Well, no matter what I do, it's not working, either I don't know how to set it up, or maybe the ISP have blocked those ports, so basically I gave up.

Many thanks for your efforts and responses. I'll close the question shortly.
0
jmcgOwnerCommented:
I'm sorry to hear that. Maybe it's time to find a knowledgeable friend who can come over and take a look at your setup?

ISPs have been known to block ports that are considered to be used for servers, i.e. 25, 80, 443, and so on. So I can't rule that out.

But when the warning went away after you added the forwarding for 50500 to both routers, that sure looks like you were on the right track and that port number was not being blocked.
0
Faraj1969System AdministratorAuthor Commented:
OK Jmcg, one last try before I give up, (your response was encouraging).

I've changed the setup a little:

Outside Router:
type: DWR-555
LAN IP: 192.168.200.10
No DHCP
No wireless.

Inside Router:
type TL-MR3420
WAN IP: 192.168.200.20 (static)
LAN IP: 192.168.210.30  (it didn't accept WAN and LAN subnet to be the same)
DHCP enabled 100-199
Wireless enabled.

StoreCenter NAS:
type: i4x-200d
IP: 192.168.210.50 (reserved in DHCP)
Connected to the inside Router.

Maybe this would shed more light on the setup ?
0
jmcgOwnerCommented:
That looks like it should be okay. What more can you say about the failure?
0
jmcgOwnerCommented:
(it didn't accept WAN and LAN subnet to be the same)
I think if you plugged the cable from the external router into one of the internal router's normal switch ports (not the WAN port), you could all be on the same subnet. Just ignore the WAN settings for the internal router.
0
Faraj1969System AdministratorAuthor Commented:
OK, to be totally honest, I really appreciate your patience and dedication in solving the problem, and I'm in a remote area, so constant internet access is not an option, therefore I apologies for the delay in responding.

I've done what you suggested, and now all of them on the same subnet 192.168.200.xxx, it's working fine since I'm able to access the internet (when it's available) from my workstation (hp laptop win 10). Also I've attached 3 images of the settings, hoping it would shed more light. The NAS is connected to the router inside (TL-MR3420).
i4x-200d---192.168.200.50.png
DWR-555---192.168.200.10.png
TL-MR3420---192.168.200.20.png
0
jmcgOwnerCommented:
So now, only the external router needs port forwarding. And it looks like you have that set correctly. But the NAS is still complaining that the internet can't reach it?

Can your HP PC talk to the NAS?
0
Faraj1969System AdministratorAuthor Commented:
Yes, it talks to it, I can browse folders, files, add, delete, and I'm sending this message from an Android device on the same subnet, and I can browse photos on the NAS from it.
0
jmcgOwnerCommented:
There's no mention of the SMB/CIFS port, so are you doing this through a browser? through an app?
0
Faraj1969System AdministratorAuthor Commented:
Sorry, SMB/CIFS port ? That's something new to my little brain, I'll try to dig it up online and check it.
0
Faraj1969System AdministratorAuthor Commented:
lol, the name confused me, on android I use the browser, on the laptop, it's the browser and also LenovoEMC app which creates Shared Drives.
0
jmcgOwnerCommented:
Sorry, SMB is the "old" name and CIFS is Microsoft's "new" name and I don't know the port numbers off the top of my head. It's the Microsoft file sharing protocol.

Right. So we may need to create a port forward for a browser to use from outside. Probably best if it's not port 443 and definitely not port 80. But then I'm not sure what the port 50500 is for but I'm guessing the LenovoEMC app may want to use it.

Do you have a static external IP or a dynamic DNS name set up? External access, even with the forwarded ports, isn't going to be easy without one of those.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Faraj1969System AdministratorAuthor Commented:
I guess both are not an option since it requires communication with the ISP. So somehow I'm convinced my problem mainly with them and it's time for an alternative.

Many thanks mate.
0
Faraj1969System AdministratorAuthor Commented:
Many thanks mate, for all the efforts you extended, and for enriching my knowledge.
0
jmcgOwnerCommented:
Dynamic DNS does not require any particular cooperation from your ISP. If you're willing to accept one of the names offered as a subnet of the DDNS provider, you don't even need to register a domain.

I've used Dynu.com so far, with results that mostly meet my expectations. There are several other providers who offer free DDNS services, so this need not cost you any money, but it would require some learning to set it up. Some routers have a DDNS setup built-in which makes it pretty easy if you use one of the providers supported in the firmware.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.