SCCM to install Rights Management Sharing Application

I have been advertising and successfully installing applications with my SCCM 2007 machine for 3 to 4 years now.
I have come to one application that I cannot seem to get installed for some reason or another.

There are silent install switches and the application has to be run with elevated privileges, which is what I thought SCCM does.

This application runs fine if I run my batch file as admin or run CMD as an admin, but if I run it without elevating the privileges I get the UAC prompt.

Command Line
"\\xxxCM01.xxxx.LOCAL\SMSPKGC$\NYC00148\x64\setup.exe" /s /ConfigO2010
Working Path
"\\xxxCM01.xxxx.LOCAL\SMSPKGC$\NYC00148"
Is there anything I can look at to see why it is hanging?


Please note that the Max Time has been increase to 10 and even 30 mins.  The manually install takes about 1 to 2.
 Error:
"The program for advertisement "NYC200D4" ("NYC00148" - "pInstall_X64") exceeded the maximum allowed run time of 5 minute(s). Systems Management Server (SMS) has stopped monitoring the program, and is unable to determine the status of the program. SMS will not automatically attempt to run this program again.
Possible causes: The program might have taken longer to run than expected, or the program might have experienced problems while running.
Possible solution: Make sure the maximum allowed run time specified for the program allows enough time for the program to finish running. If the program requires user input, ensure the program properties allow the user to interact with the program."
LVL 26
yo_beeDirector of Information TechnologyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

yo_beeDirector of Information TechnologyAuthor Commented:
I ended up using a VBS to set the SEE_MASK_NOZONECHECKS = 1 then run that process with that level set.


Set oShell = CreateObject("WScript.Shell")



Set oEnv = oShell.Environment("Process")


oEnv("SEE_MASK_NOZONECHECKS") = 1

 

oShell.Run "\\xxxxCM01.xxxx.LOCAL\SMSPKGC$\NYC00148\setup.exe /s /configureO2010Admin", 0, true

oEnv.Remove("SEE_MASK_NOZONECHECKS")

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
yo_beeDirector of Information TechnologyAuthor Commented:
I found this myself, but I figure it is worth keeping on the site for others that are looking for something similar.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.