Need to use Physical Path on RadFileExplorer

I am using a solution with "radFileExplorer" used in the controls.
Here I was passing a virtual path that works just fine.

But when I added a network path to a Mapped Drive and used it in the "radFileExplorer ", it throws a run-time exception.
Any ideas guys on how to use the physical path correctly here?
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


        protected void Page_Load(object sender, EventArgs e)
        {
            radFileExplorer1.Enabled = false;
            try
            {
                   //radFileExplorer1.InitialPath = Page.ResolveUrl("~/FoldersAndFiles");
                    radFileExplorer1.DisplayUpFolderItem = true;
                    radFileExplorer1.EnableOpenFile = true;
                    radFileExplorer1.AllowPaging = true;
                    radFileExplorer1.EnableCreateNewFolder = true;
                   
                    if (IsSuperUser() == true)
                    {
                        radFileExplorer1.EnableCreateNewFolder = true;
                    }
                    else
                    {
                        radFileExplorer1.EnableCreateNewFolder = false;
                        RemoveControlsFromFileExplorer("Delete");
                        RemoveControlsFromFileExplorer("Rename");
                    }
                    radFileExplorer1.VisibleControls = GetVisibleControls();  //Get the visible controls for the FileExplorer
                    radFileExplorer1.ExplorerMode = Telerik.Web.UI.FileExplorer.FileExplorerMode.Thumbnails;
                    radFileExplorer1.ExplorerMode = Telerik.Web.UI.FileExplorer.FileExplorerMode.Default;
                    radFileExplorer1.Configuration.AllowMultipleSelection = true;
                    radFileExplorer1.Configuration.MaxUploadFileSize = 1 * Constants.GigaByte;

                    InitializePageBasedControls();
                    radFileExplorer1.Enabled = true;
            }
            catch (Exception ex)
            {
                ShowException("Error:" + ex.Message);
                radFileExplorer1.Enabled = false;
            }
        }


        //Initialize the File Locations (Download/View/Delete) for the Current page
        private void InitializePageBasedControls()
        {
            string[] uploadPaths = new string[] {};
            string[] viewPaths = new string[] {};
            string[] deletePaths = new string[] {};

            //Set the paths as needed (Not working - Physical Paths)
            uploadPaths = new string[] { "R:\DataFolder\Upload" };
            viewPaths = new string[] { "R:\DataFolder\View" };
            deletePaths = new string[] { "R:\DataFolder\Delete" };

            //Set the paths as needed (Working - Relative Paths)
            //uploadPaths = new string[] { "~\FoldersAndFiles\Upload" };
            //viewPaths = new string[] { "~\FoldersAndFiles\View" };
            //deletePaths = new string[] { "~\FoldersAndFiles\Delete" };

            radFileExplorer1.Configuration.UploadPaths = uploadPaths;
            radFileExplorer1.Configuration.ViewPaths = viewPaths;
            radFileExplorer1.Configuration.DeletePaths = deletePaths;
      }
Error1.png
ArikkanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AndyAinscowFreelance programmer / ConsultantCommented:
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ArikkanAuthor Commented:
I tried with this method in 2 ways:

1. Mapped drive on a network folder:  >>   R:/Repository/FolderMapped/
--> Here I can see only the ROOT folder on the control and nothing else. Cannot view/write anything (On root) and cannot see any subfolders.


2. Shared network folder:  >>   \\myComputerDesktop2\Repository\FolderShared\
--> Here the whole radFileExplorer control is greyed out. Cannot see anything on it.
--> Just to check, I have given full control to Everyone (In Properties and Shares as well). But still cannot do anything on the folder....

Any ideas?
0
AndyAinscowFreelance programmer / ConsultantCommented:
If your original problem is solved (which it seems to be) then please close this question and ask a new one about the now very different problem.
1
ArikkanAuthor Commented:
Not really. I cannot view the files on the Absolute path.
0
AndyAinscowFreelance programmer / ConsultantCommented:
>>But when I added a network path to a Mapped Drive and used it in the "radFileExplorer ", it throws a run-time exception.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.