Cisco Routers Primary and Backup

I have 2 Cisco Routers 2911 with Cellular eHWICs to the Internet.

Looking for a Primary and Backup Router Setup with Matching Configurations.  

Primary Router:  
Gig 0/1 has all the Routing and VLANs and is Working

Gig 0/2
ip address 192.168.5.1
standby 0 ip 192.168.5.3
standby 0 priority 100
prempt

Backup Router.
Gig 0/1 same config as primary

Gig 0/2
ip address 192.168.5.2
standby 0 ip 192.168.5.3
standby 0 priority 99

So the backup router shows as standby but getting duplicate IP conflicts since Gig 0/1 on both are configured the same.  
Not sure how to get around this since the Cellular routers in each and I don't have a point to forward as a typical next hop to internet.  Its all cellular default route.

Thanks.
NJ_CONSULTANTAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Don JohnstonInstructorCommented:
You can't have the same IP address on two different router interfaces.

Each router G0/1 will need a unique IP address.
NJ_CONSULTANTAuthor Commented:
So I can make that change and have the secondary as .2 for each.  But then when the primary goes down and the vlan interfaces all have .1 as gateway address how will they find the gateway on router 2 with the .2 address.
Don JohnstonInstructorCommented:
You would use HSRP on the G0/1 interface as well.  But without knowing the actual configs and topology, it's hard to say if that would be the correct approach.
SolarWinds® IP Control Bundle (IPCB)

Combines SolarWinds IP Address Manager and User Device Tracker to help detect IP conflicts, quickly identify affected systems, and help your team take near instantaneous action. Help improve visibility and enhance reliability with SolarWinds IP Control Bundle.

NJ_CONSULTANTAuthor Commented:
Don JohnstonInstructorCommented:
HSRP is most likely not going to work since it connects outside and the provider is only going to recognize one address on that link.

If you're trying to protect against a failure of the primary 2911 or it's cellular link, then the provider should be responsible for converging from that failure.
NJ_CONSULTANTAuthor Commented:
So both routers sit inside the same rack.   The HSRP is set on Gig0/2 and cabled together.  But I can move to gig0/1 easily.   Each Router has 2 Cellular cards going to the internet.   Trying to setup in case the primary router goes hard down.  that the secondary will take over

I also attached the config to the previous comment.
Don JohnstonInstructorCommented:
The challenge is how the provider will handle a failure.  Since it appears that the cellular links are on the same network, it's possible that you can enable HSRP and let the provider know what you're doing and they could forward to the virtual HSRP address instead of the actual address.

But you would need to coordinate with them. The alternative would be to have the same address assigned to the backup router and leave it unplugged until a failure occurs.
NJ_CONSULTANTAuthor Commented:
I figured it out.  
I did this
Primary Router
interface gig 0/1.1
ip address 192.168.1.10
standby 1 ip 192.168.1.1
standby preempt
interface gig 0/1.2
ip address 192.168.2.10
standby 2 ip 192.168.2.1
standby prempt
etc through gig 0/1.4

Secondary Router
interface gig0/1.1
ip address 192.168.1.11
standby 1 ip 192.168.1.1
standby priority 99
interface gig 0/1.2
standby 2 ip 192.168.2.1
standby priority 99
and etc through gig 0/1.4

This way my default gateway for each subnet stays as the 192.168.X.1 address for all the virtual machines and equipment.

Test this failover and it all worked perfectly.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Don JohnstonInstructorCommented:
Well done.  Take the rest of the day off. ;-)
NJ_CONSULTANTAuthor Commented:
Close
NJ_CONSULTANTAuthor Commented:
Fixed the issue myself,. but awarding the points to Don for the help in replying.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.