Is SFP adapter good or bad for WLC?

Hi, I am trying to connect WLC4402 to Switch3560poe by SFP adapter. I try it two times with two different brands of SFP. One is "HP 1GB SFP RJ-45 Transceiver Module", and second is "GLC-T 1000BASE-T SFP Transceiver Module for CISCO HIGH QUALITY" The SFP is plugged into WLC and RJ45 end is plugged into Switch3560. I cannot see any lights at its port for the two SFP separately. And then I plugged the two SFP into two distribution ports of the WLC at the same time with one RJ45 cable connecting the two SFP. Then, the two lights of two SFP are on.

My Question is the two SFP are good or bad? or do I need to configure the WLC' distribution port before connecting the WLC with the Switch ? Thank you
eemoonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Craig BeckCommented:
The GLC-T modules will work.  I'd check your switch.

The WLC will ONLY talk at 1Gbps so if your is itch is only 10/100 you'll need to use GLC-T in the switch SFP ports to link the WLC, or get a gigabit switch.
0
eemoonAuthor Commented:
Thank you so much for your fast reply. I think you are right. Some document also mentions this 1Gbps.
The switch gigabitEthernet BW is 10000kbit, while its fastEthernet BW is 100000kbit. Are these BW by default or configured one?    If it is configured, we can get it back to original

Here are switch port info

Switch#sh int gigabitEthernet 0/1
GigabitEthernet0/1 is down, line protocol is down (err-disabled)
  Hardware is Gigabit Ethernet, address is 0019.56b4.cd01 (bia 0019.56b4.cd01)
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
....

Switch#sh interfaces  fastEthernet 0/1
FastEthernet0/1 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 0019.56b4.cd03 (bia 0019.56b4.cd03)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00

------

Switch   Ports  Model              SW Version              SW Image            
------   -----  -----              ----------              ----------          
*    1   26     WS-C3560-24PS      12.2(25)SEE2            C3560-IPBASEK9-M
0
Craig BeckCommented:
You can ignore the BW on each port.  Its a soft value so not used for physical links.

There are 2 problems that I can see here...

1. The Gig0/1 interface is err-disabled.  Shut the port then no shut to see if it comes up.  If not, check the cable.

2. You've got 2 different types of port connected.  If you're using LAG that'll break the link.

Can you post each switch port's config please?
0
Challenges in Government Cyber Security

Has cyber security been a challenge in your government organization? Are you looking to improve your government's network security? Learn more about how to improve your government organization's security by viewing our on-demand webinar!

eemoonAuthor Commented:
I also noticed the "err-disabled", which was caused by my test where I connected one cable between ports in the same switch. Now i already have removed the error.

There are two different brand of SFP now. In the switch, I connected the SFP port to fastEthernet port itself(g0/1 to f0/1), it confirmed first SFP cannot work in switch 3560(no lights), and second SFP can bring lights up. So, maybe I need another SFP that is the same brand as the second one. This way I can connect two devices: WLC and the switch.  

This switch does not have any configuration yet. Below is show run:

Switch#sh run
Building configuration...

Current configuration : 1290 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
ip subnet-zero
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!        
vlan internal allocation policy ascending
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!        
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
!
ip classless
ip http server
ip http secure-server
!
!
control-plane
!
!
line con 0
line vty 0 4
 no login
line vty 5 15
 no login
!
end

Switch#
0
Craig BeckCommented:
Ok so you have 2x GigabitEthernet interfaces.  Plug any of your SFPs in to those 2 ports and the links to the WLC will work.  You CAN'T use the FastEthernet ports to connect to the WLC using 1Gbps SFP modules - ever.

If you are using LAG at the WLC (to create an Etherchannel) you need to do the following config at the GigabitEthernet ports...

interface Port-Channel1
 switchport
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no shutdown
!
interface range GigabitEthernet0/1 - 2
 switchport
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode on
 no shutdown

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
eemoonAuthor Commented:
Hi I had done that like you said in your post, but it had not worked. Since you said it can work, I re-did it again, but this time I exchanged two SFP to plug, and then its light is up! Thank you
0
Craig BeckCommented:
Glad to help :-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.