Getting Certificate error on IE and Chrome but opens in FireFox

I am trying to open https://github.com on IE 11 and Chrome but it gives a SSL certificate error NET::ERR_CERT_AUTHORITY_INVALID on chrome with no option to proceed ahead.

It's happening with almost every site but luckily I am getting the option to proceed. Then I installed Firefox (portable version) and checked that it works without any problem!

Digging further I found that Firefox is using system proxy settings and I do not see any settings in IE and Chrome. What could go wrong . How to fix this ?

I have tried a lot changing the Advanced Security setting in Internet Explorer but no help.
Github.jpg
itaakashcomAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KimputerCommented:
Sometimes, your system time is wrong (but usually the error message will show it).

So in this case, I'd rather check the certificate itself. Can you take another screenshot? Click on the lock icon > tab Connection > Certificate Information.
Then another screenshot of the Certification Path tab.

If proxies are setup, IE and Chrome are already using it (assuming you mean, nothing is filled in Firefox, but it's using the SYSTEM's proxy settings which are found in Control Panel > Internet Settings > Connections, when filled in there, IE and Chrome are already using these settings).
0
itaakashcomAuthor Commented:
Uploaded the file as required above
Certification-Path.jpg
0
KimputerCommented:
Try to click on the top Digicert icon with the red cross in it, and "view certificate" and screenshot again.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

itaakashcomAuthor Commented:
Adding  as per requested.
Digicert_path.jpg
0
KimputerCommented:
Seems you removed a trusted certificate from your system. It all checks out. The certificate can be downloaded here: https://www.digicert.com/CACerts/DigiCertHighAssuranceEVRootCA.crt

Just download it, double click on it to install it, and make sure it's put in the Trusted Root CA folder.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
itaakashcomAuthor Commented:
Thanks . It worked like a charm :) . Also you taught me how to look for certificates being used by sites. Thanks again.
0
KimputerCommented:
Do not take these steps lightly though. Only do these steps if you know you're on the correct site. In this case DigiCert IS really a trusted root authority, just like many others, like Symantec, Google, GoDaddy etc.
If my link was to a http://24.24.24.24/pleasedownloadme.crt file, you would really have to think twice before installing it (actually not installing it, since that's the only safe way).
Problems with Trusted Root authorities shouldn't arise that often, and are also handled by Windows Updates,
1
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Databases

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.