Cisco virtual wireless controller CLI access

I'm setting up a virtual wireless controller using the guide provided here: http://www.labminutes.com/wlc0001_vwlc_7_3_vmware_installation

The narrator mentions your VMware being licensed for "Remote Virtual Serial Port Concentrator". I don't have a license level that supports that feature and upgrading is too costly at this point. How else can I get remote CLI access to this device? Is there some way to set up SSH access on that machine with the aforementioned technology?

Any help is appreciated.
travisryanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Craig BeckCommented:
You can simply SSH to the WLC's management IP.  That's a standard feature.
0
travisryanAuthor Commented:
I cannot telnet or ssh into my management IP. I can't ping my managment IP but I thought that was part of the "not having the serial port replicator feature" issue.
0
Craig BeckCommented:
Nope.  If you can't ping your management IP from the host (assuming you're using VMWare Workstation or Player) you haven't configured the networking correctly.
0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

travisryanAuthor Commented:
I'm not sure what my issue is. I have the managment interface assigned to a Virtual Machine Port Group with the correct vlan tag for my network. Is there some way to troubleshoot this from inside the virtual device?
0
travisryanAuthor Commented:
Attached are my virtual switch and virtual machine settings if that helps.
VM-networking-settings.JPG
Server-network-settings.JPG
0
Craig BeckCommented:
Set the management VLAN ID to 0 on the vWLC via the guest console then try again.
0
travisryanAuthor Commented:
Neither changing the VLAN ID to 0 or to all fixed the issue.
0
travisryanAuthor Commented:
Do you think it's an issue with the trunk and management port groups being assigned to the same physical interfaces. I wouldn't think that would matter but I've never run into an issue like this before.
0
Craig BeckCommented:
I need to see the config on the switch ports where your ESXi host connects.  It could be a switch problem.

Also, have you tried using the official Cisco guide instead?
0
travisryanAuthor Commented:
Below is the port channel settings and one of the 3 ports I'm using for my ESXi host.

interface Port-channel6
 description VMWare ESX
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan (default),(VM),(user)
 switchport mode trunk
 switchport nonegotiate

interface GigabitEthernet1/0/1
 description VMware ESX
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan (default),(VM),(user)
 switchport mode trunk
 switchport nonegotiate
 spanning-tree portfast trunk
 channel-group 6 mode on

Open in new window


The Cisco guide doesn't differ too much from the guide I referenced above and it shows how to set up a few options the cisco guide I found did not. Let me know if this helps.
0
Craig BeckCommented:
Try configuring a native VLAN on the Port-Channel (something unused) and set the WLC management interface VLAN to the tagged VLAN ID you want it to be on, then try again.
0
travisryanAuthor Commented:
After logging back in through the web portal it looks like I can get to my management interface, but I cannot get to my service interface. I'm trying to read through the Cisco setup guide to see what this port does.

I apologize for the mix up.
0
Craig BeckCommented:
You don't need the service port unless you want out-of-band management to the WLC.

I wouldn't worry about it :-)
0
travisryanAuthor Commented:
Right now the management interface is on my wifi vlan (I'm assuming it needs to be because it's acting as a "gateway" for my access points so to speak) and the service port is on my management vlan. Can we troubleshoot why that service port isn't working?
0
Craig BeckCommented:
We can, but we can also do it another way...

The APs and WLC management don't need to be 'on' the WiFi VLAN (if that's the client VLAN).  You can put management and APs on your management VLAN and create a dynamic interface on the WLC which is tagged in your WiFi VLAN.  That'll do what I think you're after.

Now, the service port is a bit of a fudge using a redirected telnet.  It may just be that you actually need to enable telnet at the WLC.  It's hard to get it working at the best of times on supported hardware!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
travisryanAuthor Commented:
Here's the correct config for the port channel and one of the ports my host is connected to. I took a look at the incorrect one and realized it doesn't have VLAN settings for the Wifi VLAN or the Management VLAN

interface Port-channel7
 description VM HOST
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan (default),(user),(wireless),(management)
 switchport mode trunk
 switchport nonegotiate


interface GigabitEthernet1/0/2
 description owvm3 trunk
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan (default),(user),(wireless),(management)
 switchport mode trunk
 switchport nonegotiate
 spanning-tree portfast trunk
 channel-group 7 mode on

Open in new window

0
travisryanAuthor Commented:
Craig, that makes sense about not putting the controller or the APs on the Wifi VLAN. I should be able to give them all management VLAN addresses and have the APs themselves hand out Wifi VLAN addresses, no?

As far the service port, I'd just like another way into the virtual device besides SSHing into the management IP. If I got to the console on the VM, it's unresponsive. If there isn't a way to get that service port working with upgrading the VMWARE ESXi software, that's something I'll need to live with.
0
Craig BeckCommented:
You can get to the console of the WLC via the ESXi console... You need to press a key in the window when prompted during bootup :-)

I'll check my ESXi install to see what's up.
0
travisryanAuthor Commented:
Attached is what I have at my console now. I'll need to reboot everytime I need to get in the console through VMWare?
12-8-15.JPG
0
Craig BeckCommented:
No not every time.  You do it once and it redirects the terminal to the ESXi console until the WLC reboots.  You can close the ESXi console amd return to it later and simply press a key on the keyboard to wake it up.
0
travisryanAuthor Commented:
The screenshot I showed you is after the controller had been running for a few days and there's nothing I could hit on the keyboard to wake it up. The only way I've been able to get at a working console through VMWare is to hit a key while the VM was booting up.

Is there a setting in VMWare or in the device I need to change?
0
Craig BeckCommented:
No, unfortunately you have to do it when the WLC is booting.  There's no other way.  That's why I said...
You need to press a key in the window when prompted during bootup :-)

:-)
0
travisryanAuthor Commented:
I think we we're both saying the same thing different ways. I understand now. Thanks for all of your help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.