Help getting two "switches" to ping each other accross a trunk line

Hello Cisco Experts,

I’m using GNS3 to setup some labs.  The current lab I have consists of two routers with switch modules in them (so they can act like switches) connected to each other.  The routers are named ESW1 and ESW2.  On each device I have done the following:
•      Created a new vlan (vlan 10).
•      Created a vlan interface.
•      Assigned each vlan interface an IP address in the same subnet.  For ESW1 interface vlan10 has the IP address of 10.99.99.1 255.255.255.252.  For ESW2 interface vlan10 has the IP address of 10.99.99.2 255.255.255.252.
•      Configured interface fa1/0 as a trunk port
•      Allowed vlan 10 on the trunk.

At this point in time, ESW1 can ping its ip address of 10.99.991 and ESW2 can ping its ip address of 10.99.99.2.  However, EWS1 cannot ping 10.99.99.2 and ESW2 cannot ping 10.99.99.1.  I can’t figure out why this isn’t working.  I suspect it is because IP is layer 3 and trunking is layer 2.  This configuration is similar to one we have at work between our agency and a county agency, so I want to understand it.  Any help with this would be greatly appreciated.

Below are the running configs for ESW1 and ESW2:

ESW1:
ESW1#show running-config
Building configuration...

Current configuration : 2242 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ESW1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
!
multilink bundle-name authenticated
!
archive
 log config
  hidekeys
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
 switchport trunk allowed vlan 1,2,10,1002-1005
 switchport mode trunk
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 10.99.99.1 255.255.255.252
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
End

ESW2:
ESW2#show running-config
Building configuration...

Current configuration : 2242 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ESW2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
!
multilink bundle-name authenticated
!
archive
 log config
  hidekeys
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
 switchport trunk allowed vlan 1,2,10,1002-1005
 switchport mode trunk
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 10.99.99.2 255.255.255.252
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
LVL 1
ndalmolin_13Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
a) GN3 have that kind of bugs
b) try extended ping to specify int vlan 10 as source address
# ping
#Protocol [ip]:
#Target IP address: 10.99.99.2
#Repeat count [5]:
#Datagram size [100]:
#Timeout in seconds [2]:
#Extended commands [n]: y
#Source address or interface: 10.99.99.1

Did you first create old school VLANs - recommended in GNS3 (vlan database) before creating vlan interfaces?
From privileged mode (not from config mode as usual) and do not use ctrl+z , must type exit :)

Switch# vlan database
Switch(vlan)# vlan 10
VLAN 10 added:
    Name: VLAN0010
Switch(vlan)# exit

And try to add some ports to VLAN 10 and attach switches or hosts to it.
Check status of your interfaces with (vlan interface may be down although having port assigned to that vlan should bring it in up state)
#sh ip int brief
Check vlan and trunk state
#sh vlan
#sh int trunk

Switching in GNS3 is very buggy experience. Many times I had to simply recreate scenario exactly the same as the first time and second time was working.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kevinhsiehCommented:
I expect that the L2 VLAN wasn't created. On my switches, it is
#config terminal
vlan 10
name NAME_MY_VLAN
exit

Repeat for both devices.

Check your VLANs
#show vlan
ndalmolin_13Author Commented:
The vlan didn't add correctly in GNS3.  I did the vlan database command and added it and things started working.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.