Exchange 2013 issues with OWA then issues with reinstallation

We have a domain with 2 2003 servers on it and are attempting to install Exchange 2013 on a 2008 R2 machine. We installed it successfully but they had a myriad of issues with OWA and were not able to fix the issues with that and a few other things. I thought uninstalling and reinstalling Exchange would rewrite possible corrupted files. I was not able to uninstall with the gui so I used the unattended commandline tools to uninstall which worked. Now when I try to install again I am being told that the account I am using is not in the enterprise admin group, the organizational management role group, that there is no organizational management role group, and that active directory does not exist or cannot be contacted. We have confirmed the domain is functioning properly.

Any ideas on how to approach this?
PIMSupportAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BembiCEOCommented:
Was this your first Exchange server, or have you tried to install into an existing exchange organization?
First at all, the user has also to be Shema Admin because the setup tries to update active directory.
If your admin is ok, I would have a look into active directory, if there are Object left over from the previous installation, which are found by the setup.
As exchange writes a lot of information into the AD, it may fail due these old settings.

Remove only Exchange Sever settings, if no other Exchange in your Active Directory exists.
You can downloas ADExplorer from sysinternals, a bit easier than ADSIEdit.
0
PIMSupportAuthor Commented:
The domain admin is the account being used so that should be a member of all the proper groups, correct? Your thought is to manually remove all mention of the exchange server? We will give that a try. This was the first exchange in this domain. I'll see if I can find specifics as to what is written during exchange installation so I can make sure those are the only items removed.
0
BembiCEOCommented:
The user should be member of domain-admins, enterprise admins and Schema-Admins groups, at least for installation  

You can remove the Exchange AD folders as long as you do not have any other Exchange server in your organization. Otherwise the other server is dead too.

You find the exchange settings in the Configuration settings (AD)...
Services\Microsoft Exchange
Services\Microsoft Exchange Autodiscover

Also you may find in AD Users and computers some Exchnage groups left over....
Possibly Microsoft Exchange Security Groups or Microsoft Exchange System Objects.
You can remove them as well, but remove first all members.

You can also start the setup step by step...

setup.exe  /PS    /IAcceptExchangeServerLicenseTerms
setup.exe /PAD  /IAcceptExchangeServerLicenseTerms
setup.exe /PD    /IAcceptExchangeServerLicenseTerms

So see if AD preparation (Schema / Forest / Domain) runs through...
The setup makes it alone, but this way you will see, if a single steps fails...
These commands will put back some objects into AD if the don't exist and set the right permissions.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BembiCEOCommented:
Oh, by the way, if you installed updates after you run the first try, it is possible that the schema has a newer version than the original version. Download a later version (the same or newer than the last installed version) and try to install from this version. The CUs are complete setups.  

The command above, run always with elevated PS console.
0
PIMSupportAuthor Commented:
A complete removal of Exchange from the domain allowed me to reinstall and it is now working properly.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.