WSUS Services install Server 2012 fails

Error message I am getting states
the operation cannot be completed because the server that you specified requires a restart.

Obvioulsy, I tried that a few other things, before reaching out here to the experts.

Thanks in advance.
ParisBPAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

FOXActive Directory/Exchange EngineerCommented:
Try installing it using powershell
On the server in question right-click powershell and run as administrator
type  the command        import-module servermanager  (press enter)
type the command         Add-WindowsFeature  UpdateServices  (press enter)
ParisBPAuthor Commented:
the operation cannot be complete because the server that you specified requires a restart.. same error..as server manager.
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

ParisBPAuthor Commented:
I saw that link.. ok.. but when I go to admin tools
GPM  I see default Domain Policy

but I do not see
computer configuration of the rest of that tree undeath default domain policy
FOXActive Directory/Exchange EngineerCommented:
Paris.
When you see the default domain policy, right-click on it then select edit

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ParisBPAuthor Commented:
I edited domain group policy as prescribed and install still fails needs restart.

I installed the .net features required separately and then tried installing WSUS and it still fails needing restart.

All updates are up to speed..
Hector2016Systems Administrator and Solutions ArchitectCommented:
@ParisBP

You need to run this command:

SFC /scannow

If there is any evident problem with installations on the server it will show you some info.

Also, you can check the CBS.log file on %windir%\logs\cbs\ for errors or warnings related to windows installer pending operations.
ParisBPAuthor Commented:
It had come down to permissions, which I went thru the full gamut of suggestions posted by FoxLuv and then hopeleonie.

each one made sense and got me closer, but at the end.. I ended up applying the log on service edit. to the default domain policy. and THEN the local gpedit on that server.

that did the trick.

Thanks Experts
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.