XenApp 7.6 - apps from PVS master image not appearing, apps from non-PVS master image fine

I asked the following question of the Citrix forum a few weeks ago now, and didn't get a single response.  I'm sure EE can do better... :)



One of my Machine catalogs comes from a PVS gold image, and has two machines.  In the associated Delivery Group, apps that I publish from this machine catalog appear in the list when I go to Add Applications, and I'm able to tick them, and an app is created.  However, these apps do not appear on the client side - neither on StoreFront nor on Receiver.  Although, strangely, the published desktop works fine - i.e. when I select a Delivery Type of 'Desktop and applications', the desktop appears fine in StoreFront/Receiver and I can run it.
 
All the apps are set to 'Show this application to the entire application group'.  Also, I have the 'Add shortcut to user's desktop' ticked - although this wouldn't be applicable for a StoreFront site anyway.
 
I have 5 other machine catalogs with one machine each, and 1 other machine catalog with two machines.  All these are non-PVS standalone machine catalogs.  Now, any application I create from these associated delivery group (and the published desktop) appear just fine to the user in StoreFront and launch fine.
 
Anyone know why published apps from my PVS machine catalog don't appear?

Thanks,
meirionwylltSenior Desktop EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brian CTXSupportCitrix ConsultantCommented:
Do you know if any BrokerEntitlementPolicy settings have been modified?

http://www.basvankaam.com/2014/06/26/configuring-citrix-xendesktop-7-x-desktop-publishing-and-limited-visibility/

There are also some filtering options in StoreFront.  https://www.citrix.com/blogs/2014/03/27/hiding-applications-in-citrix-storefront/?utm_source=feedburner&utm_medium=email&utm_campaign=Feed%3A+CitrixBlogs+%28Citrix+Blogs%29

If you select the option to limit visibility, and add your account, does it work then?

Which web browser is being used?  Is it possible that the apps tab is not showing up due to a browser compatibility issue?
0
meirionwylltSenior Desktop EngineerAuthor Commented:
Hi Brian,

When I first started looking at this problem, the only policies I had set were ones to do with client printer redirection.

Yeah I tried putting my username into the 'Limit visibility' box, but no joy I'm afraid..

I'm getting the same results from Receiver (locally), StoreFront on Chrome and StoreFront on Internet Explorer.  The apps tab is showing up fine - and contains apps published from non-PVS servers, just doesn't shows any apps from my servers that come from my PVS image.

I have installed my StoreFront servers from scratch, and can confirm that I have not set any filtering options like the ones in the link.

I've even collected traces from the XenApp servers and the two Delivery Controllers and sent them to Citrix TaaS Insight Services, but this didn't flag anything up either.

Any further suggestions?
Thanks.
0
Brian CTXSupportCitrix ConsultantCommented:
The policies I am referencing are not visible in the policy engine from within Studio.  You can only see them with the powershell commands.  This is one of those very difficult to troubleshoot problems when you are not on the machine to investigate.

A few more things I would try would be to recreate the delivery group, and (if possible) add one of the PVS image devices to a currently working delivery group.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

meirionwylltSenior Desktop EngineerAuthor Commented:
Hi, one thing I forgot to mention initially is that, apart from these two XenApp servers, I also have another which will be used for testing once the other two become live.  This is in its own Machine Catalog and Delivery Group, but from the same PSV image, and it's behaving the same way - published apps not appearing.

By the way I've also tried setting the delivery groups to Application only and rebooted, but this didn't solve it either I'm afraid.

Sorry I had a closer look at that link and ran the powershell command - here is the output...


Windows PowerShell
Copyright (C) 2009 Microsoft Corporation. All rights reserved.

PS C:\Windows\syswow64\Windowspowershell\v1.0> Add-PSSnapin Citrix*
PS C:\Windows\syswow64\Windowspowershell\v1.0> Get-BrokerEntitlementPolicyRule

BrowserName               : Windows 7 $S9-10
ColorDepth                :
Description               :
DesktopGroupUid           : 9
Enabled                   : True
ExcludedUserFilterEnabled : False
ExcludedUsers             : {}
IconUid                   :
IncludedUserFilterEnabled : False
IncludedUsers             : {}
MetadataMap               : {}
Name                      : Gweinyddion XenApp Prawf_1
PublishedName             :
SecureIcaRequired         :
SessionReconnection       : Always
UUID                      : 4a51f890-3158-44f2-9b35-c40cdf5bfffd
Uid                       : 10

BrowserName               : Gweinyddion XenApp $S10-12
ColorDepth                :
Description               :
DesktopGroupUid           : 10
Enabled                   : True
ExcludedUserFilterEnabled : False
ExcludedUsers             : {}
IconUid                   :
IncludedUserFilterEnabled : False
IncludedUsers             : {}
MetadataMap               : {}
Name                      : Gweinyddion XenApp_1
PublishedName             :
SecureIcaRequired         :
SessionReconnection       : Always
UUID                      : bda3ed39-6b98-4048-8f80-03bce46785c9
Uid                       : 12

PS C:\Windows\syswow64\Windowspowershell\v1.0> Get-BrokerEntitlementPolicyRule



Anything there that looks odd?

Thanks.
0
Brian CTXSupportCitrix ConsultantCommented:
What version of the VDA is being used, as well as any hotfixes/feature packs?
0
meirionwylltSenior Desktop EngineerAuthor Commented:
Hi, I used to have VDA version 7.6.0.5026, but in trying to solve the problem I've since upgraded to VDA 7.6.300.7020 (i.e. Feature Pack 3) to no avail.  The list of hotfixes disappeared when I upgraded the VDA, so I assume that they are incorporated in 7.6.300.7020.

Thanks.
0
meirionwylltSenior Desktop EngineerAuthor Commented:
One thing I've noticed is that only two (out of my 8) Delivery Groups are listed when I run this command.  Is it only the Delivery Group that are publishing desktops that are listed here?  The problem I have exists whether the DG publishes desktop or not, so are there commands that I can run which look at DGs from a published apps perspective?
0
meirionwylltSenior Desktop EngineerAuthor Commented:
I recreated my delivery Group and re-created all the apps, and now it's fine
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.