VM - No Network Cable

Hi,
I'm having some issues with a VM.  It runs Server 2012 R2.  I have the VMTOOLS installed, and everything was working just fine.

I'm not sure what happened, but for some reason this VM will not get any network connectivity.

It is connected to the proper VM network.
I've removed and added NICs a few times hoping to get this to work.

When I look at the VM properties screen, the network card doesn't have 'connected' checked.  No matter how many times I check it, it will 'uncheck' itself...

Any ideas?
LVL 1
jsctechyInfrastructure Team LeadAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
You are using the VMXNET3 interface ? and not the legacy E1000 interface?

the fact that it is disconnected, e.g. not connected, means the "virtual Ethernet cable is unplugged!"
jsctechyInfrastructure Team LeadAuthor Commented:
I was using VMXNET3, however when it stopped working, I then tried E1000E and E1000.  Same behavior.
No network cable.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
which version of ESXi and vCenter Server ?

also have you tried removing from the Inventory.

Re-creating the VM configuration (custom), and re-add the existing hard disk.

make sure you reselect, add a VMXNET3 interface, this will check if the VMX file is corrupted, or has a duplicated mac address.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

jsctechyInfrastructure Team LeadAuthor Commented:
Version 5.1
I haven't tried removing it from inventory yet.

I will try that and post back shortly.
jsctechyInfrastructure Team LeadAuthor Commented:
I shutdown the problem VM.
I created a new VM using VMXNet3
I selected to use an existing disk and pointed it to the original problem server's disk.

NIC showed up with yellow triangle.
In Windows Server Device Manager I removed the NIC along with ghosted NICs (greyed out NICS)
Rebooted.

Same behavior... the system shows that there is no network cable plugged in.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
can you tick the connected, and connected at power on boxes ?

Is this your only Windows 2012 R2 server ?

I would upgrade the ESXi 5.1 to the latest version U3.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
You've not exceeded the number of portgroups on the vSwitch ?

how many VMs, network interfaces are connected to the vSwitch ?

see here

http://kb.vmware.com/selfservice/search.do?cmd=displayKC&docType=kc&docTypeID=DT_KB_1_1&externalId=1004883

and this is a larger troubleshooting document

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1003893
jsctechyInfrastructure Team LeadAuthor Commented:
I've ticked the box so many times.
The vSwitch has 120 ports listed.  I have 20 VMs.  
I have numerous 2012 R2 VMs.

Everything was working earlier.  I have no idea why it just stopped working.  This happened with another VM a few or two ago, but after disabling/enabling the NIC in Windows, it worked.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Update ESXi 5.1 to the latest version.

it might be worth checking logs on the server, the VM Folder log - vmware.log

and look at the /var/logs - vmkernel.logs

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
compdigit44Commented:
Have you tried moving the VM to another host ? ALso is the VM using a static or DHCP address?
jsctechyInfrastructure Team LeadAuthor Commented:
I've tried moving the VMs to other hosts... no change.
Some use DHCP reservations, some use static.

After shutting down some non-critical systems, I was able to get the other VMs with problems to get on the network.

The GUI shows 120 ports on the vSwitch...
jsctechyInfrastructure Team LeadAuthor Commented:
I've tried reading the log files... there are hundreds of entries and I don't know what keywords to look for.

I SSH'd to the host, and the time was off by 6 hours... I don't know the exact time this all happened.

Anything I should be looking for in the log files?
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
so, after shutting down some VMs,  other's then connected to the network ?
jsctechyInfrastructure Team LeadAuthor Commented:
Yes.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
I would look at logs, and this looks like Ports on the vSwitch, increase the number
compdigit44Commented:
In the GUI if you look at the vswitch / vDS and view all ports for the different port groups...see if the number of VMs fills on availble Port ID's..

This is a very low tech way to check if you need to expand the number of ports on your vSwitch which should like what you need to do
jsctechyInfrastructure Team LeadAuthor Commented:
Compdigit44,
I don't know what you mean.  How do I view ports for a different port group?
jsctechyInfrastructure Team LeadAuthor Commented:
FYI - I have a call into VM Ware support.
They want me to disable some of the physical NICs to see if they are not functioning properly.

Of course I can't do that right now, so another day wasted :)
compdigit44Commented:
1) Open the web or C# vSphere client
2) Change to the Network View
3) Select your vSS or vDS , then highlight your port group in question
4) On the right side of the screen you will see a tab called ports.. If you scroll to the bottom and make note of the port ID and then the first one if you subtract the two you will get the number of ports allocated to the port group minus one..

Is each port in use by a VM? have you tried to create a new vSS or vDS as a test?
jsctechyInfrastructure Team LeadAuthor Commented:
We were able to solve the issue.
The issue was that the network adapter driver was crashing from running out of memory.

This seems to be a known issue with ESXi 5.1.  The following article has a fix and a workaround.

kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2072694
jsctechyInfrastructure Team LeadAuthor Commented:
I selected my answer as a partial solution because it contains a workaround if you are not ready to upgrade your ESXi.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.