oracle database control

I just upgraded my OS to Windows 10. Now my Database Control doesn't "see" the database and won't allow me to login. It "thinks" the database is down and needs to be started. However, I can login to the database with SQL*Plus. The database is up and running.
JEBORKLUNDAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Gerwin Jansen, EE MVETopic Advisor Commented:
Which Oracle database version is this about?
0
slightwv (䄆 Netminder) Commented:
Unless there is some data in the repository that you cannot live without:  drop and recreate the repository.

emca -deconfig dbcontrol db -repos drop
emca -config dbcontrol db -repos create

I am on Windows 10 running 11.2.0.3.  I had never gone to dbConsole since I upgraded to Windows 10.

It didn't let me get as far as you seem to have gotten.  I had to manually drop a few database things before the deconfig/drop worked:
drop user mgmt_view cascade;
drop user sysman cascade;
drop role mgmt_user;

Then I could use emca to drop the rest.

Even after the create I got an "unspecified" error the first time in.  I clicked on database (or whatever link was presented to me) and everything now looks fine.  I cannot reproduce the initial error so I cannot say what link was presented to me.
0
JEBORKLUNDAuthor Commented:
I am running Oracle Database 11g Enterprise Edition Release 11.2.0.3.0 - 64bit
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

slightwv (䄆 Netminder) Commented:
What about dropping and re-creating the repository?
0
JEBORKLUNDAuthor Commented:
I've solved the problem. Apparently, one or more of the users sys, system, sysman, and dbsnmp password had expired. I simply reset all of these users' password using SQL*Plus and the Database Control GUI interface now allows me in and I have full access again. I suspect that it was SYSMAN password was at the heart of the problem  but I reset all four.

Thank you to all who provided suggestions.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
slightwv (䄆 Netminder) Commented:
Feel free to accept your post as the solution.
0
JEBORKLUNDAuthor Commented:
The reason I accepted this solution is that it worked.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.