RPC server is unavailable...

Hello colleagues,

I just setup my first Windows server 2012 r2.
DHCP, DNS, AD has been created in the same



I'm trying to get my first client in the domain,
dm.jpg
 however I did noticed it took a while to bring the message of "welcome to the domain..." , right after that it took a little longer and it gave me its giving me this error
win7probs.jpg

I restarted the client and I coudln't loging to the domain therefore the only one way in is the local account

ps. I am able to see the PC in the scope and in AD within the server and I am also able to get a proper IP from the server to the client...

Did I miss to install another service?
LVL 3
ivan rosaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NVITCommented:
- Can client ping server?
- Is port 135 open on server? Try disabling firewall at client and server to see.

http://www.dell.com/support/article/us/en/19/SLN283117/EN
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ivan rosaAuthor Commented:
I found out
client could ping anyone: server, router...but server could't ping client it would time out...
so I turned off the firewall from the client, and now I am able to ping client and viceversa no problems
I restarted the DCOM service on server, and I restarted the client entirely

Tried the client again to put it on the domain this time was much faster but the delay was after it gave the "welcome again", so still same problem...
0
NVITCommented:
Safe to say it's client issue?
Tried a different client?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

awawadaCommented:
0
FOXActive Directory/Exchange EngineerCommented:
In the local area connections properties of the client machine, on the nic properties have you added the ip address of the domain controller? >>In Use the following DNS server address
ipDNS.JPG
0
FOXActive Directory/Exchange EngineerCommented:
ON the server- Local area connections> Use the following DNS>Preferred DNS server> use the same ip of the domain controller that you brought up that is hosting the DNS.
0
yo_beeDirector of Information TechnologyCommented:
On your domain controller do you have your NIC registering DNS.

These are the instructions to disable this feature, but you want to make sure the opposite is true
https://support.microsoft.com/en-us/kb/2023004

If you have to enable this your will need to run ipconfig /registerdns and do a net stop netlogon && net start netlogon.  

You should see additional DNS values added to DNS under _msdcs as well as _gc and bunch of others.

I would confirm whether they even exist prior to doing the above.

[embed=file 1031441]
DNS.png
0
ivan rosaAuthor Commented:
nvit,
I tired my second client and same thing, I also tried administrator account and same thing.

awawada,
I did what the link said but still same thing

foxlub,
I made sure these settings were correct eg
c1.jpg
yo_bee
this registration was already set checked by default, should I uncheck?
err2.PNG
0
yo_beeDirector of Information TechnologyCommented:
What about your client computers DNS server?
They need to be pointing to your DC and your router?
0
ivan rosaAuthor Commented:
Clients are set IPV4
Obtain an IP / DNS automatically
0
yo_beeDirector of Information TechnologyCommented:
What is the primary DNS showing up?
Is your DHCP SERVER issuing the router as the primary DNS. ?
0
ivan rosaAuthor Commented:
from the server side
err1.jpgerr2.jpgerr2.PNG
0
yo_beeDirector of Information TechnologyCommented:
Does your DNS entries look similar to my image ?
0
ivan rosaAuthor Commented:
pardon me, which image?
0
yo_beeDirector of Information TechnologyCommented:
The one in my first reply that had the NIC images.

DNS.png
0
ivan rosaAuthor Commented:
hmm, so they are a couple of differences, and those are
Subnet Mask = 255.255.255.0              <> mine 255.0.0.0
DNS server address = 127.0.0.1 /alternate=BLANK         <>mine  10.10.10.1 /alternate 10.10.10.10
                                 

P.s. The setup I have is I followed from an example..., but you think if change those values, like yours will make a difference? also what is the difference between having subnet 255.255.255.0 vs 255.0.0.0

thanks for your patient yo_bee
0
yo_beeDirector of Information TechnologyCommented:
Yours is fine, but one thing you brought up was your Gateway.  I did not see a setting in your DHCP Options for a gateway.

Are your clients getting 10.10.10.10 as your gateway?
0
ivan rosaAuthor Commented:
Client's
Windows IP Configuration


Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . : mydomain.com
   Link-local IPv6 Address . . . . . : xxxxxxxxxxx
   IPv4 Address. . . . . . . . . . . : 10.10.10.101
   Subnet Mask . . . . . . . . . . . : 255.0.0.0
   Default Gateway . . . . . . . . . : 10.10.10.10

Tunnel adapter isatap.mydomaim.com

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : mydomain.com 

Open in new window


or is it else where?

another thing I noticed once "It struggles to get it in the domain"it ask for rebooting, when it reboots it stays loading for a while and only shows me the local account to get in, if I was to use the "domain's" then it gives me an error like so "... can not connect cause there's not partnership..."
0
yo_beeDirector of Information TechnologyCommented:
Have you looked at the event logs?
0
yo_beeDirector of Information TechnologyCommented:
The network information looks correct.
0
NVITCommented:
> ... can not connect cause there's not partnership

Are you using AD Federation Services?
0
ivan rosaAuthor Commented:
negative sir, this is just a simple set up for a lab.

I just restarted the server and same thing, I also started the RPC service
0
ivan rosaAuthor Commented:
Allright fellows, I figured it out, long story short before starting this ticket I had installed
Norton Security Suite and this means Firewall built-in (i iknow silly me)... I was only paying attention to Windows Firewalls both ends...

What triggered it I noticed the lag, and I also change my user name on client's login, so I noticed it the changing password part work really well, but was still delaying that's when I start searching for other firewalls...

with that said, you guys recommend me to do whole lot of changing settings to my server so I can get my Norton Firewall to work or should I rely on the one built In my Router?
0
ivan rosaAuthor Commented:
You guys are awesome! thanks for your time
0
NVITCommented:
Glad to help 😊, Ivan. Have a good day...
0
NVITCommented:
My built in Windows server firewall works well for me. No 3rd party.
0
ivan rosaAuthor Commented:
noted! I can't thank you enough
0
yo_beeDirector of Information TechnologyCommented:
Glad you pin-pointed the cause.
Good work.  

Just a word of advice when posting a question, Please include all settings and applications.
I personally was not focused on asking the questions whether you had third party software.

I can guaranty that this would have been caught by one of the first EE responders.

Good luck with your lab.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.