OS 10.10.5 Messages does not retrieve "To:" name from Contacts

OS 10.10.5 Messages does not retrieve "To:" name from Contacts

Starting Messages and entering Contacts name shows "No Recipients" - typed 'Name' has pink background until clicked, then turns red. Sent message has green (SMS?) background for iPhone recipients [have iPhone]. 'Sent' Message was "Not Delivered". This is true on two Macs OS X 10.10.5 I have connected to same router.

All is well with my iPhone 6S (same network as above) Messaging - sent same message to same people [from Contacts] and sent/received OK as iMessage.
LVL 1
MARSPATHRetired EE/Computers/ITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tim LapinComputer Consultant (Desktop analyst)Commented:
How are you sharing contacts?  Via iCloud, Gmail, Exchange or other?  If so, did you recently flush the Contacts list on your mac and/or change the account?

Are all the devices logged into the same source for the Contacts file?
MARSPATHRetired EE/Computers/ITAuthor Commented:
>>> How are you sharing contacts?  Via iCloud, Gmail, Exchange or other?
iCloud

Logged into my iCloud account with usual credentials OK - Contacts appear as expected. I do appreciate the difference between iCloud.com and iCloud Drive. All my contacts are hosted with iCloud.com. Attempting to call from Contacts, that is click on Contact name, does not work - the app does not respond to clicks to call or FaceTime.  

I had not made any changes to iCloud setup before or after this issue. The OS X systems do not respond to phone or of keyboard input. There is a serious disconnect somewhere!

Interesting and perhaps related is that DockPhone App on Mac now defaults to FaceTime, rather than voice only,  when making a call which uses my iPhone.
MARSPATHRetired EE/Computers/ITAuthor Commented:
Further input about "To:" field: with red color, clicking down 'v' returns '1234567890' is not registered with iMessage.

OK, how did it become unregistered, or more to the point, how to I (re)register this contact?
Become a Microsoft Certified Solutions Expert

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

Tim LapinComputer Consultant (Desktop analyst)Commented:
One approach might be to flush the contacts from the Mac in question and to reload them.  I had to do that when I merged two different iCloud accounts.

I still haven't looked into the preference file angle but it could be that it/they is/are corrupt.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MARSPATHRetired EE/Computers/ITAuthor Commented:
Problem solved: I responded to a query asking for my Apple ID password and now all is well.

I have no idea where the message originated (I was searching the web for help), but suddenly it popped up, entered my Apple ID password and away we go...

Not only the above, but a  system message appeared on my other Mac telling me what I had done - however, the same still exists on second Mac. Guess I will have to go down that road again!
MARSPATHRetired EE/Computers/ITAuthor Commented:
See below for how I did this - thought both Macs on same WiFi was problem, so shutdown #1 and used instructions below.

You must register your phone number by signing into iMessage from your iPhone. If you are already signed into iMessage on the iPhone, sign out and sign back in on the iPhone.
If it still doesn't appear on the computer, sign out of iMessage there and sign back in. It should appear then.
 
Also, in order to send SMS messages from the computer, you must enable it on the iPhone. In iPhone settings, open iMessage. Select Text Message Forwarding. You must be on the same wi-fi network. Your computer or other device should show in the list. Just click on the device you want to enable.
Also enable SMS on the iPhone.

Hi Parrish Jones, my problem was identical to yours. My iPhone showed up in Messages on my MacBook Pro. I could text anyone from my phone that I wanted to. The problem was on my MacBook Pro. Many people I tried to text via the MacBook Pro would be highlighted in red and I would get that number not registered message. When I read that the solution was to go to the phone and change a setting on the phone, I thought, that won't help my MacBook Pro problem, but it did. It solved the MacBook Pro problem.
 
If you follow the instructions that Glenn provided, I think that it might solve your problem. I know the instructions sound counterintuitive as your problem isn't on the phone, but you should try it. It worked for me. I hope you get the same results.
 
In iPhone settings, open iMessage. Select Text Message Forwarding. You must be on the same wi-fi network. Your computer or other device should show in the list. Just click on the device you want to enable.
Also enable SMS on the iPhone.

Have you added the phone number to your Messages account?

So how does one do that. It seems the help notes in iMessages do not give complete instructions. The person I wish to message is in my contacts and I can send him msgs using my iphone and ipad but not my computer.

Messages/Accounts/Message Account/Settings - click add e-mail and enter the phone number.

https://discussions.apple.com/thread/6614652?tstart=0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Contact Management

From novice to tech pro — start learning today.