PowerPoint template thumbnails not being generated for backstage use

I have 5 templates which are all based on the same corporate brand. They are saved in the default templates folder so that they appear in PowerPoint (2013) when I click File / New and then selecting the folders Custom / Templates.

The problem I have is that only one of them shows a thumbnail as expected for the template design. The other four show a generic landscape thumbnail as indicated by the red rectangle highlights in this screenshot (the black parts are to protect confidential info):

PowerPoint backstage template thumbnails
So I went into detective mode to try to find out what was wrong by renaming one of the offending .POTX files to .ZIP and comparing the contents of the presentation archive with that of a good template.

I discovered that the file in the presentation archive \docPros\thumbnail.jpeg is present in a good template but missing from a bad template.

Since PowerPoint should be automatically creating these thumbnails when it saves the template, I am now lost what to do.

How can I fix this?
LVL 15
Jamie GarrochSenior Technical Consultant at BrightCarbonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Echo_SCommented:
Interesting.

One thing that's probably not related, but I've found that if I put a file in the Themes folder, use it so it shows up on File | New, and then delete it, I get that same icon showing on the File | New  screen. It's not a missing thumbnail -- in that case, it's actually representing a missing theme. (I consider this a bug and have reported it.)

However, usually when your file is missing the thumbnail.jpeg, it's because you didn't have a title slide (or any slide, more likely) in place when you saved the file.

Try adding a title slide and resaving the POTX.
Echo_SCommented:
Oh, and you might have to save it with a new name to get the thumbnail to show and then resave it with the name you really want....
Jamie GarrochSenior Technical Consultant at BrightCarbonAuthor Commented:
Ditto interesting! After some further testing, the key question for me is "how does PowerPoint decide what the title slide is?". Is it the first slide, the first slide with a title placeholder, the first custom layout of the first slide master, the custom layout named "Title Slide", a combination of these or something else?

So both the test decks I have, one without thumbnail and one with, have slides. Neither has a layout called "Title Slide" but the first slide in both decks has a placeholder of type title as interrogated by the G-Tools add-in I am using to spy on shape properties:

PowerPoint shape type in right-click menu
On clicking the Shape Type : XXX menu, I see more properties:

G-Tools Shape Properties
The custom layout has the Title enabled: (why Sub Title is missing from the PowerPoint UI is another topic!)

PowerPoint Slide Master Title enabled
So I tried the following on the non-thumbnail deck:

1. Added a new custom layout in position 1
2. Named the layout "Title Slide"
3. Inserted a new slide in the deck and set it to use "Title Slide" and put text in the title placeholder
4. Saved it as a new .potx file

No thumbnail appears :-(
Introduction to Web Design

Develop a strong foundation and understanding of web design by learning HTML, CSS, and additional tools to help you develop your own website.

Echo_SCommented:
Try opening a new blank presentation, copying in the title slide layout, making that the first slide, and then saving the file.

It's looking for a title slide layout, not just the title place holder. PowerPoint is unfortunately extremely particular about its title slides.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jamie GarrochSenior Technical Consultant at BrightCarbonAuthor Commented:
OK - did that and I now see a thumbnail. I then went further and did this:

1. Opened up the non-thumbnail deck
2. Slide Master view, copied the master (by selecting the top parent)
3. Created a new blank deck
4. Deleted the blank 1st slide
5. Slide Master view, pasted the non-thumbnail deck master
6. Deleted the blank master
7. Slide view, copy/pasted the slides from the non-thumbnail deck
8. Saved as new POTX

Thumbnail now appears.

Go figure!!!

I am now trying to work out how the original was broken and if there's a quicker way to fix it but this does the trick so THANK YOU very much!
Echo_SCommented:
LOL. I'm kind of lost in your steps, but I think that once you've saved the POTX/THMX with the thumbnail you can delete the title slide layout -- or at least move it to the end. (This isn't the case with superthemes, though. They are even pickier -- they even want the title slide layout to remain named Title Slide, for example.)

I think also that PPTX files work differently than POTX and THMX. And THMX might also work differently than POTX, but I can't recall off the top of my head. (And don't have bandwidth to test right now, sorry!)
Echo_SCommented:
Oh, and to get a new default layout, I do this.

1. Open problem file, put it into master view.
2. Open new blank presentation, put it in master view.
3. Copy title slide layout (not the master -- the individual layout) in new blank deck.
4. Paste layout into problem file layouts list (in master view)
5. Reformat and reorder layout as necessary and desired (in problem file)
6. Close Master View and re-save problem file (sometimes with a new name)
Laura GillenwaterCommented:
Jamie - I can't tell you how helpful your instructions were...I used them to fix several templates I had which didn't show a thumbnail, and it worked like a charm! :)

I know you wrote this about a year ago, but just wanted to let you know that it's still helping folks.
Echo_SCommented:
Also, there's a setting in File | Info | Properties (dropdown) | Advanced Properties. On the Summary tab, click Save Preview Picture.

I haven't done much testing with this, but it seems to work.
Manon MMCommented:
That last one worked for me, Echo. Thanks. I couldn't figure it out, but now it works!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft PowerPoint

From novice to tech pro — start learning today.