We help IT Professionals succeed at work.

Outlook cannot connect to the Office 365 email account with autoi discover

249 Views
Last Modified: 2016-02-22
I have just setup a client with Office 365 Exchange. The old SBS server is still on site but I have stopped all the Exchange services.
When I try and add the new profile it goes away to autodiscover the account but seems to find the old SBS exchange rather than the Office 365 Exchange.

If I setup a non domain computer with the new email it works fine on the same LAN. I even tried unplugging the SBS server to see if I can connect but it will not work
Comment
Watch Question

Remote Training and Programming
CERTIFIED EXPERT
Top Expert 2015
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
My wild guess is that the DNS manager of your DC still points to autodiscover A records of the old SBS server.

You need to:-

1. Open the DNS manager on one of your Domain Controllers.
2. Expand out the management tree until you can see your Internal Domain’s Forward Lookup Zone. Click on it, and make sure there are no A records for autodiscover.domain.local in the zone.
3. Once no autodiscover A records exist, right click the Zone name and select Other New Records.
4. Select Service Location (SRV) from the list.
5. Enter the setting for the SRV to the one of your Office 365 Exchange.
6. Hit OK to finish adding the record.
Once the SRV record is added to the internal DNS zone, Outlook and other autodiscover clients that attempt to configure themselves with a domain.local SMTP address will work properly without the Certificate errors on all versions of Exchange.

Source: https://acbrownit.wordpress.com/2012/12/20/internal-dns-and-exchange-autodiscover/
crystal (strive4peace) - Microsoft MVP, AccessRemote Training and Programming
CERTIFIED EXPERT
Top Expert 2015

Commented:
thanks for the explanation, Jackie  ~
CERTIFIED EXPERT
Most Valuable Expert 2015
Distinguished Expert 2019

Commented:
You can easily work around this by deploying the reg keys in this article: http://support.microsoft.com/kb/2212902

All you need working for O365 is the HTTP redirect method, you can block all others.
crystal (strive4peace) - Microsoft MVP, AccessRemote Training and Programming
CERTIFIED EXPERT
Top Expert 2015

Commented:
Vasil, I looked at that link for 2013 running under Windows 10 but the registry keys are different -- I found autodiscover-s.outlook.com with a value of 0000 but the article is not clear what to do ... thanks
CERTIFIED EXPERT
Most Valuable Expert 2015
Distinguished Expert 2019

Commented:
The reg keys are the same, only the version number will differ (15.0 for Office 2013). But they are not present by default, so you need to create them (ExcludeHttpsAutoDiscoverDomain, ExcludeHttpsRootDomain and ExcludeScpLookup should be enough).
crystal (strive4peace) - Microsoft MVP, AccessRemote Training and Programming
CERTIFIED EXPERT
Top Expert 2015

Commented:
thanks, Vasil
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.