How can I get my ricoh copier to scan to a shared folder on a different subnet?

awed1
awed1 used Ask the Experts™
on
As is usual, I'm in over my head.

We have two subnets. They meet at the Sonicwall which allows all normal traffic through - as far as I know.
We have a new Ricoh scanner that scans to shared folders on its subnet without any problems.
However, I haven't been able to get it to scan to folders on the neighboring subnet.
Is there a way to do this?
The computers are all Windows computers, Win 7 and a Small Business Server.
There is a place on the Ricoh interface for a username and password, but  none of the combinations that I have tried do any good.
Is there a way to place the login information into the \\address?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
If you are using DHCP  for all your Workstations, printers etc, It could be a problem.

Somehow you need to change the Subnet mask to 255.255.0.0  If the Printer/scanner is using a dynamic ip change it to a static ip and use the 255.255.0.0

Author

Commented:
Hi DTHConsulting,
Thanks for your quick response! We have DHCP enabled on each subnet, but most of the computers and switches and printers etc. addresses are static. The Ricoh is on a static address as well. I wonder how making the larger subnet will help. Right now, each subnet is /24. If I change the Ricoh's subnet to /16, won't it then be on a different subnet than everything else in that building? How will it still talk to the other devices on that subnet? Would I have to make that whole subnet /16?
Thanks, B.
If for example your ip is 192.168.1.x  with a subnet of 255.255.255.0  then you can only reach other ips that range from 192.168.1.1  to 192.168.1.254   - In this case, your gateway would need to be in the same range of x.x.x1 - 254

If however your same ip uses a subnet of 255.255.0.0  then you can address ips in the range
of 192.168.1.1  to 192.168.254.254.  

If you don't want some device (Workstation or other network device to be connected outside it's own subnet then on those devices use the 255.255.255.0

For those devices that need to span more than 1 internal subnet use the 255.255.0.0
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
DTHConsulting, Thanks. I understand what you are saying better now. I could have "supernetted" the first subnet and used a larger set of addresses. For instance, I could have had 510 addresses if I had used 255.255.254.0 and this problem would not have occurred. I was using the firewall to route between the subnets and it was all working fine until we got the Ricoh copier/scanner. That would work, but it would take a lot of scurrying around to implement, and we have some business application hardware that won't let us mess with the subnets for security reasons.

I had asked them because I like the simplicity of "supernetting" if you have time and the ability to go to each machine and reset its subnet mask, but I chose this route, using two subnets, because it cleanly separates the buildings etc. and the Business Application people said, "No."

So far, I don't know if the problem is just associated with this scanner, or if something else is coming into play.

Thanks again, B.
IT System Administrator
Commented:
simple question.
We have two subnets. They meet at the Sonicwall which allows all normal traffic through - as far as I know.
what I mean from this is you are normally reachable from one subnet to other subnet.
only the ricoh scanner has issue. so it seems you have no default gateway configured for ricoh's network interface. configure it then you will have access on either subnets.
then if you need to scan to share folder on the other subnet using ricoh scanner, you can do it with DNS or static IP.
if you configure host names on the ricoh scanner address book, then you need to have a DNS server which can resolve host names. it is the best option I suggest than using static IP.
you need to provide share folder authentication credential on ricoh to write to remote share.
I am using this setup with few subnets using my domain user authantication & works great.
using host names only with DHCP & no any complains.

Author

Commented:
upalakshitha,

Thanks!
I knew that couldn't be right because the factory rep had set-up the printer/scanner/copier.
However, when I looked more closely, there was a slight error in the gateway address.
Your solution was spot-on.
Thanks again,
B.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial