Windows service not running in windows server 2014

I have installed the windows service in windows server 2014. It  started successfully  but not  running jobs.
In the event viewer did not show any error messages. Event viewer saying just service is started, not any error or status message regarding the service.  The same service running in windows server 2008 and 2003  without any issues.
I do not have any source code to debug, how do i find out the issue ?but
Varshini SAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
Are you sure you are not talking about Windows Server 2012?  If so, how did you schedule the jobs (i.e. is it running using a domain account, have you configured it to run with highest privileges, what job are you trying to run, etc.).  Provide more details as well as any errors you might be getting in the event logs.
Varshini SAuthor Commented:
Sorry, i am talking about windows server 2012 r2 server not 2014. This service connect the SQL server and execute some queries.
 This service is running in administrator account.
Varshini SAuthor Commented:
Service is running in domain account
PMI ACP® Project Management

Prepare for the PMI Agile Certified Practitioner (PMI-ACP)® exam, which formally recognizes your knowledge of agile principles and your skill with agile techniques.

Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
Does the account have rights in SQL?  Does it work if you run the application manually? Is SQL installed on the same server as the service is having issues?  If not then have you tried the following:

1.  Ensure firewall is disabled
2.  Disable UAC

Have you tried making ODBC connection and tested it?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Varshini SAuthor Commented:
Thank You, I have disabled UAC , now its wworking.
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
You are welcome.  If your service is an EXE file, you could go to the properties for that EXE, click on Compatibility tab, click on box "Change settings for all users" and then check box "Run this program as an administrator" for Privilege level and you could still have UAC running (that is if your security policy requires UAC to be on).
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.