Link to home
Create AccountLog in
Avatar of grizrules
grizrules

asked on

Hyper-V-Integration Problems due to bad or not correct version

I looked through the post on here before posting a question.  So if this has already been solved please let me know.

I have two physical host running Win 2012 R2 STD

Each host is running three hyper-v machines, two of those replicate to the other physical host which they are not running on.

Physical machine 1 - 2012 R2 STD
Hyper -v machines: DC1 2012 R2 STD(not replicating) , File Server 2012R2 STD  (replicating to PM2) , Scan Server 2008R2 STD (replicating to PM2)

Physical Machine 2 - 2012 R2 STD
Hyper-v machines DC2 2012 R2 STD (not replicating), SQL server  2012R2 STD  (replicating to PM1), Printer  2012R2 STD  (replicating to PM1)

I ran some windows update the other day and planned a reboot of the Host and VM's.  That was on Dec. 4th.   Today Dec. 11 th, replication failed, from hyper-v manager on PM1 I could not connect to PM2 and vice versa, all replication was critical. critical.  
The first clue I had was that people could not print.

I checked the Hyper-V-Integration Admin log :

I did not see anything about Printer causing issues, however Scan states that the Hyper-V Data Exchange filed to connect to virtual machine Scan because the version does not machine the version expected by Hyper-V ( dfajde9ruewruei-df-a-asfd) Framework version. Negotiated (0.0) - Expected (3.0);
To fix this problem you must upgrade the integration services.  To upgrade , connect to the virtual machine and select Insert Integration Services Setup Disk from the Action Menu.

Under the windows log I got a warning for system: Networking driver in Scan loaded but has a different version from the Server version 5.0 client version 0.2.
unsupported config. To update select Insert Services Setup Disk from the Actin Menu

I called a friend and he suggested the do the same thing.  Which I have completed. However, when I go back into Hyper-V manager for scan under Networking it stated Degraded (integration Services update required) I preformed a Refresh but nothing.

The question is why when I reboot my host and bring up my VM's do they crash within a week and replication fails and I get an RPC error when trying to connect to the other Physcial host.  Why can people not print?
Is the Scan server causing all of this?  If show I thought integration services update would fix this.   I when through the steps but I don't believe it updated.

I have been reading these articles:
http://windowsitpro.com/hyper-v/newer-integration-services-windows-server-2012-hyper-v
http://windowsitpro.com/windows/common-hyper-v-configuration-problems

Any help appreicated
Avatar of grizrules
grizrules

ASKER

I apologize:
The Scan Server is actually Windows 2008 STD SP2
Build 6002

I also checked the system logs and have a bunch of DistributedCOM 10028 Errors
Dcom was not able to communicate with the computer PhysicalMachine2 using any of the configured protocols; request by PID
SOLUTION
Avatar of Philip Elder
Philip Elder
Flag of Canada image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Philip,
I have taken the steps by going to the VM's - "Action - "Insert Integration Services Setup Disk"

It appears to run but I still have the Status under Networking tab as "Degraded (Integration services update required" ?
The logs state that it will work but it's an unsupported configuration.   Is there something I'm doing wrong to update?   I looked at a chart for compatible VM's with Win2012 STD R2 and Windows 2008 STD was listed.
Right now replication is normal and working.   I just can't seem to update the status on the Scan server.
Plus ever time I reboot the two host and bring up the VM's within 7 days replication starts failing and I have to basically reboot again.

Am I missing something on updating the guest.iso correctly with my VM's ?

Thank you,
Mike
BTW:
All other VM's under the Summary tab display Integration Services: up to date.
However, Scan shows Heartbeat Unavailable and Integration Services is blank under the Summary tab within Hyper-V Manager
ASKER CERTIFIED SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account