SBS 2011 - Emails appearing to send but return with Delivery has failed to these recipients or groups message

Been made aware today of the following problem on a small business server 2011. It started on Friday - messages appearing
to send but coming back with the following message.

Delivery has failed to these recipients or groups:
Paul  (Paul@recipientdomain.co.uk)
The server has tried to deliver this message, without success, and has stopped trying. Please try sending this message again. If the problem continues, contact your helpdesk.
Mark  (Mark@recipientdomain.co.uk)
The server has tried to deliver this message, without success, and has stopped trying. Please try sending this message again. If the problem continues, contact your helpdesk.
Warwick and Lynn (recipientaddress@gmail.com) (recipientaddress@gmail.com)
The server has tried to deliver this message, without success, and has stopped trying. Please try sending this message again. If the problem continues, contact your helpdesk.





Diagnostic information for administrators:
Generating server: SERVER.sbs.local
Paul@recipientaddress.co.uk
#550 4.4.7 QUEUE.Expired; message expired ##
Mark@recipientaddress.co.uk
#550 4.4.7 QUEUE.Expired; message expired ##
recipientaddress@gmail.com
#550 4.4.7 QUEUE.Expired; message expired ##
Original message headers:
Received: from SERVER.sbs.local ([fe80::649a:3518:b3bc:e1c]) by
 SERVER.sbs.local ([fe80::649a:3518:b3bc:e1c%11]) with mapi id
 14.01.0438.000; Fri, 11 Dec 2015 16:16:30 +0000
From: User <dan@mycompanydomain.uk.com>
To: Paul  <Paul@recipientaddress.co.uk>, Mark
      <Mark@recipientaddress.co.uk>
CC: "Warwick and Lynn (recipientaddress@gmail.com)"
      <recipientaddress@gmail.com>
Subject: RE: Deliveries due next week (W/C 14th December)
Thread-Topic: Deliveries due next week (W/C 14th December)
Thread-Index: AdEyfvzWWwBUDlKIT8udyNTjsoIIJwAAAVpAAGuz2AAAAFRxcA==
Disposition-Notification-To: Usernam <dan@mycompanydomain.uk.com>
Date: Fri, 11 Dec 2015 16:16:29 +0000
Message-ID: <0AAEEA9084EA11499051F8014B67EFBA404C6289@SERVER.sbs.local>
References: <0AAEEA9084EA11499051F8014B67EFBA404C51E4@SERVER.sbs.local>
 <DB5PR03MB13687047D19A2C31FD29D1F09EEA0@DB5PR03MB1368.eurprd03.prod.outlook.com>
In-Reply-To: <DB5PR03MB13687047D19A2C31FD29D1F09EEA0@DB5PR03MB1368.eurprd03.prod.outlook.com>
Accept-Language: en-GB, en-US
Content-Language: en-US
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator:
x-originating-ip: [192.168.16.11]
Content-Type: multipart/related;
      boundary="_004_0AAEEA9084EA11499051F8014B67EFBA404C6289DESMAT1sbslocal_";
      type="multipart/alternative"
MIME-Version: 1.0

Nothing has changed. The sbs self certificate expires on the 16/12/15 so I ran the fix my network wizard yesterday just selected that
to fix it. This was before I knew abou the problems.


Really need some help on this one, thanks in advance.
floyd197Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RantCanSr. Systems AdministratorCommented:
So you renewed your self-signed cert successfully. Should not be an issue for your maildomain.com certificate, unless you have services assigned to your self-signed.

Have you tried to test your mailflow with:

https://www.testexchangeconnectivity.com
floyd197Author Commented:
Is this safte to Run? will it cause any other problems? is it the internet email tests I require and then
outbound smtp mail
RantCanSr. Systems AdministratorCommented:
Literally just tests deployed services and makes no changes. You should enable some test accounts to use the tool and see what kind of results you get. This tool is invaluable for troubleshooting mail delivery. It appears that outbound smtp is your issue; defo test that first. Post the results to aid further EE troubleshooting.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

floyd197Author Commented:
Thanks. Here are the results


Performing Outbound SMTP Test
       The outbound SMTP test was successful.
       
      Additional Details
       
Elapsed Time: 14729 ms.
       
      Test Steps
       
      Attempting reverse DNS lookup for IP address ip removed.
       The Microsoft Connectivity Analyzer successfully resolved IP address ip removed via reverse DNS lookup.
       
      Additional Details
      Performing Real-Time Black Hole List (RBL) Test
       Your IP address wasn't found on any of the block lists selected.
       
      Additional Details
       
      Test Steps
      Performing Sender ID validation.
       Sender ID validation was performed successfully.
       
      Additional Details
       
Elapsed Time: 1115 ms.
       
      Test Steps
       
      Attempting to find the SPF record using a DNS TEXT record query.
       The Microsoft Connectivity Analyzer wasn't able to find the SPF record.
       
      Additional Details

I used the ext Ip address. Was this correct

Would the transport connectivity log help
floyd197Author Commented:
Here is a shortened Transport Connectivity Log
TCL.txt
David Johnson, CD, MVPRetiredCommented:
First many sites will not accept mail from a site without a valid spf record.  You seem to be having problems with your smarthost.. try recreating it.
RantCanSr. Systems AdministratorCommented:
Agreed; your smarthost can provide you an spf record for your DNS to ensure the traffic is permitted.

Also, this wizard can help.

http://www.spfwizard.net/
floyd197Author Commented:
Mail has been ok for 2 years. Using the connect to the internet wizard?  Is it ok to run it again
after it has been run for the first time
floyd197Author Commented:
Should I run the setup your internet address wizard
David Johnson, CD, MVPRetiredCommented:
yes you can run it again. it is obvious that you can't hurt anything since your mail is not getting past the smart host.
floyd197Author Commented:
I meant the configure smart host wizard
RantCanSr. Systems AdministratorCommented:
You can; otherwise you can look for the exchange connector in your EMS and adjust accordingly. It may be that your smarthost IP changed or somesuch. If things were working without incident for 2 years, it should be taken as read that something changed; if you made no changes, it must have been on the internet.

http://www.netometer.com/video/tutorials/SBS-2011-how-to-configure-smarthost/
floyd197Author Commented:
Yes It was originally setup to use a smart host - the isp's outgoing mailserver. It has
been working fine since it was configured. The static IP is the same. The only thing I have done
is run the fix my network wizard to update the sbs self cert. Do you think being blacklisted can
be ruled out as ity passed the remote connectivity analyser test?
RantCanSr. Systems AdministratorCommented:
Check your mx record at mxtoolbox.com. It will tell you if you have been blacklisted, maybe on some lists taht the other test didn't check. You can also check your DNS health at intodns.com
floyd197Author Commented:
Appears not to be blacklisted
HariomExchange ExpertsCommented:
Send e-mail to Mark  (Mark@recipientdomain.co.uk) using telnet and post the results

It seems your DNS is not able to resolve recipientdomain.co.uk name

From your exchange telnet to recipientdomain.co.uk and post the results.

http://exchangeserverpro.com/how-to-send-email-via-telnet/
floyd197Author Commented:
The isp has confirmed it is an issue with them. It was confirmed that it is now fixed this morning.

Emails are sending but there appears to be a long delays - i assume cause by the backlog
or are not being delivered. Are delays of 5 hours the norm or to be expected.

Thanks
David Johnson, CD, MVPRetiredCommented:
no it is not the norm.. I've invoiced, recieved, and transferred payments via email under 5 minutes
floyd197Author Commented:
So could they still be having problems then
floyd197Author Commented:
Now seems to be sending - all the queued mail seems to have gone. But new emails seem to send
but is not being delivered. Nothing had been changed before the Isp problems and have now
allegedly been fixed. Is it possible they are still having problems. I have had a look at the exchange connector logs. Do they point towards the problem?

2015-12-16T21:09:12.367Z,08D306015D708086,MapiSubmission,95368524-0514-4881-80ed-5555c5b368d5,+,SERVER.sbs.local
2015-12-16T21:09:12.846Z,08D306015D708087,SMTP,smtp-bb1.Telecomprovider.net,+,SmartHostConnectorDelivery 3bd7b3c0-f5c5-46f7-9bd5-f741f5d4d4d6;QueueLength=1
2015-12-16T21:09:13.078Z,08D306015D708087,SMTP,smtp-bb1.Telecomprovider.net,>,"p.nsm.ctmail.com[2001:470:1f04:815::2, 216.163.188.57, 216.163.176.42, 38.113.116.194]"
2015-12-16T21:09:13.079Z,08D306015D708087,SMTP,smtp-bb1.Telecomprovider.net,>,Failed connection to 2001:470:1f04:815::2 (NetworkUnreachable:00002743)[TargetIPAddress:2001:470:1f04:815::2|MarkedUnhealthy|FailureCount:1|NextRetryTime:2015-12-16T21:10:13.079Z]
2015-12-16T21:09:13.079Z,08D306015D708087,SMTP,smtp-bb1.Telecomprovider.net,-,Messages: 0 Bytes: 0 (Attempting next target)
2015-12-16T21:09:13.079Z,08D306015D708088,SMTP,smtp-bb1.Telecomprovider.net,+,SmartHostConnectorDelivery 3bd7b3c0-f5c5-46f7-9bd5-f741f5d4d4d6;QueueLength=0
2015-12-16T21:09:13.243Z,08D306015D708088,SMTP,smtp-bb1.Telecomprovider.net,>,Established connection to 216.163.188.57
2015-12-16T21:09:14.797Z,08D306015D708088,SMTP,smtp-bb1.Telecomprovider.net,-,Messages: 1 Bytes: 3850 ()
2015-12-16T21:09:21.072Z,08D306015D708086,MapiSubmission,95368524-0514-4881-80ed-5555c5b368d5,-,RegularSubmissions: 1 ShadowSubmissions: 0 Bytes: 5579 Recipients: 1 Failures: 0 ReachedLimit: False Idle: True
2015-12-16T21:12:11.026Z,08D306015D70808A,MAPI,mailbox database,+,Delivery;QueueLength=1;DatabaseHealth=-1;MailboxServer=SERVER.sbs.local
2015-12-16T21:12:11.026Z,08D306015D70808A,MAPI,mailbox database,>,Starting delivery
2015-12-16T21:12:11.056Z,08D306015D70808A,MAPI,mailbox database,>,Connecting to server SERVER.sbs.local session type Mailbox
2015-12-16T21:12:11.403Z,08D306015D70808A,MAPI,mailbox database,-,Messages: 1 Bytes: 3970 Recipients: 1
2015-12-16T21:12:11.818Z,08D306015D70808B,MAPI,mailbox database,+,Delivery;QueueLength=1;DatabaseHealth=-1;MailboxServer=SERVER.sbs.local
2015-12-16T21:12:11.818Z,08D306015D70808B,MAPI,mailbox database,>,Starting delivery
2015-12-16T21:12:11.872Z,08D306015D70808B,MAPI,mailbox database,>,Connecting to server SERVER.sbs.local session type Mailbox
2015-12-16T21:12:11.971Z,08D306015D70808B,MAPI,mailbox database,-,Messages: 1 Bytes: 3958 Recipients: 1
2015-12-16T21:12:40.789Z,08D306015D70808D,MapiSubmission,95368524-0514-4881-80ed-5555c5b368d5,+,SERVER.sbs.local
2015-12-16T21:12:41.174Z,08D306015D70808E,SMTP,smtp-bb1.Telecomprovider.net,+,SmartHostConnectorDelivery 3bd7b3c0-f5c5-46f7-9bd5-f741f5d4d4d6;QueueLength=1
2015-12-16T21:12:41.187Z,08D306015D70808E,SMTP,smtp-bb1.Telecomprovider.net,>,"p.nsm.ctmail.com[2001:470:1f04:815::2, 216.163.188.57, 216.163.176.42, 38.113.116.194]"
2015-12-16T21:12:41.188Z,08D306015D70808E,SMTP,smtp-bb1.Telecomprovider.net,>,Failed connection to 2001:470:1f04:815::2 (NetworkUnreachable:00002743)[TargetIPAddress:2001:470:1f04:815::2|MarkedUnhealthy|FailureCount:2|NextRetryTime:2015-12-16T21:13:41.188Z]
2015-12-16T21:12:41.188Z,08D306015D70808E,SMTP,smtp-bb1.Telecomprovider.net,-,Messages: 0 Bytes: 0 (Attempting next target)
2015-12-16T21:12:41.188Z,08D306015D70808F,SMTP,smtp-bb1.Telecomprovider.net,+,SmartHostConnectorDelivery 3bd7b3c0-f5c5-46f7-9bd5-f741f5d4d4d6;QueueLength=0
2015-12-16T21:12:41.352Z,08D306015D70808F,SMTP,smtp-bb1.Telecomprovider.net,>,Established connection to 216.163.188.57
2015-12-16T21:12:42.175Z,08D306015D70808F,SMTP,smtp-bb1.Telecomprovider.net,-,Messages: 1 Bytes: 1114 ()
2015-12-16T21:12:46.517Z,08D306015D70808D,MapiSubmission,95368524-0514-4881-80ed-5555c5b368d5,-,RegularSubmissions: 1 ShadowSubmissions: 0 Bytes: 4881 Recipients: 1 Failures: 0 ReachedLimit: False Idle: True
2015-12-16T21:12:53.968Z,08D306015D708090,MapiSubmission,95368524-0514-4881-80ed-5555c5b368d5,+,SERVER.sbs.local
2015-12-16T21:12:54.204Z,08D306015D708091,SMTP,smtp-bb1.Telecomprovider.net,+,SmartHostConnectorDelivery 3bd7b3c0-f5c5-46f7-9bd5-f741f5d4d4d6;QueueLength=1
2015-12-16T21:12:54.204Z,08D306015D708091,SMTP,smtp-bb1.Telecomprovider.net,>,"p.nsm.ctmail.com[216.163.188.57, 216.163.176.42, 38.113.116.194]"
2015-12-16T21:12:54.368Z,08D306015D708091,SMTP,smtp-bb1.Telecomprovider.net,>,Established connection to 216.163.188.57
2015-12-16T21:12:55.190Z,08D306015D708091,SMTP,smtp-bb1.Telecomprovider.net,-,Messages: 1 Bytes: 1122 ()
2015-12-16T21:13:01.519Z,08D306015D708090,MapiSubmission,95368524-0514-4881-80ed-5555c5b368d5,-,RegularSubmissions: 1 ShadowSubmissions: 0 Bytes: 4905 Recipients: 1 Failures: 0 ReachedLimit: False Idle: True
2015-12-16T21:22:11.833Z,08D306015D708094,MAPI,mailbox database,+,Delivery;QueueLength=1;DatabaseHealth=-1;MailboxServer=SERVER.sbs.local
2015-12-16T21:22:11.833Z,08D306015D708094,MAPI,mailbox database,>,Starting delivery
2015-12-16T21:22:11.891Z,08D306015D708094,MAPI,mailbox database,>,Connecting to server SERVER.sbs.local session type Mailbox
2015-12-16T21:22:12.090Z,08D306015D708094,MAPI,mailbox database,-,Messages: 1 Bytes: 3879 Recipients: 1

Thanks
HariomExchange ExpertsCommented:
2015-12-16T21:09:13.079Z,08D306015D708087,SMTP,smtp-bb1.Telecomprovider.net,>,Failed connection to 2001:470:1f04:815::2 (NetworkUnreachable:00002743)

Yes as per logs it is possible they are still having problems.

Logs indicates "NetworkUnreachable:00002743"
floyd197Author Commented:
Thanks.
floyd197Author Commented:
The Isp have investigated the issues with the smarthost - I sent them the exchange logs.

The response is below.

To be hosest I am not entirely certain what they mean. Mail was working fine before the problems they had so what other problems could it have caused.

Thanks

 

I have raised this to the technical assistance team, they have completed the investigations and have advised of the following:

 

The BB is working fine, if there is an issue sending emails using an advanced or IMAP mailbox then the customer must log the fault with UK2.net – their domain registrar, because emails won’t even use Chess’ mail servers.

 

If the customer needs to use Chess’ mail servers then they should put in the LLU SMTP servers.  But they will have to change these settings to each different location’s provider if the device is mobile (ipad/phone/laptop), for each site the customer goes to (home, work etc.).
floyd197Author Commented:
Any thoughts?
floyd197Author Commented:
Anybody
floyd197Author Commented:
The ISP have said to add th efollowing settings

Primary dns 62.24.134.x

Secondary dns  62.24.243.x

Where abouts do I add these settings in the send connector
RantCanSr. Systems AdministratorCommented:
Under Hub Transport, they want you to add these to the external DNS lookup settings, I think. Is your send connector set to a smarthost, MX records, or for External DNS.
floyd197Author Commented:
Smarthost - using isp's SMTP server. This is how it was setup originally.
floyd197Author Commented:
Switched to another mailserver to get working
floyd197Author Commented:
Sorted by switching to another mail server
floyd197Author Commented:
Thanks for the suggestions. Ended up using another smarthost to solve the problem

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
floyd197Author Commented:
Changing to another smarthost was the only think that solved the problem
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.