Link to home
Avatar of JB Blanco
JB BlancoFlag for United States of America

asked on

Cannot connect to any of my VDP appliances on Vcenter Web Interface

VDP version 5.8.0.467


We have 2 VM  VDP Appliances and one shows all services running but on the other, services wont come up.  

Both have been registered to VCenter but are showing status Not Connected.

I cannot manage any of them through Vcenter Web Interface.  

I have tried rebooting both.

I have tried rolling back - results in failure

I am out of ideas at the moment.

Need your help

thanks
Avatar of Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Flag of United Kingdom of Great Britain and Northern Ireland image

Ensure, that the CPU are set to 4 vCPU and 16GB RAM for the appliances.

I think we have had several discussions already about the issues that exist with VDP

1. Poor Storage performance.
2. Poor configuration and resources.
3. VDP is poor anyway.
4. Random issues with checkpoints, rollbacks, not shutdown correctly.

To be honest with you.....

I would install a new appliance, and import the old repos. (our clients have to do this regularly every 12 months approx!)

OR

1. Call VMware Support, that will escalate to EMC support, to help you recover your data.

OR

Consider seriously if you want to use a flawed solution, VDP is no better than VDR, VMware/EMC should really leave backups to the professionals, and switch to Veeam Backup and Replication or NAKIVO.

I would be repeating again, other posts.....
Avatar of JB Blanco

ASKER

i forgot to mention they are already at 4cpu and 16gb ram.

I know its flawed but this is all i have to work with and they do not want to implement another solution unfortunately.

I would like install a new appliance and import the old repository, but i have never done this before.  I can go ahead and start provisioning a new VM to get started but would be kind enough to sorta walk me through it?
ASKER CERTIFIED SOLUTION
Avatar of Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Flag of United Kingdom of Great Britain and Northern Ireland image

Blurred text
THIS SOLUTION IS ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Thanks but.... new DNS?  

Our DNS is not changing.  So i am not sure what you mean by new DNS.    

IP address we can change without a problem but what is your reasoning behind you recommending these changes?
I meant new IP Address, registered with DNS!

new IP Address, so there is no confusion of vCenter Server and the failed VDP appliances, they can be removed and deeregistered later, when you have your new VDP servers up and running!
Im reading your article.

can i upgrade to ver 6.1.1?  I believe this is the latest from Vmware Website.

Is it backwards compatible with our current version?  5.8.0.467
no as stated in the beginning of this thread.  i am on 5.8.0.467
sorry i thought you meant VDP.

yes i am currently on Vsphere 5.5
VMware vSphere Data Protection 6.1.1 is compatible with vCenter Server 5.5, 5.5 U1, U2 and U3 and also ESXi 5.5, U1, U2, and U3 hosts.

from the

VMware Product Interoperability Matrixes
Thank you!
Quick question,

I see we have 2 VDP VMs named vdp1tb and vdp2tb.  I am not sure why they named it this way.  When i look at both VM settings, they are identical.  What do you think this refers to?

Is it a setting within VDP appliance itself? or the Web Interface?
You could be right.  Is this somthing i configure within the VDP setup?
Correct, based on disks presented to the appliance.
ok i have a little problem  

The 2 VDP vm's i have are now turned off cause i am following your guide.  But when i go to deploy the OVA template, when i get to the Format Disk section, i choose thick eager zeroed but i cannot set the size of the disk.  IT does not ask me what size to set the disk.  it chooses 200gb!  and i want it to be 100GB.  Does VDP version 6.1.1 require 200gb?  cause thats the only reason why i see that its doing this.    I even tried setting it back to 100gb after the depolyment finnished while the VM is in a powered off state and it still would not let me change it.
You import he OVA as is! You cannot specify a size, VMware has designed the appliance, you just import it!

So yes.....do not tamper with the design of he VMware VDP Appliance, it runs poorly enough as it is, it does not require any more modifications!
OK!!!!!!!!!!!!!!!!!!!!!!!!!!!!

how do you like the Exclamation points??!!!
Hey, its been stuck on Deploying OVA template and i see no progress.  Been like that for about 12 min so far.

This happened when i chose Thick Eager Zeroed for the disk format part.

is this normal?
Depending upon your storage, it can take many minutes to deploy an eager zero virtual machine disk, because it clears all the zeros, on the 200GB sectors in the VM.

So yes!
ok yes my storage is basically as you already know, Local storage on the Host.  

So that may also be a factor of the slowness

thanks
Yes, it can take a while.

Eager versus Lazy Zero (the VM disk sectors are zeroed before data is written, so their is added latency in a VM with a lazy zero disk).

So Eager versus Lazy Zero perform better.
ok, just so you are aware, i have the 2 VDP appliances turned off but they each contain 7 Virtual Hardisks with 256gb each Disk.  I only have about 2.1TB left on this host's local storage to add the same amount of disks to this newly deployed VDP.  

Should i use the existing disks or create new ones?
You add existing repos from the busted VDP appliance to the new VDP appliance! (one at a time!).

So you need to build two new VDP appliances, and add their existing disks. So you end up with two new appliances, and your existing Repos from failed VDP appliances.

and see if the new VDP appliance works with the existing Repos, this is how to recovery your backups and dead VDP servers, otherwise it's

1. call VMware support to recover.
yes but do i need to give it the same amount of virtual disks as the defective VDP VM's?

thats my question
Just add existing Repo disks.

You are not creating any new storage you are attaching old disks, in the hope that the new VDP appliance, can index these old repo, and you can recover your backups....

If you do not want to recover your backups, then just re-create new storage for blank new VDP appliances.
Hi,  merry christmas!

hope your avaliable,

I am at the part in your article where i have to create storage.  Now since i already attached the Virtual Disks from the old VDP, when i chose the radio button "Attach existing VDP storage" it gives me an error prompt saying "Cannot proceed because the appliance already has attached storage."

so then what choice to i chose?  do i create new storage? or VDP Migration?
You follow the wizard, and let the Wizard attach the existing storage. So do not add it in advance.
Sorry, was about to reply back with "Never Mind"  your right.  i just removed the disks i added in advance, and then re-added them using the wizard.

Ok i am at the part where i restore now.  

I noticed Vcenter is showing the appliance is doing an integrity check.  

I am going to go ahead and proceed and keep you updated as i go.  But should i wait for the integrity check to complete?

Also, on a side note.... The maintenance service is not starting up on the appliance.
Okay i dont see the replicate folder as your article states.

I am sure i am connected to the new VDP appliance ver 6.1  but on the restore backup section of the web gui, the drop down shows no folder at all.
On a side note... all the services are backup on the appliance.  The maintenance service just took awhile to come up i guess.  

So i am basically at a stand still here.  NOt sure why i dont see the imported replicated restore points.

I am following your article to the T.  

I web'ed into the vdp appliance itself and noticed that there is an older roll-back point that i could try rolling back to.  But its not validated of course.  

let me know what i should do
SOLUTION
THIS SOLUTION IS ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
you could be right about it being corrupt.

but when i brought up the 5.5.8.0.467 appliances, they would come up but the services on one would not start up.  So i webbed into the one where the services where started and i could see in emergancy restore section that it had a backup repository,  i did not try to restore however.

I could not access either of them via Vcenter Web gui.  When i tried to connect to them from the VDP section of Vcenter, it would just freeze.  

thats what started this whole mess and thats why i am trying your article .  

So now i am downloading ver 5.5 and 5.8 just incase.
You need to decide if you want the backups in he repository.

If you do not need them, trash them all and start again, if you do need them, restore them, and back them up again in a new working VDP server.
ok i am settling for "They Corrupt"  so since i already added the Disks from the Corrupt VDP Appliance to this new Ver 6.1 VDP appliance,  can i just start backing up VM's and a new Repository will be written over everything and all will be fine?
No, do not do this. TRASH, and create a sparkling new VDP 6.1, with new storage, and start again.
Thanks
have to start all over now
Ok i just finished deploying a new VDP 6.1 appliance.  and going through your article, created new storage 1TiB but i chose Thick Eager Zeroed.  I beleive you said this is recommended.  

I have a question.  The older 5.8 Appliance had a total of 7 disks and it was 1TiB.   Each disk was roughly 256gb in size.  Now with this new Appliance, it will only allow me to create 3 Disks for the 1TiB new storage.  

is this normal?

should it be like the old appliance with 7 disks?
SOLUTION
THIS SOLUTION IS ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
Thanks!

i will let you know once i complete everything and hopefully i can get backups working again on ver 6.1

will update this thread once complete
Ok i was successfull!

I just scheduled for this friday backups  i took half of the VM's on 1 appliance, and the other half on the other.  they will both kick off simultaneously at 11:30pm  

Is that best practice for this type of setup?  remember that i am using local host storage which has been provisioned for Thick Eager Zeroed.
Andrew Hancock is the MAN!