Windows 2008 Server

I am getting this error when trying to copy a file on the C-drive:
"you'll need to provide administrator permission to copy to this folder"

The user is a member of the local admin group.
How can I disable this specific notification?
exhuserAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
You need to open cmd.exe in Admin Mode. Right click on cmd.exe and select Run as Administrator.

If you are using Notepad, say for the Hosts file, you need to open Notepad with Run as Administrator.
exhuserAuthor Commented:
How does it fix the copying files issue?
JohnBusiness Consultant (Owner)Commented:
It normally allows copying to protected areas like user folders and program folders
Exploring SQL Server 2016: Fundamentals

Learn the fundamentals of Microsoft SQL Server, a relational database management system that stores and retrieves data when requested by other software applications.

exhuserAuthor Commented:
OK. How can I disable this message permanently?
JohnBusiness Consultant (Owner)Commented:
The message comes up when you need permissions , so it does not go away permanently . However you should not see the message if you have adequate permissions
exhuserAuthor Commented:
I understand this. Are you saying there is no way to disable this message if the user is a member of the local admin group?
JohnBusiness Consultant (Owner)Commented:
If you are admin and you are trying also to go where further elevated permissions are needed (examples above), there is no way to eliminate the message.
NVITEnd-user supportCommented:
The security permissions on the folder may be amiss. One solution is to adjust the Security for the folder or file. Clear then reassign the users / groups.
JohnBusiness Consultant (Owner)Commented:
I assume in my information above that folder permissions are correct (as is normal on a server) so please let us know if not.
exhuserAuthor Commented:
The security permissions are standard -- right after the installation.
JohnBusiness Consultant (Owner)Commented:
Then you need to live with the message unless you first use elevated permissions.
neel_7575Commented:
You may need to disable User Account Control (UAC) setting in your server.

This article may guide you further:

https://support.microsoft.com/en-us/kb/2526083

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JohnBusiness Consultant (Owner)Commented:
NEVER - NEVER disable UAC on a Server. Don't. That is the WRONG thing to do.
Lee W, MVPTechnology and Business Process AdvisorCommented:
Question - WHY are you copying FILES to the root of the drive?  There is RARELY a good reason to do so.  You can easily make new folders and copy files to folders.  If you really MUST copy a file or two to the root, fine, deal with the error message, complete the copy - but don't do something every professional IT person I know would consider absolutely foolish - like disabling UAC!
R. Andrew KoffronownerCommented:
I like the good comment option, but maybe a bad comment button is needed, for suggesting you remove UAC, I can't imagine when I'd consider doing this on a production server.

As for copying files to the Root, I can think of a couple reasons I'd consider it like avoiding local paths, being long than my User Paths, by making initial Shared C:\net but making the share "Network Shared Files" especially when moving company files from other hardware.

Basic Production Servers really shouldn't have people logged into them enough for the elevated permsions "run as Administrator" to be a big issue.
exhuserAuthor Commented:
I actually found a registry fix, but as this Microsoft article says, "Under certain constrained circumstances, disabling User Account Control (UAC) on Windows Server can be an acceptable and recommended practice"
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.