Win 7 systems getting : The server was unable to allocate from the system nonpaged pool because the server reached the configured limit for nonpaged pool allocations.

I have some win7 systems getting this error in the system event viewer:  The server was unable to allocate from the system nonpaged pool because the server reached the configured limit for nonpaged pool allocations.

Now these systems have data stored on them that other system access.  they really just started getting the error about 3 weeks ago. After looking it up it shows that it usually because the system is used as a server and getting alot of connections from other systems.

Any way to verify this this, or how many connections these systems are getting?
rdefinoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ralph PickeringInfrastructure ConsultantCommented:
Performance monitor ought to do it. Add a counter for Server... Server Sessions for starters.
Ralph PickeringInfrastructure ConsultantCommented:
Regarding the error, you could try this registry change:

Set HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache to 1 (the default is 0)

Set HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size  to 3 (default is 1)

Restart for the changes to take effect.

You would, however, be better off getting a dedicated server as you're hitting the limit of what can be expected of a desktop OS. Something like Server 2012 R2 Essentials on an entry level server like an ML310e would be ideal and not too expensive (I use one at home for running Plex, and it thrashes the HP Microserver it replaced). Alternatively, a small NAS, like a Synology DS416 would be perfect. Just my 2 cents...

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Technical Support @ Pro-Tek Integrations, LLCCommented:
I have some win7 systems getting this error in the system event viewer:  The server was unable to allocate from the system nonpaged pool because the server reached the configured limit for nonpaged pool allocations.

I have been experiencing the same issue but this only started after the client introduced a Windows 10 Machine into the network. Somedays I need to reboot it ever few hours and then others it will go several days but the only way I can gain access to the shared folder again is to reboot the machine.

Regarding the error, you could try this registry change:

Set HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache to 1 (the default is 0)

Set HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size  to 3 (default is 1)

Restart for the changes to take effect.

I just completed this registry change but cannot reboot the system at this time but will post if this helps me one I am not needing to reboot said system for at least a week!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.