Winnsi.dll errors in Windows 7

The attached error pops up with any attempt to run anything in my Windows 7 machine. I have a clean winnsi.dll file but I get permission blocks when I try to overwrite the problem winnsi.dll file. I have tried everything I could find to set the permissions and nothing works. I see online that I should be able to just copy it and overwrite the problem file. I have purchased and run registry cleaners and it still pops up.

I understand this file is used by most if not all programs. I can't even launch the Task Manager, cannot access any external devices or an internet connections. I also lost my network. All seems to be related to this file. Suggestions?

 winnsi.dll error message
weknowjackAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPRetiredCommented:
1. run msconfig and diagnostic startup.
2. run sfc /scannow 2x or until it returns no errors.
weknowjackAuthor Commented:
Thanks but how/where would I do that?
weknowjackAuthor Commented:
I found msconfig but it has many options. do I only check diagnostic startup? Anyway, that's what I did and restarted. Then did the sfc from a command prompt and the attached shows what it returned:sfc result
OWASP Proactive Controls

Learn the most important control and control categories that every architect and developer should include in their projects.

David Johnson, CD, MVPRetiredCommented:
start cmd  right click on the cmd icon and select run as administrator

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
weknowjackAuthor Commented:
Ok, did that, now this - attached

scannow result
Rob LeaverSr. Network & Server EngineerCommented:
Are you able to boot into safe mode? If so, do you still receieve the same errors?
weknowjackAuthor Commented:
I had to enable the Windows Module Installer. Now sfc is running, currently at 25%. We'll see what's next.
weknowjackAuthor Commented:
It worked. the error is gone. Thanks much, David.
weknowjackAuthor Commented:
this got it fixed. read the entire thread.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.