Windows 10 Desktop Delay

JayEmEmm
JayEmEmm used Ask the Experts™
on
Since upgrading to Windows 10, the log-on screen comes up quickly, but after logging on, the desktop takes more than 2 minutes to appear.  During this delay, the screen is black with nothing else appearing.

At first I thought it was the Spy Hunter program because Task Manager showed it using a significant amount of resources during that time.  But I uninstalled Spy Hunter and the delay is exactly the same.  Task Manager does not show any large use of resources now.

What could be causing this delay?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Distinguished Expert 2018

Commented:
I saw this once or twice with version 10240, but never with v1511. Do you run 1511?
The command
winver
will tell you the version.

Author

Commented:
Yes, my version is 1511
Distinguished Expert 2018

Commented:
Do two tests: create another user and logon as him
if no better, boot safe mode as shown here
OWASP Proactive Controls

Learn the most important control and control categories that every architect and developer should include in their projects.

Author

Commented:
I went into user accounts in Control Panel.  When I tried to execute the link for Add a New User, it would not respond.

I booted in Safe Mode, and the desktop came up in a much shorter time without the delay.
Distinguished Expert 2018

Commented:
Good.
The next step logically is to find out what is the difference between safe mode and normal mode. In normal mode, all drivers are loaded - not in safe mode, there, only a basic set of drivers is loaded.
In safe mode, neither are all services loaded.

So it seems, it's either a driver or service causing the problem. To come closer, do the following: start msconfig (via winkey+r) and disable all non-microsoft services and reboot.

Author

Commented:
I disabled all non-Microsoft services (2 remained checked--they were AVG Antivirus related).  Desktop still had delay.
Distinguished Expert 2018
Commented:
Ok, from here on, it will be harder. Download autoruns from microsoft. With it, you can disable all the stuff that runs automatically, including drivers. Start it via right click option "run as administrator".
You can first save all entries as they are, but be careful, reopening the saved state does not mean you have rebuild it. It's just a way to look at how it was before you tuned it.

Author

Commented:
Update on progress:

I downloaded Autoruns and began disabling a few selected individual items.  With no initial success in finding the cause of the delay, I then begain looking at entire groups as selectable from the menu bar.  I disabled all from the drivers, Task Scheduler, codecs, Winlogon, Logon, Explorer, and Internet Explorer groups one group at a time.  I assumed we already covered the Services group when we disabled all non-Microsoft services in msconfig.

When I disabled all in the Drivers group, the computer would not reboot (boot device not found).  I recovered from that and disabled all non-disk related drivers in the Drivers group.  None of these disabled groups was shown to be the cause of the problem.  The disk-related drivers are still untested, but I am hesitant to cause the boot problem again.

I could not discern what in the disk-related drivers may have caused the boot failure problem.  Is there a way to determine this?  Any other ideas on how to proceed?

I really appreciate your help.
Distinguished Expert 2018

Commented:
You should not mess with things that you don't understand. The disk controller drivers are the only thing that we may not disable since then, the hard drive cannot be accessed and nothing, literally nothing would work. All the other things can have side effects, but should not keep the system from booting. Nevertheless, we need to be careful and given the amount of entries that you see, you might lose yourself in it.
What I'd do: there's a column "publisher". Look at all the 3rd party stuff and disable those, leaving only the microsoft stuff in and the basic drivers.

Author

Commented:
Although I was unable to find the cause of the delay using Autoruns,  that was a good troubleshooting tool that I was unaware of.  So using that tool gave me a lot of information on my problem and will be a good tool to use in the future.

Author

Commented:
I finished checking each of the drivers, but none of them proved to be the cause of the problem.  I ended up re-installing Windows 10 and that cleared the delay.  There were several other minor quirks that were occurring in the old installation, and these were cleared up too.  So the cause of the delay may have been a glitch in the Windows 10 upgrade process.  

At this point, Windows 10 is operating well and the computer is running fine.

I greatly appreciated your help, and you introduced me to the Autoruns tool that gave me a great deal of information regarding my problem.  It will be great tool to use in the future.

Thanks again for your help.
Distinguished Expert 2018

Commented:
Welcome.
One more thing to learn: before we reinstall, there's always the inplace upgrade

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial