Parallels on iMac with Windows10 - iMac sees all networked PC's - Parallels does not

I have a client.  The owner has a new iMac from which he uses Parallels to run Quickbooks with the data file on a Windows networked PC running Windows 10.  

All shared files on the Windows PC allow "Everybody" total access.  All PC's on the network can see all shared folders on the Windows PC that has the Quickbook Folder "Shared".

On the iMac, bringing up Network shows the entire network, and the shared folders.  

When Parallels is fired up on the iMac, the Windows PC doesn't appear.  As a consequence, he can't access the Quickbooks Company File.

The network connection on the iMac is set to wireless.  I've checked switching to a wired, bridged connection with the same results.  

So, we have a new iMac with Parallels installed so the client can work with Quickbooks 2016 as a client of the "Host" PC where the company file is stored under a Multi-User License.  But, although in the Apple OS, he can see all network PC's, the minute he fires up Parallels - Starts Windows 10 - That host machine isn't seen.
JONINBENDAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bbaoIT ConsultantCommented:
the VM on Parallels should be using "Bridged Networking" directly access the SAME subnet of where the iMac is based. see below for the details.

Which networking mode (Bridged, Shared or Host-Only) should I use for the virtual machine?
http://kb.parallels.com/au/4948

as you mentioned, you have probably already done this but you do need to verify the settings by checking if the iMac and the VM  are on the SAME subnet and can PING each other.
Davis McCarnOwnerCommented:
Try this first and see if it gets better:
Are you signed in to Windows 10 with a Microsoft Account?

If so, you’ll want to switch to a Local Account if you’re using old-fashioned folder sharing instead of a Homegroup. As far as I can tell, this is the only way to fix it.

To switch to a local account:
1.Click Start
2.Type: account
3.Click Change your account picture or profile settings
4.Click the link: Sign in with a local account instead

From this page: http://scottiestech.info/2015/08/01/10-fixes-for-common-problems-in-windows-10/
JONINBENDAuthor Commented:
So, as I understand it, I should go into the Windows 10 virtual machine on the iMac, and sign in as a local account.....?  

BTW, I did notice at the same business, one PC was part of a homegroup, and couldn't be seen until I deleted the homegroup. Not an identical situation, but along the same lines.  Essentially, you can't have it both ways.

It's the weekend, so I'll hit it again on Monday, and let you know if it worked.  Thank you
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

bbaoIT ConsultantCommented:
> checking if the iMac and the VM  are on the SAME subnet and can PING each other.

before workgroup authentication, the network level verification should be done first. did you do that?
JONINBENDAuthor Commented:
Well, it turned out to be a user issue.  Their PC couldn't be seen because they had made it "Private".   Once I discovered that, I went into the settings (Windows 10), and turned it off for public networks.  Once that was done, the iMac running Parallels could see the host PC.
Setting changed on Windows 10

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JONINBENDAuthor Commented:
I went through the suggestions.  That didn't work, so I decided to reinstall Parallel Tools as suggested.  That didn't work either.  Then I installed a clean version of Windows 7 which didn't solve the issue, but after double checking everything I had done, I decided to check the host PC.  That's when I discovered it was set to "Private".  Reading the attached settings information, I just switched it to "Off" since the PC was now "Public".  That solved it.  On Windows 10, you are either Private, Public, or Domain unless you want to work within a Homegroup.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.