RHEL6.6 - pcsd GUI disabled

Hi,

I have a RHEL6.6 OS running a pacemaker cluster (see info below).

After I started the pcsd

# service pcsd status
pcsd (pid  28487) is running...

# ps -ef | grep 28487
root      6911 28713  0 20:19 pts/1    00:00:00 grep 28487
root     28487     1  0 18:09 pts/0    00:00:01 /usr/bin/ruby -I/usr/lib/pcsd /usr/lib/pcsd/ssl.rb

And auth the nodes using the hacluster user.

# pcs cluster auth eastapp1 eastapp2
eastapp1: Already authorized
eastapp2: Already authorized

But when I try to go the the pcsd GUI webpage I get this: ---  https://IP_cluster_node:2224/login

PCSD GUI is disabled


Any suggestion on how to enable this?

Tks,
Joao


============================================

Info about the cluster:

# pcs status
Cluster name: east
Last updated: Wed Jan 13 20:14:29 2016
Last change: Wed Jan 13 19:53:21 2016
Stack: cman
Current DC: eastapp1 - partition with quorum
Version: 1.1.11-97629de
2 Nodes configured
2 Resources configured


Online: [ eastapp1 eastapp2 ]

Full list of resources:

 Resource Group: mastera_sg
     mastera_vip        (ocf::heartbeat:IPaddr2):       Started eastapp1
     aacserver  (ocf::heartbeat:aac):   Started eastapp1

#

# rpm -qa|grep -i pacemaker
pacemaker-cluster-libs-1.1.12-4.el6.x86_64
pacemaker-libs-1.1.12-4.el6.x86_64
pacemaker-1.1.12-4.el6.x86_64
pacemaker-cli-1.1.12-4.el6.x86_64


# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 6.6 (Santiago)
joaotellesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MazdajaiCommented:
Is this a new installation? Has it worked before?

Can you post the following?

netstat -ant|grep :2224
cat /etc/corosync/corosync.conf

Open in new window

joaotellesAuthor Commented:
Its new and never worked before.

The netstat output is the same on both nodes:
# netstat -ant|grep :2224
tcp        0      0 :::2224                     :::*                        LISTEN  

# cat /etc/corosync/corosync.conf
cat: /etc/corosync/corosync.conf: No such file or directory

Im using cman as the stack.

# pcs status
Cluster name: east
Last updated: Thu Jan 14 13:28:08 2016
Last change: Wed Jan 13 19:53:21 2016
Stack: cman
Current DC: eastapp1 - partition with quorum
Version: 1.1.11-97629de
2 Nodes configured
2 Resources configured


Online: [ eastapp1 eastapp2 ]

Full list of resources:

 Resource Group: mastera_sg
     mastera_vip        (ocf::heartbeat:IPaddr2):       Started eastapp1
     aacserver  (ocf::heartbeat:aac):   Started eastapp1

No fencing or STONITH.

[root@eastapp2 /]# cat ./etc/cluster/cluster.conf
<cluster config_version="8" name="east">
  <fence_daemon/>
  <clusternodes>
    <clusternode name="eastapp1" nodeid="1">
      <fence>
        <method name="pcmk-redirect">
          <device name="pcmk" port="eastapp1"/>
        </method>
      </fence>
    </clusternode>
    <clusternode name="eastapp2" nodeid="2">
      <fence>
        <method name="pcmk-redirect">
          <device name="pcmk" port="eastapp2"/>
        </method>
      </fence>
    </clusternode>
  </clusternodes>
  <cman/>
  <fencedevices>
    <fencedevice agent="fence_pcmk" name="pcmk"/>
  </fencedevices>
  <rm>
    <failoverdomains/>
    <resources/>
  </rm>
</cluster>
joaotellesAuthor Commented:
The weird thing is that I conf the cluster using pcs command and the conf was propagated to the other nodes without problem... plus like I said both nodes are already auth properly.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

joaotellesAuthor Commented:
Also, after i follow these steps:

[root@eastapp1 ~]# service iptables start
[root@eastapp1 ~]# iptables -I INPUT -p udp -m state --state NEW -m multiport --dports 5404,5405 -j ACCEPT
[root@eastapp1 ~]# iptables -I INPUT -p tcp --dport 2224 -m state --state NEW,ESTABLISHED -j ACCEPT
[root@eastapp1 ~]# iptables -I OUTPUT -p tcp --sport 2224 -m state --state ESTABLISHED -j ACCEPT
[root@eastapp1 ~]# ssh eastapp2
Last login: Thu Jan 14 13:46:55 2016 from eastapp1
[root@eastapp2 ~]# service iptables start
[root@eastapp2 ~]# iptables -I INPUT -p udp -m state --state NEW -m multiport --dports 5404,5405 -j ACCEPT
[root@eastapp2 ~]# iptables -I INPUT -p tcp --dport 2224 -m state --state NEW,ESTABLISHED -j ACCEPT
[root@eastapp2 ~]# iptables -I OUTPUT -p tcp --sport 2224 -m state --state ESTABLISHED -j ACCEPT
[root@eastapp2 ~]# service iptables save
iptables: Saving firewall rules to /etc/sysconfig/iptables: [  OK  ]
[root@eastapp2 ~]# exit
logout
Connection to eastapp2 closed.
[root@eastapp1 ~]# service iptables save
iptables: Saving firewall rules to /etc/sysconfig/iptables: [  OK  ]
[root@eastapp1 ~]# pcs cluster status
Cluster Status:
 Last updated: Thu Jan 14 14:03:49 2016
 Last change: Thu Jan 14 13:40:14 2016
 Stack: cman
 Current DC: eastapp2 - partition with quorum
 Version: 1.1.11-97629de
 2 Nodes configured
 2 Resources configured

PCSD Status:
  eastapp1: Online
  eastapp2: Online

----

I got this on the pcs status:

# pcs cluster status
Cluster Status:
 Last updated: Thu Jan 14 14:03:49 2016
 Last change: Thu Jan 14 13:40:14 2016
 Stack: cman
 Current DC: eastapp2 - partition with quorum
 Version: 1.1.11-97629de
 2 Nodes configured
 2 Resources configured

PCSD Status:
  eastapp1: Online
  eastapp2: Online

----

But after I issue the command again:

# pcs status
Cluster name: east
Last updated: Thu Jan 14 14:04:08 2016
Last change: Thu Jan 14 13:40:14 2016
Stack: cman
Current DC: eastapp2 - partition with quorum
Version: 1.1.11-97629de
2 Nodes configured
2 Resources configured


Online: [ eastapp1 eastapp2 ]

Full list of resources:

 Resource Group: mastera_sg
     mastera_vip        (ocf::heartbeat:IPaddr2):       Started eastapp1
     aacserver  (ocf::heartbeat:aac):   Started eastapp1
joaotellesAuthor Commented:
This is what I see in the pcsd logs when I try to login to the GUI

::ffff:10.216.209.65 - - [14/Jan/2016 14:20:27] "GET /login HTTP/1.1" 200 20 0.0164
::ffff:10.216.209.65 - - [14/Jan/2016 14:20:27] "GET /login HTTP/1.1" 200 20 0.0172
eastapp1 - - [14/Jan/2016:14:20:27 CET] "GET /login HTTP/1.1" 200 20
- -> /login
[2016-01-14 14:20:37] ERROR OpenSSL::SSL::SSLError: SSL_accept SYSCALL returned=5 errno=0 state=SSLv2/v3 read client hello A
        /usr/lib/ruby/1.8/openssl/ssl-internal.rb:174:in `accept'
joaotellesAuthor Commented:
And more info on corosync

# corosync-cfgtool -s
Printing ring status.
Local node ID 1
RING ID 0
        id      = 10.216.209.65
        status  = ring 0 active with no faults
[root@eastapp1 ~]# /usr/sbin/corosync-objctl  runtime.totem.pg.mrp.srp.members
runtime.totem.pg.mrp.srp.1.ip=r(0) ip(10.216.209.65)
runtime.totem.pg.mrp.srp.1.join_count=1
runtime.totem.pg.mrp.srp.1.status=joined
runtime.totem.pg.mrp.srp.2.ip=r(0) ip(10.216.209.72)
runtime.totem.pg.mrp.srp.2.join_count=1
runtime.totem.pg.mrp.srp.2.status=joined
MazdajaiCommented:
[2016-01-14 14:20:37] ERROR OpenSSL::SSL::SSLError: SSL_accept SYSCALL returned=5 errno=0 state=SSLv2/v3 read client hello A
        /usr/lib/ruby/1.8/openssl/ssl-internal.rb:174:in `accept' 

Open in new window


Ruby get caught on TLS. Can you run the following?

rpm -q pcs
rpm -q ruby
rpm -q openssl

Open in new window

joaotellesAuthor Commented:
[root@eastapp1 ~]# rpm -q pcs
pcs-0.9.123-9.el6.x86_64
[root@eastapp1 ~]# rpm -q ruby
ruby-1.8.7.374-2.el6.x86_64
[root@eastapp1 ~]# rpm -q openssl
openssl-1.0.1e-30.el6.x86_64

Also, tried this:
# wget https://10.216.209.65:2224
--2016-01-14 16:21:05--  https://10.216.209.65:2224/
Connecting to 10.216.209.65:2224... connected.
ERROR: cannot verify 10.216.209.65’s certificate, issued by “/C=US/ST=MN/L=Minneapolis/O=pcsd/OU=pcsd/CN=eastapp1”:
  Self-signed certificate encountered.
    ERROR: certificate common name “eastapp1” doesn't match requested host name “10.216.209.65”.
To connect to 10.216.209.65 insecurely, use ‘--no-check-certificate’.
joaotellesAuthor Commented:
Or:

# wget https://eastapp1:2224/
--2016-01-14 16:30:19--  https://eastapp1:2224/
Resolving eastapp1... 10.216.209.65
Connecting to eastapp1|10.216.209.65|:2224... connected.
ERROR: cannot verify eastapp1’s certificate, issued by “/C=US/ST=MN/L=Minneapolis/O=pcsd/OU=pcsd/CN=eastapp1”:
  Self-signed certificate encountered.
To connect to eastapp1 insecurely, use ‘--no-check-certificate’.
MazdajaiCommented:
It complains about the self signed cert and can be ignored.

Can you post the following?
cat /usr/lib/pcsd/ssl.rb

Open in new window

joaotellesAuthor Commented:
# cat /usr/lib/pcsd/ssl.rb
require 'rubygems'
require 'webrick'
require 'webrick/https'
require 'openssl'
require 'logger'
require 'rack'

def is_rhel6()
  if File.open('/etc/system-release').read =~ /(Red Hat Enterprise Linux Server|CentOS|Scientific Linux) release 6\./
    return true
  else
    return false
  end
end


CRT_FILE = "/var/lib/pcsd/pcsd.crt"
KEY_FILE = "/var/lib/pcsd/pcsd.key"
server_name = WEBrick::Utils::getservername

if not File.exists?(CRT_FILE) or not File.exists?(KEY_FILE)
  name = "/C=US/ST=MN/L=Minneapolis/O=pcsd/OU=pcsd/CN=#{server_name}"
  ca   = OpenSSL::X509::Name.parse(name)
  key = OpenSSL::PKey::RSA.new(2048)
  crt = OpenSSL::X509::Certificate.new
  crt.version = 2
  crt.serial  = ((Time.now).to_f * 1000).to_i
  crt.subject = ca
  crt.issuer = ca
  crt.public_key = key.public_key
  crt.not_before = Time.now
  crt.not_after  = Time.now + 10 * 365 * 24 * 60 * 60 # 10 year
  crt.sign(key, OpenSSL::Digest::SHA256.new)

  File.open(CRT_FILE, 'w',0700) {|f| f.write(crt)}
  File.open(KEY_FILE, 'w',0700) {|f| f.write(key)}
end

webrick_options = {
  :Port               => 2224,
  :BindAddress        => "::",
  :SSLEnable          => true,
  :SSLVerifyClient    => OpenSSL::SSL::VERIFY_NONE,
  :SSLCertificate     => OpenSSL::X509::Certificate.new(File.open(CRT_FILE).read),
  :SSLPrivateKey      => OpenSSL::PKey::RSA.new(File.open(KEY_FILE).read()),
  :SSLCertName        => [[ "CN", server_name ]],
  :StartCallback => Proc.new {
        `python /usr/lib/pcsd/systemd-notify-fix.py`
  }
}

server = ::Rack::Handler::WEBrick
trap(:INT) do
  puts "Shutting down (INT)"
  server.shutdown
  #exit
end

trap(:TERM) do
  puts "Shutting down (TERM)"
  server.shutdown
  #exit
end

require 'pcsd'
server.run(Sinatra::Application , webrick_options)
MazdajaiCommented:
Can you try to append this line in ssl.rb?
  :SSLOptions         => OpenSSL::SSL::OP_NO_SSLv2 | OpenSSL::SSL::OP_NO_SSLv3,

Open in new window


  :SSLCertName        => [[ "CN", server_name ]],
  :SSLOptions         => OpenSSL::SSL::OP_NO_SSLv2 | OpenSSL::SSL::OP_NO_SSLv3,
}

Open in new window

joaotellesAuthor Commented:
Appended:


webrick_options = {
  :Port               => 2224,
  :BindAddress        => "::",
  :SSLEnable          => true,
  :SSLVerifyClient    => OpenSSL::SSL::VERIFY_NONE,
  :SSLCertificate     => OpenSSL::X509::Certificate.new(File.open(CRT_FILE).read),
  :SSLPrivateKey      => OpenSSL::PKey::RSA.new(File.open(KEY_FILE).read()),
  :SSLCertName        => [[ "CN", server_name ]],
  :SSLOptions         => OpenSSL::SSL::OP_NO_SSLv2 | OpenSSL::SSL::OP_NO_SSLv3,
  :StartCallback => Proc.new {
        `python /usr/lib/pcsd/systemd-notify-fix.py`
  }
.
.


===

But same result:
[root@eastapp1 pcsd]# wget https://eastapp1:2224/
--2016-01-14 17:02:21--  https://eastapp1:2224/
Resolving eastapp1... 10.216.209.65
Connecting to eastapp1|10.216.209.65|:2224... connected.
ERROR: cannot verify eastapp1’s certificate, issued by “/C=US/ST=MN/L=Minneapolis/O=pcsd/OU=pcsd/CN=eastapp1”:
  Self-signed certificate encountered.
To connect to eastapp1 insecurely, use ‘--no-check-certificate’.

# wget https://localhost:2224/
--2016-01-14 17:03:02--  https://localhost:2224/
Resolving localhost... ::1, 127.0.0.1
Connecting to localhost|::1|:2224... connected.
ERROR: cannot verify localhost’s certificate, issued by “/C=US/ST=MN/L=Minneapolis/O=pcsd/OU=pcsd/CN=eastapp1”:
  Self-signed certificate encountered.
    ERROR: certificate common name “eastapp1” doesn't match requested host name “localhost”.
To connect to localhost insecurely, use ‘--no-check-certificate’.


====

The openssl error I had with the pcsd.log is gone... but Im still getting the PCSD GUI is disabled when trying to access thre URL using a browser... https://localhost:2224/

I, [2016-01-14T17:05:28.723746 #6256]  INFO -- : Running: /usr/sbin/corosync-objctl totem.cluster_name
I, [2016-01-14T17:05:28.733447 #6256]  INFO -- : Redirecting '*'...

::ffff:10.216.209.65 - - [14/Jan/2016 17:05:28] "GET /login HTTP/1.1" 200 20 0.0115
::ffff:10.216.209.65 - - [14/Jan/2016 17:05:28] "GET /login HTTP/1.1" 200 20 0.0121
eastapp1 - - [14/Jan/2016:17:05:28 CET] "GET /login HTTP/1.1" 200 20
- -> /login
::ffff:10.216.209.65 - - [14/Jan/2016 17:06:06] "GET / HTTP/1.1" 302 - 0.0017
::ffff:10.216.209.65 - - [14/Jan/2016 17:06:06] "GET / HTTP/1.1" 302 - 0.0020
eastapp1 - - [14/Jan/2016:17:06:06 CET] "GET / HTTP/1.1" 302 0
- -> /
joaotellesAuthor Commented:
I found this option.. I wonder if we can use in the rb file somehow...

# wget --no-check-certificate https://eastapp1:2224/
--2016-01-14 17:15:59--  https://eastapp1:2224/
Resolving eastapp1... 10.216.209.65
Connecting to eastapp1|10.216.209.65|:2224... connected.
WARNING: cannot verify eastapp1’s certificate, issued by “/C=US/ST=MN/L=Minneapolis/O=pcsd/OU=pcsd/CN=eastapp1”:
  Self-signed certificate encountered.
HTTP request sent, awaiting response... 302 Found
Location: https://eastapp1:2224/login [following]
--2016-01-14 17:15:59--  https://eastapp1:2224/login
Reusing existing connection to eastapp1:2224.
HTTP request sent, awaiting response... 200 OK
Length: 20 [text/html]
Saving to: “index.html”

100%[===========================================================================================================================================================>] 20          --.-K/s   in 0.04s  

2016-01-14 17:15:59 (511 B/s) - “index.html” saved [20/20]
joaotellesAuthor Commented:
Also, the wget without the certificate returns this index.html:

# more index.html
PCSD GUI is disabled

Which is the same message I get on the browser... so I wonder solving this self signed certificate issue will do anything...
MazdajaiCommented:
If you have rebooted the box and to no avail, you will need to do a clean reinstall on the latest version
pacemaker-1.1.12-8.el6.

yum remove pacemaker cman pcs

Open in new window

joaotellesAuthor Commented:
Sorry did not follow what you said... do I have to reconfigure everything?

I changed the pcsd.rb and set the DISABLED_CLUSTER to false and I was able to access the GUI but I got this error while creating the cluster in the GUI...

::ffff:10.216.209.65 - - [14/Jan/2016 18:40:06] "GET /remote/check_auth HTTP/1.1" 200 - 0.0592
::ffff:10.216.209.65 - - [14/Jan/2016 18:40:06] "GET /remote/check_auth HTTP/1.1" 200 - 0.0598
eastapp1 - - [14/Jan/2016:18:40:06 CET] "GET /remote/check_auth HTTP/1.1" 200 0
- -> /remote/check_auth
eastapp1 - - [14/Jan/2016:18:40:06 CET] "POST /remote/check_gui_status HTTP/1.1" 500 186223
https://localhost:2224/manage -> /remote/check_gui_status
I, [2016-01-14T18:40:27.110591 #4262] INFO -- : Running: /usr/sbin/corosync-objctl totem.cluster_name
NoMethodError - undefined method value' for nil:NilClass:

        /usr/lib/pcsd/remote.rb:256:incheck_gui_status'
/usr/lib/ruby/1.8/open3.rb:86:in popen3'

        /usr/lib/pcsd/remote.rb:255:incheck_gui_status'
/usr/lib/pcsd/remote.rb:58:in remote'

        /usr/lib/pcsd/pcsd.rb:184:inPOST /remote/?:command?'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:1592:in call'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:1592:incompile!'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:957:in []'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:957:inroute!'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:976:in route_eval'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:957:inroute!'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:997:in process_route'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:995:incatch'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:995:in process_route'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:955:inroute!'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:954:in each'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:954:inroute!'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:1067:in dispatch!'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:1049:ininvoke'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:1049:in catch'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:1049:ininvoke'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:1064:in dispatch!'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:889:incall!'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:1049:in invoke'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:1049:incatch'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:1049:in invoke'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:889:incall!'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:877:in call'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/rack-1.5.2/lib/rack/session/abstract/id.rb:225:incontext'
/usr/lib/pcsd/vendor/bundle/ruby/gems/rack-1.5.2/lib/rack/session/abstract/id.rb:220:in call'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/rack-1.5.2/lib/rack/commonlogger.rb:33:incall_without_check'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:217:in call'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/rack-protection-1.5.2/lib/rack/protection/xss_header.rb:18:incall'
/usr/lib/pcsd/vendor/bundle/ruby/gems/rack-protection-1.5.2/lib/rack/protection/base.rb:50:in call'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/rack-protection-1.5.2/lib/rack/protection/path_traversal.rb:16:incall'
/usr/lib/pcsd/vendor/bundle/ruby/gems/rack-protection-1.5.2/lib/rack/protection/json_csrf.rb:18:in call'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/rack-protection-1.5.2/lib/rack/protection/base.rb:50:incall'
/usr/lib/pcsd/vendor/bundle/ruby/gems/rack-protection-1.5.2/lib/rack/protection/frame_options.rb:31:in call'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/rack-1.5.2/lib/rack/session/abstract/id.rb:225:incontext'
/usr/lib/pcsd/vendor/bundle/ruby/gems/rack-1.5.2/lib/rack/session/abstract/id.rb:220:in call'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/rack-1.5.2/lib/rack/logger.rb:15:incall'
/usr/lib/pcsd/vendor/bundle/ruby/gems/rack-1.5.2/lib/rack/commonlogger.rb:33:in call_without_check'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:217:incall'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:210:in call'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/rack-1.5.2/lib/rack/head.rb:11:incall'
/usr/lib/pcsd/vendor/bundle/ruby/gems/rack-1.5.2/lib/rack/methodoverride.rb:21:in call'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/show_exceptions.rb:21:incall'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:180:in call'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:2004:incall'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:1469:in call'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:1778:insynchronize'
/usr/lib/pcsd/vendor/bundle/ruby/gems/sinatra-1.4.4/lib/sinatra/base.rb:1469:in call'

        /usr/lib/pcsd/vendor/bundle/ruby/gems/rack-1.5.2/lib/rack/handler/webrick.rb:60:inservice'
/usr/lib/ruby/1.8/webrick/httpserver.rb:104:in service'

        /usr/lib/ruby/1.8/webrick/httpserver.rb:65:inrun'
/usr/lib/ruby/1.8/webrick/server.rb:173:in start_thread'

        /usr/lib/ruby/1.8/webrick/server.rb:162:instart'
/usr/lib/ruby/1.8/webrick/server.rb:162:in start_thread'

        /usr/lib/ruby/1.8/webrick/server.rb:95:instart'
/usr/lib/ruby/1.8/webrick/server.rb:92:in each'

        /usr/lib/ruby/1.8/webrick/server.rb:92:instart'
/usr/lib/ruby/1.8/webrick/server.rb:23:in start'

        /usr/lib/ruby/1.8/webrick/server.rb:82:instart'
/usr/lib/pcsd/vendor/bundle/ruby/gems/rack-1.5.2/lib/rack/handler/webrick.rb:14:in `run'
/usr/lib/pcsd/ssl.rb:66
I, [2016-01-14T18:40:27.304376 #4262] INFO -- : Running: /usr/sbin/corosync-objctl totem.cluster_name
::ffff:10.216.209.65 - - [14/Jan/2016 18:40:27] "GET /remote/check_auth HTTP/1.1" 200 - 0.0615
::ffff:10.216.209.65 - - [14/Jan/2016 18:40:27] "GET /remote/check_auth HTTP/1.1" 200 - 0.0626
eastapp1 - - [14/Jan/2016:18:40:27 CET] "GET /remote/check_auth HTTP/1.1" 200 0
- -> /remote/check_auth
eastapp1 - - [14/Jan/2016:18:40:27 CET] "POST /remote/check_gui_status HTTP/1.1" 500 186223
https://localhost:2224/manage -> /remote/check_gui_status
MazdajaiCommented:
Yes i recommend reinstall it with the latest pacemake, ruby and openssl packages. Be sure to save the commands so we can reproduce it later.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
joaotellesAuthor Commented:
Tks! SOrry the question but any suggestion on how to save the commands?
MazdajaiCommented:
The above is a traceback error. You shouldn't need to edit the Ruby Script to get the ui working. Doing a clean reinstall is the easiest way.

You can use pcs command to save and restore config.
joaotellesAuthor Commented:
Tks.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.