We help IT Professionals succeed at work.

PXE-E32 TFTP open timeout during PXE boot for WDS

20,235 Views
Last Modified: 2016-06-13
Hello, I'm receiving PXE-E32 TFTP open timeout during PXE boot for WDS. I'm attempting to PXE boot my laptop and it receives an address, but there's no pulling down the boot file/image in order to begin the process. DHCP and WDS are running on separate servers. DHCP is Server 2008 and WDS is Server 2012 R2.

Options 066 (WDS server) and 067 (boot\x64\wdsbnp.com) have both been specified and Port 69 is open on the WDS server.  

We tried downloading the file through a TFTP client and received there is a problem when parsing the received packet.

Any advice on how to proceed?

Thank you!
Comment
Watch Question

Matt MinorTechnical Systems Analyst
CERTIFIED EXPERT

Commented:
What error do you receive when the TFTP open timeout occurs? There should be a "PXE-Exx" error that we can reference to determine the cause.
Matt MinorTechnical Systems Analyst
CERTIFIED EXPERT

Commented:
PXE-E32. In the subject. Got it.
Matt MinorTechnical Systems Analyst
CERTIFIED EXPERT

Commented:
Is option 066 configured using the hostname or IP of your WDS Server?
Matt MinorTechnical Systems Analyst
CERTIFIED EXPERT

Commented:
2nd Question: is the WDS server on a different subnet than your client?
Manager I.T.
CERTIFIED EXPERT
Top Expert 2015
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
@Matt 066 is configured with the IP. WDS is on a different subnet than the client, but they're using the same Subnet Mask.

@Muhammad Right now both are unchecked.
DHCP.JPG
DHCP-Server.JPG

Author

Commented:
Thanks for both of your input.
Matt MinorTechnical Systems Analyst
CERTIFIED EXPERT

Commented:
I would trial PXE Booting with those two options for "Do not listen on Port 67" and "Configure DHCP Option 60..." checked-off. I think there's something happening with broadcast traffic on the network and the connection to the TFTP server is being interrupted.

Try enabling those two settings and then PXE-booting.

Author

Commented:
@Matt If I enable the 2nd option - Configure DHCP options to indicate that this is also a PXE server I receive an error that the server does not have the DHCP service installed.
Matt MinorTechnical Systems Analyst
CERTIFIED EXPERT

Commented:
Oh right your DHCP is separate - ok so that one can stay unchecked.

Author

Commented:
We attempted that, but it gave the same error.

Author

Commented:
Any other useful info? Looks like it downloaded the WDSNBP file from the WDS server, but it doesn't see a gateway.

Thanks!
PXE.JPG
Matt MinorTechnical Systems Analyst
CERTIFIED EXPERT

Commented:
If you press F12, what is the message?

See this similar EE posting as it seems to be very close to your current situation.

https://www.experts-exchange.com/questions/28225408/Windows-2012-WDS-trouble.html

Author

Commented:
Thanks, Matt. I'll check in the am and get back to you.

Author

Commented:
Sorry for the delay. Still checking on it. Do you think enabling WinHTTP AutoProxy Support would help at all?

Thanks.

Author

Commented:
So, now when we begin the PXE boot, we're receiving an error.

File:\Boot\BCD
Error Code: 0x000000f

Any thoughts? :)

Thanks.

Author

Commented:
We've also tried generating a new boot image and using an existing one from the old WDS/DHCP server.

Author

Commented:
We went with Clone Deploy as a solution instead. Thanks for the info.

Author

Commented:
Thanks.
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.