Link to home
Start Free TrialLog in
Avatar of techitch2
techitch2Flag for United States of America

asked on

Crystal report date range

Let me preface this that I have little to no Crystal Report training, however I have been able to tweak reports and convert reports for our new ERP.  I have an existing report that shows a list of vendors and dollar amounts from "this year" and from "last year."  The report pulls from two custom views that were created for us (ap_ytd_purch.amount and ap_lstyr_purch.amount) and also pulls vendor name from a table (apvenfil_sql)  What i want to be able to do is ask the report for a date range.  So I've created a Bdate and Edate in the formula fields and tied them to a parameter.  I know I'm missing something but for whatever reason I can not think of it.  This is not working.  It shows me the same data no matter what dates i enter.  Any help?
Avatar of vasto
vasto
Flag of United States of America image

You need to create parameters and use them in the record selection formula. Here is a video showing the process
https://www.youtube.com/watch?v=NkmXGu2fqF8
Avatar of Mike McCracken
Mike McCracken

Are you using the views as the data source or did you build a COMMAND?
If you are not sure look at
Open the report
Click DATABASE --> DATABASE EXPERT
Do you see a list of tables/views or do you see a single leaf in the tree?
If a single leaf if you right click it do you see EDIT COMMAND and VIEW COMMAND?

mlmcc
Avatar of techitch2

ASKER

Vasto, That was great info but there is no date fields to associate the parameter too.

mlmcc, These are part of the database.  I am adding a screenshot below.
Capture.JPG
Capture1.JPG
ASKER CERTIFIED SOLUTION
Avatar of Mike McCracken
Mike McCracken

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
No they do not.  Here is what they consist of (attached)
Capture2.JPG
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I was afraid of that.