Multiple Issues with my server that our causing issues with users on there works PC's

thinktechsolutions
thinktechsolutions used Ask the Experts™
on
It was just brought to my attention that there have been several issues with the server and employees PC apparently these issues have been going on for awhile but because I was away dealing with some family issues nobody wanted to bother me. So now I'm trying to determine that root cause of the issue and need some help in figuring everything out. I know they had to bring in some outside help about a month ago and there was not a detailed list of what that tech did. So I'm going through the event viewer log files on my Server and DNS server and I see a ton of issues that I'm having a hard time figuring out why.

Here are the error messages coming from the File Server and Domain Control Active directory
Under Applications I'm getting a lot of these.

Windows cannot query DllName registry entry for {CF7639F3-ABA2-41DB-97F2-81E2C5DBFC5D} and it will not be loaded. This is most likely caused by a faulty registration.

Windows cannot query DllName registry entry for {7B849a69-220F-451E-B3FE-2CB811AF94AE} and it will not be loaded. This is most likely caused by a faulty registration.

There'ss about another 15 more errors on that list

Under System I get these
The certificate received from the remote server has not validated correctly. The error code is 0x80096004. The SSL connection request has failed. The attached data contains the server certificate.

Now under My DNS,DHCP,DC server I'm getting these error messages

Under system
The certificate received from the remote server has not validated correctly. The error code is 0x80096004. The SSL connection request has failed. The attached data contains the server certificate.

Under DNS server
The DNS server has encountered numerous run-time events. To determine the initial cause of these run-time events, examine the DNS server event log entries that precede this event. To prevent the DNS server from filling the event log too quickly, subsequent events with Event IDs higher than 3000 will be suppressed until events are no longer being generated at a high rate.

The DNS server recv() function failed. The event data contains the error.

When I run netdiag this is what I get as well
 Testing DNS
    [FATAL] Could not open file C:\WINDOWS\system32\config\netlogon.dns for reading.
    [FATAL] Could not open file C:\WINDOWS\system32\config\netlogon.dns for reading.
        [FATAL] No DNS servers have the DNS records for this DC registered.
    Testing redirector and browser... Failed

If anybody can help me figure out what is going on it looks as though the DC got demoted possibly not really sure. If anybody could give me a hand I would greatly appreciate it. I can't get ahold of the previous tech that came out to the office to see what all was done thank you in advance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
My first guess would be the server isn't looking at itself as the First DNS server.
or that the listener is not correctly configured.

I've removed and reinstalled DNS server on 2003 servers many times in the Past. pretty straight forward, of course backup before changing things.

I'd highly recommend upgrading the server.

Author

Commented:
Thank you for your suggestions I checked and according to the logs netserver1 which is the DNS server. I don't mind reinstalling the DNS server but I think there is a configuration that I'm not seeing could be the meds I'm on that is giving me brain fog.

As far as replacing the server that is the plan much later on this year don't have the money right now to replace the server at this moment but currently all my software still work with server 2003 but server 2012R2 are 2016 will be my future server version along with a new server to replace this poweredge server.

 I've attached ipconfig, dc diag,dnslint,repl,netdiag These log files are for NETSERVER1. If you don't mind could you take a look at these are all coming from the primary DC,DNS,DHCP server. Thank you for taking the time to respond to my question
netdiag-edited-with-dummy.txt
dcdiag-edited-with-dummy.txt
Dnslint-edited-with-dummy.txt
ipconfig-edited-with-dummy.txt
repl-edited-with-dummy.txt
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Error messages from one of the employees computer at the office. it looks as though I have no logon servers apparently trying to verify that now. Any suggestions for anybody that is looking at this question please let me know Thank You
Error-message-from-employees-comp.txt
Why are you using forwarders?

where are the Errors
DllName registry entry for {CF7639F3-ABA2-41DB-97F2-81E2C5DBFC5D} and it will not be loaded.
DllName registry entry for {7B849a69-220F-451E-B3FE-2CB811AF94AE} and it will not be loaded.

Showing up? what machine and when?

this is looking like separate issues, or a cascading problem.

Author

Commented:
I thought it was best practice to have forwarders and root hints on the DNS server? I can remove them but having them on the DNS could it be causing these problems.

The errors are coming from the dummy server that is a DC and a FILE replication
the error message shows up all the time and is logged in eventviewer it looks to be every 5 minutes.

You know what is very strange under Active directory domains and trusts
under dummybuilders.com
if I click on it nothing shows up the right side
if I right click and go to properties
nothing for description
under trusts nothing in there

I thought there is usually something in the trust but now that I think of it that's only if you have 2 domains on different DCs.
another question, are you using the 32 bit Netdiag on a 64bit machine? that seems to be a common problem with the "[FATAL] Could not open file C:\WINDOWS\system32\config\netlogon.dns for reading." error

check it's location if it's in the program files(x86)  path.

again backup before doing much.

have you tried netdiag /fix?

Author

Commented:
I've tried netdiag/fix and I'm still running in to errors in the event viewer. I believe it is the 32bit netdiag. Any other suggestions. I have it backed up. Now I only ran netdiag /fix on the DC,DNS,DHCP server the netserver1 not the dummy server which is DC, FILE.

Author

Commented:
This is the Dc diag log on the netserver1.

This was the log from doing an nslookup on dummybuilders.com it was done on an employee computer at the office. I saved all the events and then I cleared the log file. I will update what comes up tomorrow but the DNS seems to be the culprit unless I'm missing something.

Server:  netserver1.dummybuilders.com
Address:  192.168.11.107

Name:    dummybuilders.com
Addresses:  192.168.11.105
          192.168.11.107
DC-Diag-Netserver1.txt

Author

Commented:
Ok the dummy server this is the error message I'm getting now.

The File Replication Service is having trouble enabling replication from NETSERVER1 to dummySERVER for c:\windows\sysvol\domain using the DNS name netserver1.dummybuilders.com. FRS will keep retrying.
 Following are some of the reasons you would see this warning.
 
 [1] FRS can not correctly resolve the DNS name netserver1.dummybuilders.com from this computer.
 [2] FRS is not running on netserver1.dummybuilders.com.
 [3] The topology information in the Active Directory for this replica has not yet replicated to all the Domain Controllers.
 
 This event log message will appear once per connection, After the problem is fixed you will see another event log message indicating that the connection has been established.

If somebody could give me an idea on what is going on I would greatly appreciate it
Thank You
is the netserver1, DNS server working in itself? able to look at it's own records and nslookup shows itself as default DNS server?
is the .com start of authority and the Server listed in the NameServers for dummybuilders.com
is there a .local for dummybuilders?
do you have firewall exceptions for port53?
have you tried turning off windows firewall?

Author

Commented:
Netserver1 yes it is a DNS server and I'm attaching the ping test I did in cmd prompt.
Nslookup show it was netserver1.dummybuilders.com
Address 192.168.11.107
Under forward lookup zones
_msdcs.dummybuilders.com
State of Authority is netserver1.dummybuilders.com
Name Server netserver1.dummybuilders.com
417ca3a2-15b3-4b62-9c44-517813206e62 Alias (CNAME) dummyserver.dummybuilders.com
9c0f8ccd-c090-4c0f-b40b-9a0c2651276f Alias (CNAME) netserver1.dummybuilders.com

Inside dummybuilders.com
State of Authority serial 7546 netserver1.dummybuilders.com
Name Server netserver1.dummybuilders.com
Same as parent folder 192.168.11.105 - Ip address for dummy server
Same as parent folder 192.168.11.107- Ip address for netserver1
_msdcs folder in the same folder Name Server netserver1.dummybuilders.com
DomainDNSZONES 192.168.11.107
Forest DNZ Zones 192.168.11.107

Firewall is actually turned off because we have sonicwall. There are exception in the sonciwall for the netserver1.

This is a new event log that I've never seen before.

The DNS server was unable to complete directory service enumeration of zone dummybuilders.com.  This DNS server is configured to use information obtained from Active Directory for this zone and is unable to load the zone without it.  Check that the Active Directory is functioning properly and repeat enumeration of the zone. The extended error debug information (which may be empty) is "". The event data contains the error.

Thank you again for all your help I'll be onsite at the office tomorrow most of the day if you have any suggestions on what do look at next please let me know thank you
ping-test.txt
Dirk MareSystems Engineer (Acting IT Manager)

Commented:
Are both servers AD, DNS servers?
Dummy
netserver

Can you post..
Ipconfigs from both servers and from one client?
pings from both servers to each other and to them selfs and from a client?
Can you post screenshots from your DNS properties and from you AD DNS zone properties?

DirkMare

Author

Commented:
Andrew Koffron is amazing thank you so much for going above and beyond with helping me figure out this issue. I can't thank you enough for all your help and time your amazing.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial