Windows 10 Not Restarting For Scheduled Updates With WSUS

ColumbiaMarketing
ColumbiaMarketing used Ask the Experts™
on
Hello,

I have been running a handful of Windows 10 Professional computers in my organization that use my WSUS server for updates.  I have noticed that none of them will automatically restart during the scheduled time Windows 10 picks or when you manually pick a restart time.  I have to manually restart them every single time to finish the installation.  This happens whether the user is logged in or not and even if they are logged in there isn't a single program running that would prevent it.  I have group policy set to automatically install updates, which it does that just fine.  What would be causing this and how can the automatic scheduled restart work properly without having to manually restart them every time?  

Thank you
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Distinguished Expert 2018
Commented:
Use deadlines on the WSUS approval and test. As far as I know, deadlines are the only way for 8.x and ten to get them to restart at a set time.

Author

Commented:
Thank you for the information.  Can deadlines be set via group policy for all updates that are set to be automatically approved in WSUS, like all security updates for example?
Distinguished Expert 2018

Commented:
Oh yes. See the screenshot:
Screenshot
CompTIA Network+

Prepare for the CompTIA Network+ exam by learning how to troubleshoot, configure, and manage both wired and wireless networks.

Author

Commented:
I will be testing this shortly to see if it will resolve the restarting issue and will report back.  Thanks again.

Author

Commented:
I do appreciate your suggestions and apologize for not getting back to this case.  My concern with setting deadlines is that I have my updates configured to be approved automatically, so if I set a deadline I would assume that a potential restart could happen during a time other than on Sunday's at 11:00pm.  Am I correct on that regard?  My goal is to simply have the restarts only take place on any given Sunday at 11:00pm.  

Thanks again.
Distinguished Expert 2018

Commented:
You are correct. In your other thread I just posted to use a script, maybe. https://www.wuinstall.com/

Author

Commented:
The issue that I have raised to Microsoft, which currently looks like a bug, is that when using scheduled installations it won't restart at the scheduled time, which Microsoft says you also have to enable the 'Always automatically restart at the scheduled time' GPO when using scheduled installations.  There is a bug with the 'Autorestart' GPO that seems to take precedence over the scheduled installation time and then forces the user to restart when Windows 10 finds any potential updates, since it installs updates immediately when they are found.  The Autorestart GPO only allows you to configure up to 180 minutes to delay the restart as well.  Basically, it essentially ignores any scheduled install time you choose.  Microsoft informed me they are currently looking into this so hopefully they will have a resolution shortly.  

Using deadlines would be a workaround if Windows 10 adheres to them, but not a permanent solution to the restarting issue I am facing.
Distinguished Expert 2018

Commented:
Look at wuinstall if you are looking for a working solution.

Author

Commented:
I will look into that if Microsoft doesn't fix this GPO bug, but it's definitely possible they will patch a fix for this at some point because this behavior simply shouldn't be happening.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial