Downloading using WGET

I would like to download a csv file from this website and save it to C:\temp.  I typed this.

H:\>wget64 --user="aaa" --password="aaa" "https://website.com/files/download?type=144  --auth-no-challenge --content-dispostion -q$ -P C:\temp

I got the response below, but there was no file in C:\temp.

--2016-01-21 12:28:34--  https://website/files/download?type=144
%20%20--auth-no-challenge%20--content-dispostion%20-q$%20-P%20C:%5Ctemp
Resolving website.com (website.com)... IPAddress
Connecting to website.com (website.com)|IPAddress|
:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 189 [text/html]
Saving to: 'download@type=144%20%20--auth-no-challenge%20--content-dispostion%20
-q$%20-P%20C%3A%5Ctemp'

download@type=144%2 100%[===================>]     189  --.-KB/s    in 0s

2016-01-21 12:28:35 (541 KB/s) - 'download@type=144%20%20--auth-no-challenge%20-
-content-dispostion%20-q$%20-P%20C%3A%5Ctemp' saved [189/189]
AlHal2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bill PrewIT / Software Engineering ConsultantCommented:
One thing I notice right off, it looks like you are missing a double quote after 144.

~bp
AlHal2Author Commented:
If I add the " after 144 it says:
wget64: unrecognized option '--content-dispostion'
Bill PrewIT / Software Engineering ConsultantCommented:
You have a typo, "--content-dispostion" should be "--content-disposition".

~bp
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

AlHal2Author Commented:
I get invalid option --  '$'
Bill PrewIT / Software Engineering ConsultantCommented:
Not sure where you got that command line from, but there is no -q$ option, only a -q, is that what you wanted, it reduces output from the transfer.

~bp

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AlHal2Author Commented:
Thanks.
It's not accepting my authentication, but I don't think that's a problem with the syntax.
I removed the -q to see this.
Bill PrewIT / Software Engineering ConsultantCommented:
Yes, in case it helps, I was able to download from a local secure page using your basic syntax once we fixed the errors we have discussed here.  Good luck!

~bp
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
HTTP Protocol

From novice to tech pro — start learning today.