Link to home
Create AccountLog in
Avatar of joukiejouk
joukiejouk

asked on

When accessing our Intranet Site in IE or Chrome, Windows Security prompts for credentials but should not as we are authenticating through SSO.

We use SSO in our environment. When our users sign into the domain, they should be able to access our Intranet site without the need to authenticate again. Some (not all) of our users are having an issue where they launch Chrome or IE, they are getting prompted to enter their credentials (see screenshot). They can access our Intranet after entering their credentials. They place a check mark for "Remember my credentials" checkbox as well. After closing out of their browser and re-launching, the same issue is happening for them. This is causing an inconvenience. This happened after server patching was done. We deploy only Microsoft OS security patches. What can I do to resolve the issue for these users? This is only happening to a handful of users, and not everyone. I already tried having them clear out their browser cache and even resetting IE to default but to no avail.

User generated image
Avatar of REIT
REIT

Hi,

Is the issue effecting the same users? if so compare the OU they;re in to the ones SSO currently works for. Another thing to try would be to get an effected user to logon to a machine which a working person uses. Do you use thinclients in your environment?
Avatar of joukiejouk

ASKER

A few thin clients are used. The users affected do not use them. I wouldnt think this has anything to do with OU, as SSO is applied to all our users. This is a result of patching that was done on the sharepoint and Active Directory servers. Why this is only happening to a few and not all is unknown. I can have them log into another machine to test, but if they are successful in that regard, what can we do to fix the issue for when they are on their own machine?
Well you need to clarify whether the Server was patched or the Desktop Oses.

If it works for a user on another machine the best thing to do would be to compare the differences between the two clients (IE Windows Updates)
The attached Word file will detail what patches have been deployed to our Sharepoint servers and what patches have been deployed to our workstation. In reviewing the patches applied to our Sharepoint servers, I cannot find any patches that are IE patches, just OS security updates.

For desktop patches, I do see an Internet explorer patch (KB83124275). I worked with a user to remove that patch, but to no avail. User still having the issue. The user version of IE is the following:
User generated image
Our sharepoint server version of IE
User generated image
Once again, the issue seem to have happened once we patched all our sharepoint servers.
Patches-applied-to-Sharepoint-serve.docx
I upgraded my version of IE to the same version as the users having this problem (IE 11). I compared my Windows patches on my workstation with the patches on a user's workstation having this problem, and it is identical. I still do not have any issues with SSO. I had the user having this problem log into my workstation, and bring up IE on the user's sesssion on my workstation, and the user is still having this problem. We last patched our sharepoint servers back in October of last year, so everything on the Sharepoint server that just got patched was from Nov 2015-January 2016. We did not deploy any IE updates to our sharepoint servers, just OS security updates. Not sure what to make of this problem, and/or if anyone experienced any problem such as this with patches.
I've requested that this question be deleted for the following reason:

I resolved the issue. It was a GPO settings for SSO.
I stated about GPOs in my first comment?
ASKER CERTIFIED SOLUTION
Avatar of joukiejouk
joukiejouk

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
what were the changes done?