Mapping drive via group policy

DColin
DColin used Ask the Experts™
on
Hi Experts,

I am trying to create a universal drive shared by everyone on my home (2008R2) network via group policy but it is not working.

If the shared folder is located C:\UDrive on computer named HPENVYDESKTOP is the correct GPO location \\HPENVYDESKTOP\UDrive ?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Sr. Network & Server Engineer
Commented:
That is the correct location.

Are you targeting computer or users? I assume you have AD set up and are deploying it to a security group or OU?

Here is a step by step guide on how to set it up: https://technet.microsoft.com/en-ca/library/cc732793.aspx
Also is the share called UDrive ?  folder is not always share name, and check permissions and make sure if the share has a $ at the end you include that.

You should be able to see the share if you open \\HPENVYDESKTOP\

Author

Commented:
Rob Leaver,

Yes I have the AD role installed on my two DCs.

When I try to follow the instructions in your link at item 5 Network Share Settings I am trying to set the folder path. I am Using the Folder Selection dialogue box to navigate to the shared folder which is located on the C: drive of one of the network computers (HPENVYDESKTOP) but when I click the network icon on the navigation tree no computers are showing up. The computer is definitely on the netwok because I can log into it and use it.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Rob LeaverSr. Network & Server Engineer

Commented:
Have you set up the folder to be shared?

Properties > sharing > Advanced sharing then adjust the permissions accordingly.

Make sure you have network discovery is also enabled.

Author

Commented:
Rob Leaver,

Thanks I can now see the shared folder if I click the network icon in windows explorer and click the icon of the computer that the drive is physically located on.

Is it possible to have the shared folder icon in a more accessible place? I am sure I have seen the shared folder icon located in the blank space below the network icon in windows explorer.
Rob LeaverSr. Network & Server Engineer

Commented:
DColin -

You would have to map the share to your computer manually to have it in more of an accessible place but if you're deploying via GPO then this would defeat the point. Now you've able to view the share, you should now be able to deploy it via GPO.

Thanks,
-RL

Author

Commented:
Rob Leaver,

Yes it deploys via GPO but the user has to open it via the network icon, Is this normal and if a user wants the folder icon more accessible then they have to then map it themselves. Or could GPO do this also?
Rob LeaverSr. Network & Server Engineer

Commented:
No - this is telling me the folder is just shared and the user can access it over the network because you've shared it.

This tells me your group policy isn't working. Have you run gpupdate /force and restarted the users computer?

You would have picked a drive letter it would be mapped to when setting up the GPO - it should show as a network drive under your users computer as that network drive.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial