vSphere web client, not mapping keyboard correctly

Mike Hammer
Mike Hammer used Ask the Experts™
on
I can see a kb (2071245) which is almost identical but  just relates to Turkish and a few other countries  not English

when open console is used within web client      characters like \ | # are either not present or mapped else ware, RDP works fine

the vcentre is locale of English as is the guest os

ESX 6  vcentre
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Chris HInfrastructure Manager

Commented:
Did you install vmware tools?

Have you tried uninstalling and reinstalling the vmware tools?

Has this host been migrated?

Author

Commented:
yes VMware tools installed

every server does this  (inc Linux)   vmtools vm tools  are part f template so am just reinstalling now to double check

no the host built from scratch and set to keyboard uk
Chris HInfrastructure Manager

Commented:
Yeah, I've had this issue with Windows 7 client attaching to vsphere...   I still haven't fixed it.  I actually RDP into a TS and then rdp into my workstation and it seems to work fine, just slow as a dog..

I have to use the onscreen keyboard to type my passwords.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Mr TorturSystem Engineer

Commented:
Hi,
and inside the guest OS you are in english too? no other language or keyboard unusual settings?
By the way what is it affecting? All VM, one VM, few VM on a specific ESXi?

Author

Commented:
reinstall didn't change anything

also the thick vsphere client also works its just he web client that does this.
Chris HInfrastructure Manager

Commented:
Tried forcing localized keyboard:
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1016403

Note: Languages supported are English, German, French, Japanese, Korean, and Chinese.
The default URL for the vSphere Web Client is:

https://client_hostname:9443/vsphere-client

To specify a language, append:

English: /?locale=en_US
German: /?locale=de_DE
French: /?locale=fr_FR
Japanese: /?locale=ja_JP
Korean: /?locale=ko_KR
Chinese: /?locale=zh_CN

For example, to display the vSphere Web Client in French, use:

https://client-hostname:9443/vsphere-client/?locale=fr_FR

Author

Commented:
HI, it affects all VM's Windows Linux  when connecting via web console

and multiple ESX even at different sites and unconnected

everything set to uk    from ESx to host
Mr TorturSystem Engineer

Commented:
Did you try :
- multiple browsers ?
- And the previous KB given by experts?
- the VMRC, as given in the VMTN link provided before?

This could help explain :
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2091284

Author

Commented:
Hi sorry at home now,

Chrome. Ie and Firefox tried

Not looked at vcrm. Yet

And I can just use other methods.   But.  Would rarther it worked in the web client and the additional functionality.

Author

Commented:
VMRC works fine,      but that really is another workaround isn't it  its not the web client opening console in browser.  (VMRC looks better and seem much quicker)  but I would like to know cause and fix to browser not working    I seem in the minority of it not working,

Author

Commented:
cheers vmrc was the final solution to issue

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial