troubleshooting Question

Exchange 2013 DAG

Avatar of pchettri
pchettri asked on
ExchangeWindows Server 2012
2 Comments1 Solution1314 ViewsLast Modified:
After a recent update on server and reboot of Active and passive server. I noticed that test-replication with FL parameter is showing error like -

Server           : xxx
Check            : DatabaseRedundancy
CheckDescription : Verifies that databases have sufficient redundancy. If this check fails, it means that some
                   databases are at risk of losing data.
Result           : *FAILED*
Error            : There were database redundancy check failures for database 'xxxx' that may be lowering its
                   redundancy and putting the database at risk of data loss. Redundancy Count: 1. Expected Redundancy
                   Count: 2. Detailed error(s):


                           yyy:
                           The RPC to retrieve the status of database copy 'fc\yyy' failed. Error: A
                   server-side administrative operation has failed. The Microsoft Exchange Replication service may not
                   be running on server yyyy. Specific RPC error message: Error 0x6d9 (There are no
                   more endpoints available from the endpoint mapper) from RpccGetCopyStatusEx4


Identity         :
IsValid          : True
ObjectState      : New

RunspaceId       : e60d3c1f-64f1-4
Server           :xxxx
Check            : DatabaseAvailability
CheckDescription : Verifies that databases have sufficient availability. If this check fails, it means that some
                   databases are at risk of losing service.
Result           : *FAILED*
Error            : There were database availability check failures for database 'xxdb' that may be lowering its
                   availability. Availability Count: 1. Expected Availability Count: 2. Detailed error(s):


                         yyy:
                           The RPC to retrieve the status of database copy 'yyy' failed. Error: A
                   server-side administrative operation has failed. The Microsoft Exchange Replication service may not
                   be running on server yyy. Specific RPC error message: Error 0x6d9 (There are no
                   more endpoints available from the endpoint mapper) from RpccGetCopyStatusEx4


Identity         :
IsValid          : True
ObjectState      : New


The state of the Microsoft exchange replication on passive server shows as "disabled" should I force enable that server or just reboot the passive server again?


email flow, access is working through primary database. Following is the current status

Check                      Result     Error
-----                      ------     -----
ClusterService             Passed
ReplayService              Passed
ActiveManager              Passed
TasksRpcListener           Passed
TcpListener                Passed
ServerLocatorService       Passed
DagMembersUp               Passed
MonitoringService          Passed
ClusterNetwork             Passed
QuorumGroup                Passed
FileShareQuorum            Passed
DatabaseRedundancy         *FAILED*   There were database redundancy check failures for database 'FC...
DatabaseAvailability       *FAILED*   There were database availability check failures for database '...

on the passive copy status it shows "service down".
Cluster status shows healthy


it may be some service that has stopped in exchange passive DAG. Is there a way to find a list of running services on Windows 2012 r2 Exchange 2013 server.
Does not suppose to have same list of services as primary server running? my DAG server shows "Ms exchange DAG management", "Ms Exchange diagnostics", Ms Exchange Health manager" "Ms Exchange mailbox Assistants", Ms exchange throttling", "Ms exchange transport log search" all as disabled.

I did enable "Exchange replication", "AD topology"  and "Ms Exchange search" but I have not sure about other services. If enabling them would conflict with active server

THe DAG passive sever does not ping any external servers or IP like 8.8.8.8
One more thing I noticed that on both the server is that "The microsoft fail over cluster virtual adapter" is showing APIPA address, which I guess is by design of new cluster
ASKER CERTIFIED SOLUTION
Sajid Shaik M
System Admin

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 2 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 2 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros