exchange 2013 , outlook 2010

hi Experts,
Outlook hangs attempting to download offline address book, it showing connecting to exchange but never end and OAB still showing on server not local /user/app/local/etc...
inbox downloaded emails fine, just OAB
some suggestion on this link but not helping!
https://community.spiceworks.com/topic/343922-outlook-hangs-attempting-to-download-offline-address-book

this exchange environment  multi tenants
thank you very much
VN-PC viewAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MacleanSystem EngineerCommented:
Is this for all users or a single individual?
If single individual try setting him up with a clean mail profile under control panel>>mail.
See if that works better.
VN-PC viewAuthor Commented:
hi Maclean

i did that many times also tried other accounts , resulted same error. i think this got to do with virtual directory on IIS, also deleted the folder in user folder local/app /Microsoft/outlook OAB folder
thank you your response
MacleanSystem EngineerCommented:
Have you attempted to re-create the OAB virtual directory?
And are there any errors in the event logs to confirm that the problem is IIS related?
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

VN-PC viewAuthor Commented:
thank you Maclean
i will try that as soon that box ready, rebooting now, adn will let you know asap

thanks
MacleanSystem EngineerCommented:
Ok, I should probably have made a note to make sure you have backups just in case. Should be fine, but never a bad idea to have a backup.
VN-PC viewAuthor Commented:
Hi Maclean

good new More hanging but bad new new error failed 0x80200049, :).
the GAL etc...address is still there i can see all addresses. just not allowing me to download

thank you, i will let you know if i found something new.
MacleanSystem EngineerCommented:
Regarding that error, I think you might be able to resolve that with a CMDlet on the CAS server

"Update-OfflineAddressBook -Identity "Default Offline Address Book"

Once done wait for perhaps 15 minutes, then restart the File Distribution Service on your CAS server.
Once completed run the following CMDlet "Update-FileDistributionService -Identity CASServername"
VN-PC viewAuthor Commented:
i ran this and got an error not recognized command  "Update-FileDistributionService -Identity CASServername". so this maybe for ex2010

the Update-OfflineAddressBook -Identity "Default Offline Address Book"  OK it excepted
MacleanSystem EngineerCommented:
Could be that my notes on the latter command were wrong. It might be "Update-FileDistributionService -Identity CASServer" But as I did not make a note whether it has to state the actual word CASServer, or the Server Name, I assumed it was the server name.

(I keep a spreadsheet with handy commands that I don't want to forget :))
VN-PC viewAuthor Commented:
Hi Maclean,

yest i did my "server name", BTW the GAL i was able download from inside network but not from outside.
error 0x80200049, same error, but at least now it showed some error not like before just hang
thank you sir
MacleanSystem EngineerCommented:
Ok, I found an article which might be able to provide some insight.

One here with a very good description. It is related to 2010, however I would assume that the theory would be similar behind the 2013 issue.

In addition a more simple thing at the client workstation, if it shows EventID 16398, might be resetting the bits queue. Outlook uses BITS to download the OAB, and if the BITS queue is full, it stops functioning properly. This might seem far fetched if every single user is having these problems, and it is external connections only, but worth double checking so it can be ruled out as a problem. (Can run this from a elevated CMD prompt on client PC)

BITSADMIN.EXE /RESET

Also deploying the latest CU11 update for Exchange 2013 could potentially rectify some issues.
Always make a proper backup before doing major changes or upgrades of course.

I'm not sure whether the certificate might be at play too due to it working internal but not external, however lets try the basics first and go from there.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
VN-PC viewAuthor Commented:
Maclean****** you have hit the nail right on the head Brother (BITSADMIN.EXE /RESET)
millions thank you sir
VN-PC viewAuthor Commented:
Awesome!!!!
MacleanSystem EngineerCommented:
Not a problem. I would recommend making a full server & AD backup at some stage, so you can implement CU11 as well. It has various bug fixes that could prevent some other issues, but not critical as your problem appears to have been a mix of 1] Resetting OAB virtual directories, and 2] Clearing BITS queue. So CU11 is merely a recommendation. Enjoy the rest of your week.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.