PaperPort 14.5: The operating system is not presently configured to run this application"

I did a clean install of Windows 10 (after a previously working Windows 10 upgrade) and when I reinstalled PaperPort 14.5, I started getting the error "The operating system is not presently configured to run this application".

PaperPort starts normally and works OK but the error always pops up after a few seconds and requires closing the error's dialog box. I did not have this error when I was using PaperPort on my upgraded (from Windows 8.1) Windows 10 system.

Any ideas?

Thanks,
Stan
rosestAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

McKnifeCommented:
This sometimes happens. Sometimes, what is upgraded works better than when installed clean because the setups run differently on the previous OS.
Ask paperport support.
Joe WinogradDeveloperCommented:
Hi Stan,
I haven't seen that particular message with my testing of PaperPort 14.5 on W10, but perhaps some of the tips in my EE article will help:
PaperPort 14 in Windows 10 - A First Look

Also, since you're on 14.5, you should install Patch 1, which fixed numerous bugs. This EE article explains how to get it via a download from the Nuance site at no charge:
How to install the Patch 1 update for PaperPort 14.5

Regards, Joe
rosestAuthor Commented:
Joe,

I should have mentioned that I immediately installed patch 1 after installing PP 14.5. BTW, thanks for posting how to find PP 14.5. The update manager for PaperPort 14.0 hadn't identified that as an available update and I only stumbled on your post in looking for a solution for this error. But, the error started when I installed PP 14.0 in the Windows 10 clean installation and continued with PP 14.5, patch 1. Running the Scanner Connection Tool made no difference.

I also tried doing an uninstall of PP and a reinstall, setting the installer to operate in Win 8 compatibility mode, but I am still getting the error.

Since the error doesn't pop up for 5 to 10 seconds after PP starts, I tried watching Windows Task Manager to see if I could tell what was starting around that time. It is always "PaperPort 32Bits Outlook Mailer Support Com Objeect (32 bit)". It has a process name of PPMAIL~1.EXE and a command line of
"C:\Prograqm Files (x86)\Nuance\PaperPort\PPMailerOutlook.exe" -Embedding

I doesn't seem to matter whether Outlook (2016) is running or not; the error still pops up.

I now see that I don't have an email option on the Send To bar and I believe that is because I am running Office 2016 which came out after the release date of PP14.5 and its Patch 1 (12-Jun-2015). However, since PP looks in c:\windows\win.ini for a line MAPI=1 to know whether the system uses mail, then finds that the default mail client is Outlook 2016, which it doesn't know about, maybe it gets confused and throws up that error?

I've also found that the error occurs whenever I refresh the Send To bar, so that provides some evidence that this is the problem.

Stan
HTML5 and CSS3 Fundamentals

Build a website from the ground up by first learning the fundamentals of HTML5 and CSS3, the two popular programming languages used to present content online. HTML deals with fonts, colors, graphics, and hyperlinks, while CSS describes how HTML elements are to be displayed.

Joe WinogradDeveloperCommented:
Hi Stan,
I'm glad to hear that my article on the free upgrade to PP14.5 was helpful for you. Also glad to hear that you're on Patch 1 and good to know that you already tried the Scanner Connection Tool. Sad to know that none of this has helped.

That's excellent diagnosis on the Outlook process! There are clearly many problems using PP14 with Office 2016. Maybe you've discovered another one. The ones I ran into are documented in this EE article:
PaperPort 14 with Office 2016/Office 365 - A First Look

One obvious question: Is your Office 2016 32-bit or 64-bit? If it is 64-bit, then it should be running:
c:\Program Files (x86)\Nuance\PaperPort\PPMailerOutlook64.exe
not:
c:\Program Files (x86)\Nuance\PaperPort\PPMailerOutlook.exe
But even if it's running the correct PPMailerOutlook for your bit-level, it could still be a PP14/Office2016 integration bug.

> then finds that the default mail client is Outlook 2016, which it doesn't know about, maybe it gets confused and throws up that error?

Yes, very possible.

> I've also found that the error occurs whenever I refresh the Send To bar, so that provides some evidence that this is the problem.

Agreed!

Regards, Joe

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rosestAuthor Commented:
Joe,

I am running 32 bit Office; I've read that most Office add-on's don't work well with the 64 bit version. Or, at least they used to not work well, maybe that's out-of-date information. ;-)

I'm not seeing icons for any of the other Office apps, either, which you say you did see. Was your test on a system that previously had Office 2013? Maybe that makes a difference. Since Outlook was working on my previous upgraded Win 8.1 -> Win 10 system, which had been originally running Office 2013 before upgrading that to Office 2016, I believe that impacts how it works.

I submitted a bug about this yesterday to Nuance and received their canned response:
- Your bug report will be reviewed for reproducibility
- Bugs reported will be triaged for fixing in a future update or version release of the product
- No response will be provided regarding your bug report
- If you require a response from Nuance, please open a new question and select a Support category
- Support categories include: Error Message, Hardware - Setup/Config, How to use Product, Product - Problem/Issue, Product - Setup/Config

I'm not sure what they mean to resubmit it in a different category. I submitted it in the "bug" category which certainly seems to me to be one in which I would want a response!

Stan
Joe WinogradDeveloperCommented:
Hi Stan,

> I'm not seeing icons for any of the other Office apps, either, which you say you did see.

No, no! You read that wrong. Look at my article again. It says, "However, the Send To Bar on the system with the Office 2016 applications (installed as part of the Office 365 subscription) has only the Outlook icon on it — Excel, PowerPoint, and Word are all missing!"

> Was your test on a system that previously had Office 2013?

No.

> I'm not sure what they mean to resubmit it in a different category.

What they mean is that they don't provide a response on bug reports — they just enter them into the system. If you want a response from Nuance, you need to pick one of the other categories.

> I submitted it in the "bug" category which certainly seems to me to be one in which I would want a response!

Yes, it would seem that a response is in order, but that's not the way Nuance does it — and at least they tell you that. But I agree with you — a bug report should certainly get a response. Regards, Joe
rosestAuthor Commented:
I resubmitted it in the Problem Category and received a response that PP does not support Office 2016 and referred me to this article:


Microsoft Office 2016 support for Nuance PDF products
Answer ID 17956   |    Published 09/29/2015 10:05 AM   |    Updated 12/04/2015 10:16 AM
Microsoft Office 2016 support for Nuance PDF products

Summary:

Microsoft Corporation has released Microsoft Office 2016. Nuance PDF products are known for supporting previous Microsoft Office products.

Information:

Nuance PDF products support Microsoft Office, however, Office 2016 is currently not supported with any Nuance PDF product.

I wonder if and when they will support it?

Stan
Joe WinogradDeveloperCommented:
Stan,

> I wonder if and when they will support it?

I don't know. I'm fortunate to have some good contacts at Nuance Technical Support due to my heavy involvement in the PaperPort community (I'm an Owner of a PaperPort Wiki, PaperPort Google Group, and PaperPort Yahoo Group). So I sent an email about the problem of PP14.5 with Office 2016 directly to my Nuance contacts on 9-Dec-2015. Unfortunately, there's been no response yet. If and when I hear back, I'll let you know. Regards, Joe
rosestAuthor Commented:
Thanks,
Stan
rosestAuthor Commented:
Joe,

I don't know what happened, but in the last week sometime, the error went away and Outlook 2016 appeared in the Send To Bar! I can't think of anything I did or anything related that I just installed. There weren't any patches for PP (unless they were extremely silent!), but, I won't complain.

Does it now work for you?
Joe WinogradDeveloperCommented:
> Does it now work for you?

Outlook 2016 always appeared on the Send To Bar for me — it's all of the other Office 2016 modules that are missing, as I mentioned in post https:#a41456548 earlier.

Btw, sorry I missed this when you sent it a few months ago. I either didn't get the notification from EE or it got buried in an avalanche of email. I was just reviewing some old, open questions and came across this one. I think we're done with this thread, so please close the question when you get a chance. Thanks, Joe
rosestAuthor Commented:
With Joe's help, this is now working for me.
Joe WinogradDeveloperCommented:
Thanks, Stan — much appreciated! Regards, Joe
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.