Exchange 2010 adding 2 signature blocks

Harold
Harold used Ask the Experts™
on
This is happening in random email addresses, but Exchange or something is adding 2 signature blocks to the initial out going mail. I've checked the Transport Rule and nothing has change, that I see. Our internal users use Outlook and Exchange webmail.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Possible culprits:
* Signatures set up by end-users
* 3rd party software

Run get-transportagent in PowerShell to check what applications process your emails.
Scott CSenior Engineer
Commented:
Look for a program called Exclaimer or CodeTwo.

Both of those are popular signature creators for Exchange.
HaroldNetwork Engineer

Author

Commented:
Adam: There are no local signatures setup and we use no 3rd party apps.
Scott: trying to stop dual sig blocks applied to out going messages. Not trying to setup sig blocks.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Are the 2 signature blocks identical? Have you checked headers of problem emails for irregularities?

In any case I recommend running get-transportagent just to eliminate any forgotten rogue apps :)
HaroldNetwork Engineer

Author

Commented:
Adam: there are more sig blocks but the one assigned to this user, is the same as many other users.

get-transportagent, is there more switches to through on this command or just get-transportagent?
Scott CSenior Engineer

Commented:
LOL.  I know you are trying to stop dual blocks.  I was just pointing out two programs that MIGHT be causing your issue.
The reason I'm asking if they're identical is to rule out some sort of loop where a transport rule adds a signature twice instead of 1 time.

@get-transportagent
No switches, just the command - the list of transport agents typically isn't very long.
Scott CSenior Engineer

Commented:
Get-Transport agent....just that.  No additional switches needed.
HaroldNetwork Engineer

Author

Commented:
This is what I get back.....

[PS] C:\Windows\system32>get-transportagent

Identity                                           Enabled         Priority
--------                                           -------         --------
Transport Rule Agent                               True            1
Text Messaging Routing Agent                       True            2
Text Messaging Delivery Agent                      True            3


[PS] C:\Windows\system32>get-transportagent
HaroldNetwork Engineer
Commented:
I removed the sig block from sig block group from the users account and logged back in and now it's send a single sig block, not two.
HaroldNetwork Engineer

Author

Commented:
Found the solution by removing the sig block from user profile and added back.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial