Link to home
Create AccountLog in
Avatar of tiffanyhowe2
tiffanyhowe2

asked on

How to disable cache in FireFox 44+ completely?

Here is the situation. I have installed FireFox 44+ AND HttpFox addon ( https://addons.mozilla.org/en-US/firefox/addon/httpfox ) that shows which links are loading by FireFox. Using the addon, I can see that FireFox loading lots of links from the cache. How do I completely disable that caching? Things I did:

1. Running FireFox in Private Mode (never remember history)
2. Set cache to 0 in FireFox settings
3. Set some values using about:config
 a) browser.cache.disk.enable > false
 b)  browser.cache.memory.enable > false
 c)  browser.cache.offline.enable > false
 d) browser.cache.check_doc_frequency > 1

Still I can see 301 redirect caching and others issues using httpfox addon. Googled for a few days, but no any suitable solution found! Help?
SOLUTION
Avatar of Dave Baldwin
Dave Baldwin
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of tiffanyhowe2
tiffanyhowe2

ASKER

I wanted to disable the cache and did what I said above, but noticed the cache thing is not disabled anyway no matter what I'm doing. Though asking experts in here :)
Any way around that except using the other browser? FireFox got millions of plugins and tweaks.
Thanks for the reply by the way!
Other than disabling the cache, are you having a problem?
I use the modify hearers plugin and set there some custom user-agent, but noticed cache entries do not obey the rule and still show the real one. Just an example. Also, I WANT the website to read all pages as if they were a new, not cached.

Is there some place in firefox, where it stores the cached links? As I use private browsing, clear temp files (bleachbit and ccleaner) and can still see the cached messages. Tried to flush the DNS as well. May it be some caching on my ISP level you think?
ASKER CERTIFIED SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Did you tried refreshing the pages by holding down the  Ctrl+F5 key or Ctrl+Shift+F5? Reloads (overrides cache)

ref:
https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly

Sudeep
Does not helps in my case. As I told you, I have installed httpfox plugin and I can see many pages are loaded from cache, even if I had disabled it completely.
Moreover, I tried to download FireFox Portable and add this httpfox plugin only. I can see pages I never visited are shown and loaded from cache too!!! How it could be? Again, what do I do to force firefox to load every single link it loads and completely forget the cache thing?
I don't believe that you can.
But how come httpfox is showing me the cached link of www.google.com if FireFox never accessed it before?
Probably because Firefox "phones home" to Google to see if the current page is on the 'bad' list.  They have a long standing agreement to do that.  There are other background connections that Firefox makes and you don't see.