troubleshooting Question

Linux Script Issue

Avatar of acubedec15
acubedec15 asked on
Linux
3 Comments1 Solution64 ViewsLast Modified:
I have  an error when I run the following command from a UNIX utility server, Our UNIX utility server has keys set up so we can run command on all UNIX/Linux servers in the environment.

Here is the error

# ssh linuxcna 'su - tadm -c "/etc/init.d/tmgr start"'
runuser: cannot set groups: Operation not permitted
[FAILED]

Now if I log into linuxcna and run the command, I still get an error :
# su - tadm -c "/etc/init.d/tmgr start"
runuser: cannot set groups: Operation not permitted
                                                                      [FAILED]

I also have the right permissions on /bin/su
# ls -l /bin/su
-rwsr-xr-x. 1 root root 32204 Oct 29 10:23 /bin/su

Any suggestions..
ASKER CERTIFIED SOLUTION
nociSoftware Engineer
Join our community to see this answer!
Unlock 1 Answer and 3 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 3 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros