WS-FTP unable to connect to server after software update

I have a bit of an authentication problem. I updated some packages on my Slackware64 14.1 system yesterday. Today, when a client was trying to WS-FTP to his account, he was blocked. The WS-FTP log is below. I've tried restarting openSSH. I can ssh to this account, but the client cannot WS-FTP. I'm sure it has something to do with the update, but I don't have any idea where to look. Need help
KexInitPacket (Client):  no kex guess present
KexAlgorithms
diffie-hellman-group-exchange-sha1,diffie-hellman-group1-sha1
00:  diffie-hellman-group-exchange-sha1
01:  diffie-hellman-group1-sha1
.
.
.
Failure to agree with SSH server on compatible algorithms
SSH Transport agreed algorithms
     Purpose: key agreement             Algo: invalid
     Purpose: server host key           Algo: ssh-rsa
     Purpose: encryption cs             Algo: aes128-ctr
     Purpose: encryption sc             Algo: aes128-ctr
     Purpose: MAC cs                    Algo: hmac-sha1
     Purpose: MAC sc                    Algo: hmac-sha1
     Purpose: compression cs            Algo: none
     Purpose: compression sc            Algo: none
Failed SSH Key Exchange
SSH Transport closed.

Open in new window

LVL 1
MarkAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave BaldwinFixer of ProblemsCommented:
It appears he needs to update WS-FTP.  Or try Filezilla, it is usually very current.
https://filezilla-project.org/

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MarkAuthor Commented:
Hmmm, I'm probably not going to get them to do that. Is there a way to change something on my end?
Dave BaldwinFixer of ProblemsCommented:
I think you need more info.  What FTP client works form your computer?  Have you tried WS-FTP on your computer?  Note that older algorithms and methods are being 'expired' all over the web.  They may not have a choice.
Exploring SharePoint 2016

Explore SharePoint 2016, the web-based, collaborative platform that integrates with Microsoft Office to provide intranets, secure document management, and collaboration so you can develop your online and offline capabilities.

MarkAuthor Commented:
Dave Baldwin:
older algorithms and methods are being 'expired' all over the web.
Yes, I know, I've run into this before. I've asked the fellow to check on updating his WS-FTP.

I am able to sftp from a remote linux host, no problem. I don't have access to WS-FTP.

I'm wondering if I can somehow specify an older encryption mechanism in a configuration on my Linux server.
Dave BaldwinFixer of ProblemsCommented:
I don't know.  Please click on "Request Attention" above and see if someone else knows.
MarkAuthor Commented:
The user updated his WS-FTP. Problem solved.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.