Link to home
Start Free TrialLog in
Avatar of PeraHoman
PeraHoman

asked on

passive-interface commands on OSPF

How does passive-interface command work for VLANs?

passive-interface default
no passive-interface VLAN 10

To start:
Do all interfaces (physical OR logical) that have VLAN as an access or trunk participate in OSPF?
Avatar of PeraHoman
PeraHoman

ASKER

Use this example

sw1
router ospf 10
passive-interface default
no passive-interface vlan 20
network 10.102.21.28 0.0.0.3 area 0

interface vlan 20
ip address 10.102.21.29 255.255.255.252

interface GigabitEthernet2/1/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 20,31
 switchport mode trunk
 switchport nonegotiate
 spanning-tree portfast trunk
 channel-group 1 mode on
end


interface GigabitEthernet1/1/1
 description NMCIUMDF1-AC1-SW01 Gi1/1/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 20,31
 switchport mode trunk
 switchport nonegotiate
 channel-group 1 mode on
end

interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 20,31
 switchport mode trunk
 switchport nonegotiate
end





sw2
router ospf 10
passive-interface default
no passive-interface vlan 20
network 10.102.21.28 0.0.0.3 area 0

interface vlan 20
ip address 10.102.21.30 255.255.255.252

interface GigabitEthernet2/1/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 20,31
 switchport mode trunk
 switchport nonegotiate
 spanning-tree portfast trunk
 channel-group 1 mode on
end


interface GigabitEthernet1/1/1
 description NMCIUMDF1-AC1-SW01 Gi1/1/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 20,31
 switchport mode trunk
 switchport nonegotiate
 channel-group 1 mode on
end

interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 20,31
 switchport mode trunk
 switchport nonegotiate
end




Pretty much a port channel between two switches with ospf no passive interface on vlan 20.  What's happening here when the physical interfaces are passive, but they have vlan 20 as non-passive?
Continuing from this, what is the purpose of running a L2 Etherchannel between them and along with a SVI (VLAN 20)?  This is a collapse core.
ASKER CERTIFIED SOLUTION
Avatar of Predrag Jovic
Predrag Jovic
Flag of Poland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial