MS Word Form Creation - Responders Can't Enter Text

cbridgman
cbridgman used Ask the Experts™
on
I have created a survey form in MS Word 2013 that will be used by students to rate a class that they take. I've used Active X controls (option buttons) for the ratings (e.g., great, good, bad, awful) and a rich text content control for students to put comments in. When I take the form out of Design mode, all of the option buttons work as they should and the rich text control works properly. When I set editing restrictions to filling in forms via the Restrict Editing option, however, responders, while still able to choose options, are then unable to enter anything into the rich text control (question 5 on the form).

I do want to protect the document so that responders can not modify anything on it but I do want them to be able to answer the questions, including the text question.

Can someone help me with this?

I've attached a sample copy of the survey (not restricted). It is attached as a docx file because that is all that EE will accept. It is actually a .docm file.
Training-Survey.docx
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Christopher Jay WolffWiggle My Legs, Owner

Commented:
Cannot open the file.  Word says no details available on error.

Used Word 2013 to create this docm that is attached.


did you double check your settings?

Here is my screen with the Restrict Editing button selected and the properties dialogue box open for the current selection of my Plain Text Content Control.

I've read you get editing control with Plain Text Content Control, and that there is no control on Rich Text Content Control.  However, mine seems to work with minimal testing as the dialogue boxes allow.  Please check the properites dialogue box when your Rich Text Content Control is the selection to view differences.

Word 2013 Plain Text Content Control.This-is-a-form.dotx

Author

Commented:
I checked my document and it was pretty much the same as yours. I've attached another file that shows how I am still unable to enter text in the field. Steps that I took follow:

Turn on Design Mode
Add Rich Text Content Control to form.
Set Content Control Properties according to your screen print
Turn off Design Mode
Restrict Editing according to your screen print
Save the Document
Close the Document
Open the Document
Attempt to type in the Rich Text field. Doesn't work.

Any other ideas? Am I missing something? Try saving the doc after you turn on Editing Restrictions, closing it, and then reopening.
Christopher Jay WolffWiggle My Legs, Owner

Commented:
Hi.  Forgot to attach.  :-)  You're not the only one.

That's really strange.  Mine works.  I know it is possible you may have a corrupted file from messing around with it for a while.  But before going through all work below, just try reboot and relaunch Word and start a brand new minimal file to test very simply.  If no go try holding down Cntl key and launch Word.  It will give a dialogue box confirming launching in safe mode.  If no go, try a different computer with same software if at work where you are able to do that.  I would also delete all browsing history and cache and things like in IEE under Internet Options.  And try Word while not connected to internet.

I would definitely try refreshing anything you can think of like rebooting (I'm sure you already did this), emptying cache.  The link below probably applies to learn how temp and cache files are stored.  Includes your registry files. Check link below to clean house a little.  Haven't found one for 2013 or newer but most probably applies.  BTW, what version of Word are you using?
https://support.microsoft.com/en-us/kb/211632


For what its worth, here are my steps I wrote down as I did it from scratch.  It works for me.  I don't think you need these steps but I'm just double-checking.  Since mine works as far as entering text,  The Rich Control is supposed to allow me bold and different fonts and colors but does not.  Haven't messed with why.  Another reason is since it is survey, maybe just use Plain Text Control.  I was thinking your file is  corrupt.



------------------------------------------
open new blank doc
save as word template file for now .dotx
developer tab
design mode

In the document, enter some text that says "Rich Content" hit Enter to go one line below
click Rich Text Content Control icon in ribbon to insert control
move cursor to end of newly inserted control and hit enter to go a line or two below the new control


There in the document, enter some text that says "Plain Content" and hit Enter to go one line below
Click Plain Text Content Control icon in ribbon to insert control


Click Rich Content Control by handle and click properties in ribbon right below "design mode" (or right-click handle and properties
In Properties check the box to turn on Content Control cannot be deleted
Make sure box remains unchecked that says Contents cannot be edited
click ok

select Plain Text Content Control by handle and click properties in ribbon
In Properties check the box to turn on Content Control cannot be deleted
Make sure box remains unchecked that says Contents cannot be edited
Also check the box that says Allow Carriage Returns

Click the Retrict Editing button in the ribbon
In the right panel "Restrict Editing" under "2" check the box to "Allow only this type of editing..."
Also under "2" change the pull down to "Filling in Forms"

*******************************************************************
maybe try skipping this part to see if it will start working
Take document out of Design Mode by clicking Design Mode in ribbon
Now in the right panel "Restrict Editing" the "3" is not dimmed and check box to start enforcing restrictions
enter pw twice
ok
******************************************************************

save, close, open, enter text
OWASP Proactive Controls

Learn the most important control and control categories that every architect and developer should include in their projects.

Christopher Jay WolffWiggle My Legs, Owner

Commented:
Also wondered.

When you select the little content control handle where I marked it in blue, hit the delete key, do you get the message I circled in blue?

It says, "This modification is not allowed because the selection is locked."

 But mine will allow edit.  Or what message do you get there when try to edit or delete?

bad photo.  No screen grab for that message.

Word 2013 content control delete message.
Christopher Jay WolffWiggle My Legs, Owner

Commented:

Author

Commented:
I believe I have found what is causing the problem. It had to do with my MS Word Start up options. I chose to open e-mail attachments and other files in reading view. After turning that switch off, and going through the protection process again. All was good. I'm now able to fill out the entire form.

There is one remaining item though. When a form recipient opens the form on their own PC, it would be nice if the ribbon would not appear. I know that users can hide the ribbon but I'd really like it if the ribbon were hidden by default for the form.

Any suggestions on this?

Author

Commented:
By the way, sorry I didn't respond sooner to your posts. I came down with the flu and stayed away from work for a couple of days.

Author

Commented:
One other thing, I'd also like the menu bar to be hidden when users open the form. Is that, together with having the ribbon collapsed by default, a possibility?

Author

Commented:
I continue to make progress but I'm not quite there yet. I have figured out how to hide the ribbon, the menu, and the ruler so now the form appears just the way I want it when it is opened. It's just the form itself without any ribbons, menus, or rulers. However, it appears that all of those settings are global. Any document that I open or create now starts out with the ribbon, menu, and rulers hidden. I only want those items hidden when the form is opened.

Is there a way to do that?
Christopher Jay WolffWiggle My Legs, Owner

Commented:
Did you use VB?

You might be able to do this with PS.  Set up Word to look the way you want, launch form, when user closes, reset Word back to the way it was.  I'll look into it.  If you beat me to it, please let me know.

Glad your health is back!!
Wiggle My Legs, Owner
Commented:
After taking a quick look before I have to go back to work I found a few ideas.

older versions of Word use a xml file to keep word settings.  I found this at msdn and the file is in Users\...\appdata\local\Microsoft\office

and the filename is Word.officeUI

Mine is Word 2013 and my disk does not have that file.  In the same location I have a file called WINWORD.EXE_rules.xml which you can view and edit with notepad.  I don't think it holds the information you want but I looked fast.

If it were me, I would launch Powershell script to edit Registry key settings for word according to this starter link about it here from Microsoft.
https://support.microsoft.com/en-us/kb/822005

The top-level registry locations for different versions of Word are at the bottom.  Once form is complete, powershell could change settings back to original.

Author

Commented:
I actually decided not to go the VB route. I kind of ran short on time. I do appreciate your help though. The form is work as I want it to. I just can't force the ribbon to hide itself.
Christopher Jay WolffWiggle My Legs, Owner

Commented:
Thanks for the points, but I didn't do much.  :-\  

Was working on a powershell solution for you and got hacked a couple days ago.  Did refresh of win8.1 and things are strange.  Seem to be calming down some.  Thought I'd let you know.  After the last two days of recovery I'm a little worn on computers, but if I can get back to the powershell solution for ribbon I'll post here again.  I'm not positive I can do it, but I'd like to try.  If no post then I didn't do it.

Fun forms to you.

Author

Commented:
Thanks a lot

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial