UAC Issues

How can I modify UAC behavior in Windows 2012 R2 Remote Desktop Services to allow SAGE 100 2016 accounting application to run as a published application.  Sage must run as an Administrator which then generates the UAC prompts.  I don't want to give Local Administrator rights to regular users.  

I tried disabling UAC in the registry editor with the "EnableLUA" key but once disabled the Sage application failed to load.  With UAC disabled, Sage fails to load and appears it no longer launches as an Admin despite that option still being set.

Thanks,

Jeff
camusa2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zac HarrisSystems Administrator Commented:
Just give the users "Full" access to the directories used by the software. This is done by right-clicking the folder(s) and clicking Properties then the security tab.
You can either create a local group and add all the users to that and then add the group to the security tab or add the users individually to the security tab.
Even better is if you are on a domain, you can create a group to be pushed down to the workstations, put all the users in the group and then add that group to the security tab.
You can set a GPO to push the group with the domain members to each workstation that's needed.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
camusa2Author Commented:
Zac, I gave a user Full permissions to the c:\Sage directory structure but still they get prompted for UAC login when attempting to launch the application as seen in the attached screen shot.

Even by making them local administrators they still get prompted to login at the UAC prompt.  This may be something unique to RDS and published applications.
camusa2Author Commented:
Follow up.  I had re-enabled UAC before testing the full permissions to the C:\Sage directory structure.   I disabled UAC a second time, now Sage is launching successfully by providing users full permission to the folder structure.  As an RDS server with quite a few users accessing it, it would be nice to have UAC turned on so if there are any other thoughts on how this could be accomplished it would be appreciated.
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Zac HarrisSystems Administrator Commented:
Did you mean to attach a screenshot?

The UAC is doing what it's supposed to do. If the user is not an administrator they will be prompted. There are ways to change the behavior of the UAC in the Local Group Policy of the machine. You can play around with those settings to see if any of them accomplish what you are trying to do. (See attachment)

UAC LGPO
camusa2Author Commented:
Zac, I had played around with the UAC policy controls but couldn't find anything that would affect a regular user.    Sorry, I thought I had attached the image.  It's just a screen shot of the UAC prompt you receive when opening a published application that requires admin rights.

 UAC.jpg
Zac HarrisSystems Administrator Commented:
The UAC is designed to keep non-admins/those without admin rights from making changes to the system and executing things with admin privilege.

Besides totally turning off the UAC, there is no way to "suppress" the prompts for certain things. That kind of defeats the purpose of the UAC. There is no "Allowed-and-Blocked" list as in the firewall.
camusa2Author Commented:
Thanks Zac.  I was hoping there was a way to get around this without disabling UAC but doesn't sound like it will be possible.  In googling this issue I found quite a few folks upset with Sage's requirement to run the application with Admin rights and sounds like a less than well written application.    Thanks for your help, I will run with UAC turned off.
Zac HarrisSystems Administrator Commented:
Glad I could help you. Unfortunately some developers put requirements on the software sometimes for good reason and sometimes because they are lazy.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Application Servers

From novice to tech pro — start learning today.