Link to home
Create AccountLog in
Avatar of davidrobertbristow
davidrobertbristow

asked on

Webdav server error 405 using iannotate on ipad

Hi experts,

I have webdav setup on a IIS 7.5 server.  From a web browser on a PC, I can go to http://webdav.castlegar.ca/paperless_meetings and after signing in with a valid username and password then I can browse folders, open docs, etc.  Our elected officials use Branchfire IAnnote on ipads.  It uses a webdav connector.  When I plug in the correct information for the webdav connection then connect, I get "server error 405".  I know that I am entering the webdav information correctly because I can connect to a webdav service running on an older windows 2003 server.  I am trying to migrate the webdav service to a windows 2008 R2 server.  Can you help me? Thanks.
Avatar of Dan McFadden
Dan McFadden
Flag of United States of America image

The 405 error indicates that the method sent in the http request (GET, POST, HEAD, etc.) is not allowed based on the configuration of the site.

Can you post the http logs for the site so we can see the method that is being requested?

Also, on the directory/folder that is webDAV enabled... in IIS Manager, select that dir, in the center features area, open "Handler Mappings" and edit the WebDAV handler.  Can you post a screen shot of the "Request Restrictions - VERB" tab?

Dan
Avatar of davidrobertbristow
davidrobertbristow

ASKER

Hi Dan,

Thanks for your feedback.  I've attached a screenshot of the verb tab.  Where do I go to get the http logs?  

Thanks,

David
verb-tab.jpg
For the IIS logs, go into IIS Manager, go to the web site with the issue, open the Logging feature.  There you will find a Log File section with a directory field.  That's where the logs are.  If you have more than 1 site in IIS, you will need to know the site ID (click on sites, its the column labeled ID) to find the logs.  The directory  that contains the site's log files is named W3SVC+[SiteID}].  So if your site is the Default Web Site, its log directory is W3SVC1.

You could also, as a test, switch the verb setting to all and see if that works.  But I'd only do this as a test.

Dan
I will get back to you shortly as I need to drive into work now.
Hi Dan,

The webdav virtual directory that I setup is under the default website (see attached screenshot).  I found the http logs for the default website and have attached the most recent log file.  Looking through it for the webdav virtual directory "paperless_meetings" I found the section where the ipad logs in as user "paperless_agenda".  Below is that section of the log.

2016-02-25 00:50:22 192.168.3.33 GET /paperless_meetings/ - 80 CITY\paperless_agendas 162.245.240.138 Mozilla/5.0+(Windows+NT+10.0;+WOW64)+AppleWebKit/537.36+(KHTML,+like+Gecko)+Chrome/48.0.2564.116+Safari/537.36 405 0 0 62
2016-02-25 00:50:22 192.168.3.33 GET /favicon.ico - 80 - 162.245.240.138 Mozilla/5.0+(Windows+NT+10.0;+WOW64)+AppleWebKit/537.36+(KHTML,+like+Gecko)+Chrome/48.0.2564.116+Safari/537.36 404 0 2 62

Thanks,

David
u_ex160225.log
paperless_meetings-virtual-directory.JPG
Ok, the iPad is sending a GET request, which is not a verb that is listed in the WebDAV allowed verbs list.  You could add GET to the list and retry.

Dan
I added get to the list of verbs (see attached screenshot) then restarted the WWW service.  I still get the same error (405).

Thanks,

David
Get-added-to-verbs.JPG
I suggest clearing the browser cache on the iPad.

If the issue persists, then I would test the "All Verbs" option.

Dan
I set it to "All Verbs" but it still doesn't work.  I can browse the webdav directory with a web browser but not the IAnnotate app.  I've emailed Branchfire (the app maker) tech support and have tried all of their settings.  Thanks.
I'm going to use a cloud storage solution (google drive) for viewing pdf documents (council agendas) for staff since I can't figure out how to get webdav working.  Thank you for your help.
ASKER CERTIFIED SOLUTION
Avatar of Dan McFadden
Dan McFadden
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account