MAC Network printer

AXISHK
AXISHK used Ask the Experts™
on
My network printer use IP 192.16.100.40 with port number 9100 under Window setup for printer. Where can I setup the port in MAC ?

I have tried both 192.16.100.40  OR 192.16.100.40:9100 but it still fails. Any idea ? Is it related to firewall issue ?

Thx
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
When you add it by ip, what protocol do you select? HP Jetdirect socket should work, since it has the correct settings for your printer
bbaoIT Consultant
Commented:
port 9100 is normally for IPP, so you may simply choose IPP for the Protocol field.

Author

Commented:
The network printer is Canon. Should I select HP JetDirect ?

Thx
Angular Fundamentals

Learn the fundamentals of Angular 2, a JavaScript framework for developing dynamic single page applications.

You can easily choose hp jetdirect for a canon printer, as long as the network port is standard (port 9100), IPP is port 631
There should be no need to use a JetDirect. If the printer bis a low cost one, it may not work anyway.

You can add the printer as an IP printer, using LPD instead of port 9100, as follows:

Open System Preferences > Print & Fax
Click "+" under Printers list
In the Add Printer window click IP
Leave protocol set as LPD
Type the printer's IP in the Address field
In the Name field type printer manufacturer/model
Print Using field should be filled in by default when printer is found
Click Add

Assuming the printer supports PostScript, if the Mac cannot find the printer when you type in the model, you should be able to install the PPD for the printer and point the Mac at that. If the printer is a low-cost one, which does not support PostScript, you may have to do other things as well. What model is it?
I did not mean a jetdirect device, only using the hp jetdirect socket.
Sorry, I overlooked that. However, Macs prefer LPD.
Computer Consultant (Desktop analyst)
Commented:
Which model is the printer specifically?  Have you checked to make sure it is compatible with Macs?   Have you downloaded the recommended drivers (if any) from the company's website?

As to the port, setting it directly should not be necessary.  

Go the System Preferences and select Printers & Scanners:

1.

choose the recommended printing protocol (Bonjour, LPD, ...)

2.

put in the address of the printer if required

3.

select the driver if one pops up or choose it manually (might have to use "generic")

4.

click Add

Author

Commented:
The user will come back to the office after 1 month. Will post my problem again if needed .  Thx

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial